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Learning Objectives

» Explore Robot Structural Analysis software’s key features and capabilities

» Learn how to use the different project types and layouts built into Robot Structural
Analysis

» Learn how to implement best practices for deploying Robot Structural Analysis
within a structural engineering office

» Learn how to use the capabilities of the Robot Structural Analysis, Revit, and
Advance Steel interoperability

Description

This lab will use straightforward practical examples to teach best practices to new users of
Robot Structural Analysis software. The lab is intended for those who have an understanding of
structural analysis but are new to Robot Structural Analysis. It will introduce the basic
functionality of Robot Structural Analysis, key features, and best office practices for teams
working in Robot Structural Analysis. Topics will include, but are not limited to, concrete design,
steel design, and composite deck design. Additional topics will address loadings and key
strategies for collaboration between Robot Structural Analysis and other Autodesk applications,
such as Revit software and Advance Steel software.

Speaker(s)

Garrett Shahan is a Graduate Engineer at IKERD Consulting, an internationally recognized
consulting group in buildings, civil, and industrial construction markets specializing in using
Building Information Modeling (BIM)-enabled Virtual Design and Construction (VDC). During his
time at IKERD, he has been involved in a variety of projects involving engineering design and
modeling, reality capture, software training, and BIM coordination. He has utilized and taught
Autodesk products including but not limited to Revit, Robot, Advance Steel, Inventor, ReCap,
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and Navisworks for projects ranging from residential houses to multi-million square feet sport
facilities.

Will Ikerd—PE, CM-BIM, LEED AP—is principal at IKERD Consulting, an internationally
recognized consulting group in buildings, civil, and industrial construction markets specializing in
using Building Information Modeling (BIM)-enabled Virtual Design and Construction (VDC). He
serves as an expert consultant in design and construction cases involving BIM and VDC
processes. Currently, he is on the board of directors of the national BIM Forum, and he was
past chair of the Structural Engineering Institute’s national BIM Committee. He has won the Best
Speaker award twice from the International Structures conference, and he was named
Structural Engineering magazine’s “Top 10 Leaders in Structural Engineering,” Glass
Magazine’s “Top 30 under 40,” and Building Design & Construction magazine’s “Top 40 Under
40.” He has served as PCI’s BIM consultant in that industry’s innovation initiatives.
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Autodesk Robot Structural Analysis Professional 2020

1.0 Three Coordinates

Because we will be working in Revit, it is important to understand coordinates in Revit. There
are three coordinates or origins that are relevant to working with Revit:

1.1 Revit’s System Origin

With a Revit project open in a plan view, type “RH” or click the “Reveal Hidden Elements” button at the
bottom left of the view window. This will reveal the location of both Revit's System Origin and the Project
Base Point. If using a template, these items should appear near the center of the default elevation view
locations.

Revit’s System Origin cannot be moved. It serves as a constant reference point across all Revit projects.

1.2 Project Base Point

The Project Base Point is an automatically generated reference point like Revit's System Origin,
but the Project Base Point may be moved like any other hidden element. This can be helpful if
all trades wish to coordinate a uniform base point other than Revit's System Origin, but it is not
designed to provide coordination across different software.

At any time, you can right-click the Project Base Point and select “Move to Startup Location” to
reset the Project Base Point to Revit's System Origin.

The Project Base Point is “clipped” by default, which means that moving the base point will also
move the other elements of the project with it. To move the Project Base Point independent of
the other project elements, you can click the paperclip icon to toggle its clipping on or off.

1.3 Working Origin

It is often helpful to establish an origin for your project in addition to these two other origins
provided by Revit. This working origin can be created and placed by the user to avoid certain
complications such as drawing in negative space. Although the placement of this Working Origin
is arbitrary, it is often helpful to place it at a sufficiently positive location relative to the Project
Base Point so that no part of the drawing will be placed in negative space. For simplicity, we will
use 100, 100’, 100’

1. Expose Revit's System Origin and the Project Base Point (Figure 1)
a. Create a new Revit project using the structural template.
b. Open the Level 1 view
c. Type “RH” or click the “Reveal Hidden Elements” button on the bottom left of the
view window to expose Revit's System Origin and the Project Base Point.
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Figure 1 Exposing the Origin

2. Mark the X and Y grids based on the Project Origin (Figure 2)
a. On the Architecture tab, on the Datum panel, click the Grid icon, or type “GR.”
Draw a horizontal and a vertical gridline each intersecting the Project Base Point.
b. Type “RH” or click the “Close Reveal Hidden Elements” button to toggle off

hidden elements.
c. Change the grid name of the horizontal grid to "XXX" and change the grid name

of the vertical grid to "YYY".
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Figure 2 Gridlines

3. ltis helpful to mark the Project Base Point with a set of model lines. The exact design is
somewhat arbitrary, but the following instructions yield one helpful design (Figure 3):

a. On the architecture tab, on the Model panel, select Model Line, or type “LI". Draw
a model line from the Project Base Point (now marked by the intersection of your
gridlines) to the east 10’ and a model line from the Project Base Point to the
north 10’.

b. Create a circle that starts at the origin and is 5’ in diameter.

c. Create a line from the intersection of the horizontal model line and the circle to
the intersection of the vertical model line and the circle.
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Figure 3 origin icon

d. On the View tab, on the Create panel, select the Framing Elevation in the
Elevation drop down.

e. Select the "XXX” gridline to create the Framing Elevation, then click the Escape
button on your keyboard.

f.  Open the new elevation view by double clicking on the elevation tag.

g. Inthe structure tab select the model line on the Model panel, select Model Line.

h. Draw a 10’ model line along the "YYY” gridline upward from Level 1 (Figure 4).

4. Create a new 3D view from the quick access toolbar to view the 3D origin (Figure 5).

Page 6



{/\ AUTODESK.
UNIVERSITY

REPHG K-2-88-FOA G-0E NG -~ i pe M5y B e ‘W @ _8X
I Achieciore  Stuctre  Siesl  Systems  bnset  Annotste  Anshge  Massing & St Collsborate  View Mansge  Add-ns  Quaniification  Site Designer  LODManager Moy | Flace Lnes  Precest (D)=
b Sl =115 i BIOEO Iy s
oty [ Seu - =~ — = BB L | . w0 -
vt B g - g4 PBEO T aax SO o5k
Mody | Place Lines Placement Plane, Grd 000 Flchai Offsee 0 0° | [JRadiy: 1 0
v X | Properties x [ a2 [ Leven & oo} A Hevation 18 X ]
New Lines (Lines) B
Constrants.
M With Nearby
Graphics. —
Line Style
Deta
Level 2
\_o- i o_-
a
_
® i
HL
&
Level 1
& 0-0"
Properties help Apply were D WP 8BS ra o« N
VERTICAL AND [Lines : Madel Lines] & ia[EN . TR OTo
Figure 4
RECHG- Q- Q=-70A G-2F 5@ * Autodesk Revit 2019.2 - Not For Resale Version - Project - 30 View: (30) 90 5 7Y R ikerd W @ -&x
I wontecure Srucre Swel Systems  insert Annctate Anshze  Massing & Site  Collsborste  View  Mamage  Addins  Quartficatcn  Site Desgner 10D Manager Modfy Precat (e
=] 3P = grp B
Q) «cWHEND & L8 B O« 0 AR ZEs %7 = i T
odfyl Beam Wl Column Floor Tuss Biace Besm Connection holsted Wall Siab Rebar Ares Path Fabic Cover Rebw Component  Model Model Model, By Shait Well Vertical Dommer Set Show Viewer
2 . System 2 Arsa Coupler g Te Une Group Face
X | Properties X [ Lewi2 5 Lol 1 @ po) X 4 fevation1-a
Ry
fendering Settings Ea
o e
Eye Elevation
Targe: Elevation
ety Duts
View Template
oo N %
—-:n.u)w.‘ﬂ
Phasing
Phace Fiter Show A1
Phace New Conruction
Propertes help Aply ward BE « GAKER cBMEIT .
Hold bution and mave mouse to Spin the View. &t fo@A TARENOTPo

Figure 5

Now we will create the Working Origin.

5. Mark the X and Y grids based on the Project Origin (Figure 2)
a. Inthe Level 1 view, select the "YYY" gridline.
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In the modify grids tab, select copy, or type “CO”. Copy the gridline 100’ to the
right (Figure 6).

Change the name of the new gridline to “Y1”.

Select the “XXX” gridline.

Copy the gridline upward 100’ as in step 5b.

Change the name of the new gridline to “X1”.

Extend gridlines “X1” and “Y1” until they intersect (Figure 7). The intersection of
these new gridlines marks our Working Origin at 100’, 100’, 0'.
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Figure 6
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6. Modify levels to indicate the origin at 100’.
a. Open an elevation view
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b. Change the name of the Level 1 level to “ORIGIN”. Click “Yes” if asked to confirm
whether to rename corresponding views in a pop-up dialog box.
Move the Level 2 level so it is 100’ above the “ORIGIN” level.

C.
d. Change the name of the Level 2 level to “LEVEL 01”.
e

. Move your gridlines so they are visible in the “LEVEL 01” view.
f. Create a new level called “LEVEL 02" 10’ above “LEVEL 01”.
7. Mark the new working origin with a symbol of model lines as was done with the Project
Base Point in step 3. Make sure the working origin marker is placed at LEVEL 01 since
that will be the ground level. You may need to make another structural elevation view if

you wish for the working origin to be 3D.
8. Save and close the Revit project.
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2.0 Importing Projects From Revit

1. Open the “Revit to Robot” file in Revit 2020.
2. Go to the Analyze tab. Under the Structural Analysis section, go to Robot
Structural Analysis>Robot Structural Analysis Link.

i1 Integration with Rebot Structural Analysis X

Direction of integration with Autodesk Robot Structural Analysis
(® Send madel
(") Update model

() Update madel and results

Type of integration
(®) Direct integration

() Send to the intermediate file [ smus)

Send options
Help H Cancel
3. Using the default settings of Send model and Direct integration will send the

model contents, grids, and levels over to Robot Structural Analysis Professional
2020. It does not matter what view is used to export as it will send all model
content regardless. Sending the model will also automatically open Robot if it is
not already and open the new export.
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3.0 Starting A Project
E Autodesk Robot Structural Analysis Professions (x|

[ New Project.. |
3

Open Project.. Sealect project

B Neulj
= Open project...

Start a new project by selecting the Frame 3D Design 4. structure type or click
new and select the Frame 3D Design structure type.

3.1 Structural Axis

0@. Structural Axis - X
1. On the right-hand toolbar, select Axis Definition, | "™ _wgnea&m_ —
or use Geometry>Axis Definition. Eoear i Qun_é_ Artony
Advanced parameters
2. On the X tab in the Structural Axis dialogue box, xR
set the number of Repetitions to 1, and the m”“oo e zpmrﬁ_ﬁ.." M M_,msgs_" ®
Distance to 20 feet. Confirm that Position is still e — =
at 0 Feet for the first axis. Set the Numbering to 1 0.00
Define and label the axes Y1 and Y2. Add the N .00 (e
axes. || Delete
Delete all
3. Repeat this on the Y tab by placing axes at both 0 |
ft and 20 ft. Define the axes as X1 and X2. ‘ 5|
Numbering: P23es. v

4. Repeat this one last time on the Z tab by placing

anaxisatOft,1ft6in (1.5 ft),and 11 ft6 % in = Ao
(11.5625 ft). Set the number of Repetitions to 1 | ooty | Close Help

and the Distance to 1.5 feet. Add the axis.
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Change the Distance to 10.0625 feet and Add it. Define the axes as L01, L02,
and L03. Click Apply.

3.2 Adding Sections

= T w 10x33

W 10x33 -

_ American hot rolled shapes (AISC m_

Color: _?:u|<_ Family: w e

H Wide-flange Shapes (W-Shapes)

I Sections — % 'z
|
D ﬁ) V.A. D D H m n_ﬁ u i | section type: Steel ~ | Gamma angle: iﬁomuv
. |

| Material: [ sTERL <]

X DELETE |

[0 Baxis | | Standard  parametric Tapered Compound Specal Ax, Iy, Iz...
_ .

_H_ © 1ag | [variable

L L 4x4x0.25 " % H ﬁ [ HH 4T 9.73 | (in)

! . _ Label: Section selection

T wiox22 | Seion —
1
|
|
|
|
|
|
|

Lines/Bars
M O | Elasto-plastic analysis
Apply Help “ Add Close Help
5. Open the Bar Sections dialogue box on the right-hand et ]
toolbar or expand the layouts drop-down menu and FR Stat
select Sections and Materials. g
| SectionstMaterials |
&= Supports
6. Click New Section Definition. On the Standard tab, set the | S
Database to AISC 15.0, the Family to W, and the Section A e Do
to W10X33. Add the section. Also add the W10X22 and £ RC Desion
L4X4X1/4 sections. Close the New Section dialogue box.
7. Close the Section dialogue box or expand the layouts drop-down menu and
select Start.
3.3 Bar Placement
8. To add bars on the side of the platform, change the view to XZ on axis X1.
YZ
XY
XZ  Y=000R- Structure axis X1 - >_ alv
9. Open the Bars dialogue box on the right-hand toolbar or expand the layouts

drop-down menu and select Bars.
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10.Set the Bar Type to Simple Bar and the Section to W10X33.

11. Draw two W10X33 along axes Y1 and Y2 from axes L02 to L03. Draw a W10X22
on axis L03 from axes Y1 to Y2. The result should resemble the image above.

12.Change the view axis to X2. Add the bars along the same axes for the other side
of the platform.

13.To add the other members on top change the view to XY and Structure axis to
L03. Add the W12X26 and W8X10 sections though the Sections button or the
Sections and Materials view mode.

14.Add the W12X26 bars along axes Y1 and Y2 from X1 to X2.

15.0pen the Structural Axis Definitions dialogue and add axes Y1.3 and Y1.4 in
the X tab at Positions of 3.5" and 14, respectively. Also add axis X1.6 in the Y
tab at the Position of 13.75’.

16.Using the Bars dialogue box add W8X10 bars along Y1.3 and Y1.4 from X1.6 to
X2. Add a W10X22 on axis X1.6 from Y1 to Y2.

17. Open the Nodes A\rv dialogue or the Nodes view mode. Place nodes at the
following locations:
a. 0,4.5833, 11.5625
b. 0, 9.1666, 11.5625
c. 20, 4.5833, 11.5625
d. 20, 9.1666, 11.5625
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18. Pressing the Node Numbers button at the bottom left of the view will make the
nodes visible. With the nodes visible add W10X22 Bars from gridline Y1 to Y2
between the newly created nodes

19. Using the Bar Sections dialogue, add the last member we’re using of a
L4X4X1/4.

20. To get the last members added, add nodes at the following locations:
0, 0, 5.5625

6, 0, 11.5625
14,0, 11.5625
20, 0, 5.5625
20, 6, 11.5625
20, 14, 11.5625
20, 20, 5.5625
6, 20, 11.5625
0, 20, 5.5625

j- 0,14, 11.5625
k. 0,6, 11.5625

S@mea0ow

21. With the nodes now placed, add the L4X4X1/4 Bars from the nodes on the
columns to the nodes at LO3.
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3.4 Supports

22.0pen the Supports tool by using the & button on the right,
Geometry>Supports, or switch to the Supports view mode.

23.Place pinned supports at the base of all four W10X33 columns by one of the
following methods:

a. Select the Pinned option and click the bases of the columns in the view.

b. If using the Supports view or if you open the Supports table through
View>Tables>Supports, enter the nodes of the base of the columns (1, 3,
5, 7) in the table in the List of nodes column and the Pinned row.

c. Optional: select the Section shapes button (. ))at the bottom left of the
view window to get the appearance of the image below.

3.5 Loads

24.The loads we’ll be applying will require a cladding in order to be applied.

25.Go to Geometry>Claddings.

26.Using the rectangle option, pick points along the top of the platform using either a
XY view at LO3 or a 3D view. Or use the point coordinates from the image on the

right.
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27.Move to either the Loads view mode or go to Loads>Load Types. Within the
Load Types dialogue add a dead load by setting Nature to dead and click Add.
Setting the nature will automatically set the Name and Label to DLA1.

28.Add both a live load type and wind load type.

29.Use the Loads table through the Loads view mode or go to Loads>Load Table.
Put the Case to 1:DL1, the Load type to surface on object, List item 22 for the
cladding. And lastly set PZ=-0.1.

30.1In the next row set the Case to 2:LL1, the Load type to surface on object, List
item 22 for the cladding. And lastly set PZ=-0.1.

31.To run these newly defined loads, use the Calculations button (
Analysis>Calculations.

) or go to

32.To see the effects of the loads, change the view mode to Results or open
Results>Diagrams for bars.

33.Within the Diagrams dialogue go to the Deformation tab. Select the Exact
deformation for bars option. Then on the Reactions tab check the options for
FZ and Descriptions. And lastly on the Parameters tab change the Diagram
description to the labels option. Click apply.
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Note the units will be displayed in the title bar of the view.
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