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Description 

In this lab, you will learn how to create a basic 3D game environment and a side scrolling 3D game 
environment with AutoCAD. Create and import street furniture, buildings, vehicles and other 3D 
objects using AutoCAD’s Solid, Surface and Mesh tools. Export the 3D environment to an FBX file 
format for Autodesk Stingray. Import the AutoCAD 3D model into Autodesk Stingray to see the model 
in real time. This class is designed to expand your AutoCAD 3D modeling knowledge. 
 

Speaker(s) 

Vince has been using Autodesk products since 1992. He has been working in the GIS, Civil 
Engineering and Surveying field since 1995. He currently serves as Sr. Designer for Timmons Group, 
a civil engineering consulting firm located in Richmond, Virginia. He is also a Design Specialist and 
Blogger on the site Poly In 3D where he writes tutorials and how to tips for Autodesk products. Vince 
has also been 3D modeling and rendering for over 15 years using a verity of Autodesk® products and 
other non-Autodesk® products. Autodesk University 2012 lab speaker on Civil 3D 2013, Civil View 
2013 and 3ds Max Design 2013. Autodesk University 2015 lab speaker on Vehicle Tracking 2016. 
 
 

vsheehan@comcast.net 

Poly In 3D Blog 

Vincent Sheehan (@vlsheehan) | Twitter 

Vince Sheehan | Linked in 

 

 

 

 

 

Learning Objectives 

• Create ground surfaces such as sidewalks, roads, street furniture and other 3D assets. 

• Create buildings. 

• Apply texturing/materials to the 3D objects. 

• Export 3D model for Stingray. 

• Import model using a Stingray template. 
 

mailto:vsheehan@comcast.net
http://polyin3d.blogspot.com/
https://twitter.com/vlsheehan
https://www.linkedin.com/in/vsheehan


 
 

Launch AutoCAD 2018 

When starting a game environment, there are a few things to consider. 

• Environment theme, location and setting. 

• Project propose. (Racing, shooter, adventure and so on) 

• Features/asset items. 

• Gather reference images. 

• Sketch layout. 
 
3D Modeling Workspace 

Set the workspace to “3D Modeling”. This will have all the 
necessary tools to create 3D assets and 3D environments.  

3D Modeling Ribbon Menus 
Below are the basic modeling types used in this exercise. 3D Solid, 3D Surface, 3D Mesh and 3D 
Face. 
 
Solid Tab: 

 
 
3D Soild objects consist of primitive shapes and extruded profile. Solids contain volume/mass 
properties. 
 
Surface Tab: 

 
 
3D Surface creation tools are similar to the 3D Solid tools such as sweeping, lofting, extruding, and 
revolving. 3D Surfaces can also be created by blending, patching, offsetting, filleting, and extending 
other surfaces. They do not contain volume/mass properties. 
 
Mesh Tab: 

 
 
3D Mesh is similar to 3D Surfaces. They contain vertices, edges, and faces that use polygonal 
representation. They also do not contain volume/mass properties. 
 
 
 

https://www.autodesk.com/products/autocad/overview


 
 

3D Modeling an Environment 
A few things to keep in mind while 3D modeling. 

• 3D Face Normals. Draw 3D Faces and surfaces facing the camera/view. 

• Layers, UCS. X, Y, & Z locations. Model environment around 0,0. 

• Units in AutoCAD and Stingray. Stingray uses Meters. Other game engine units may vary. 

• DELOBJ (System Variable). Set DELOBJ to 0. Controls whether geometry used to create 
other objects (3D Solids, 3D Surfaces and 3D Mesh) is retained or deleted. 

 
Open “C:\DATASETS\Vincent Sheehan\GA122371-L\DWG\Environment\DWG\01 - Layout.dwg”. This 
drawing is a small city block that consist of guidelines of roads, sidewalks and building pads set to 
various elevations. Use Shift + Mouse Wheel or View Cube to 3D Orbit the view. 
 
1. Create the road pavement. 

a. Isolate layer “ROAD-OUTLINE”. 
b. Turn on “ROAD” layer then set it current. 
c. Type 3DFACE at the command line then Snap Endpoint to the four corners of a street. 

Repeat for each road.  
d. For intersection return curves, click the Ruled Surface button under the Mesh 

tab, Primitives panel then select the two curves on each side of the intersection. 
 

2. Create the sidewalks. 
a. Isolate layer “ROAD-OUTLINE” and “SIDEWALK-OUTLINE”. 
b. Turn on “SIDEWALK” layer then set it current. 
c. Zoom to a sidewalk ramp. 
d. Type 3DFACE at the command line then Snap Endpoint to the 

intersection of the ramp wings. Repeat to create the remaining 
ramp and sidewalk surface. 

e. For sidewalk corners, click the Loft button under the Surface 
tab, Create panel. 

f. Click Mode in the command line. 
g. Click Surface. 
h. Select the magenta arch and line. 
 

3. Create the curb face. 
a. Set “SIDEWALK” layer current. 
b. Zoom to a curb and sidewalk area. 
c. Click the Extrude button under the Surface tab, Create panel. 
d. Click Mode in the command line. 
e. Click Surface. 
f. Select the top edge of the sidewalk outline then type -0.5 for 

extrusion height. 
g. Open “02 - Layout.dwg” for a completed ground surface. 
 

4. Create the building pad, floors and roof. 
a. Isolate layer “BUILDING-01-OUTLINE”. 
b. Turn on “BUILDING-01-FLOOR" layer then set it current. 
c. Zoom to a building pad. 
d. Click the Extrude button under the Surface tab, Create panel. 
e. Click Mode in the command line. 
f. Click Solid. 
g. Select the building pad rectangle then type 0.5 for extrusion height. 



 
 

h. Copy the newly created building pad up 12’ to create the second, up 24’ to create a third 
floor then up 36’ to create the roof. 

i. Change the roof solid object to “BUILDING-01-ROOF” layer. 
5. Create the building walls. 

a. Isolate layers “BUILDING-01-FLOOR” and “BUILDING-01-ROOF”. 
b. Turn on “BUILDING-01-WALLS" layer then set it current. 
c. Type 3DFACE at the command line then Snap Endpoint to each 

floor corners then the ceiling elevation of the above floor object. 
d. Repeat to create the additional walls. 
e. Convert the walls to a Surface object. 

1) Click the Convert to Surface button under the Mesh tab, 
Convert Mesh panel then select the 3D Face wall object. (Note: 
This does not delete the 3D Face object so either delete it or 
place it on a different layer for possible adjustments.) 

 
6. Create the window and door cutouts. 

a. Click Z-Axis Vector under the Home tab, Coordinates panel. 

b. Snap endpoint from left to right side of the building face to 
change the Z Axis along the front of the building. 

c. Set “GUIDELINES” layer current. Draw a 4x4 rectangle for side 
windows and a 3X6 rectangle for the front windows. 

d. Copy the polyline window along the wall to the desired locations. 
e. Set “BUILDING-01-WALLS” layer current. 
f. Click the Extrude button under the Surface tab, Create panel. 
g. Click Mode in the command line. 
h. Click Surface. 
i. Select all the window polylines then type 0.40 for extrusion height. 
j. Trim the wall with the window outlines. 
k. Click the Trim button under the Surface tab, Edit panel. 
l. Select the wall surface object then right click/enter. 
m. Select the extruded window surface objects then right click/enter. 
n. Pick inside the extruded window surface/area to trim. 
o. Repeat steps h. trough l. for additional windows and doors. 
p. Note: To adjust the window location and size along the wall, move 

the magenta rectangle. 
 
7. Create the window and door objects. 

a. Set “BUILDING-01-WINDOWS” layer current. 
b. Click the Patch button under the Surface Tab, Create panel. 
c. Select the inner edge of the previously created extruded 

surface then right click/enter. 
or 

d. Type 3DFACE at the command line then Snap Endpoint to each 
corner of the extruded surface cutout. The 3D Face is not linked to 
the extruded surface object. 

e. Repeat steps a - d for door objects. 
f. Copy the newly created walls to the second and third floor. 
g. Mirror the side walls to the opposite side of the building. 

 



 
 
8. Assigning Textures and Materials. 

a. Isolate layer “BUILDING-01-WINDOWS”. 
b. Click the Material Browser button under 

the Visualize tab, Materials panel. 
c. Click the Create New Material button the 

select New Generic Material. (The 
Materials Editor will open) 

d. Rename the material name to 
“Window_Glass-10”. 

e. Click the white image box then select 
Window_Glass-10.png from the “Textures” 
folder. (Note: One window opening is 4x4 
so the image size is 400x400 pixels. 
Another window opening is 3x8 so the 
image size is 300x800 pixels.) 

f. Change the scale to 4.0 width, 4.0 height. 
(Note: Unlink the width and height scale to 
aspect for unequal size images.) 

g. Close the Texture Editor and Materials 
Editor. 

h. Drag the newly created 4x4 window 
material to the 4x4 window 3D Face. 

i. Set the Visual Style to “Realistic” to see the 
materials. 

j. To adjust the material mapping, click the  
Material Mapping button under the 
Visualize tab, Materials panel then while 
holding the “Control” (ctrl) key, pick the 
side of the drop box. 

k. Repeat for additional materials. 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 

Image from Autodesk Help file. 

Open “C:\DATASETS\Vincent Sheehan\GA122371-L\ 
DWG\Environment\DWG\03 - Layout.dwg” for a completed building. 



 
 

Creating a Background View 
 
1. Creating a Mountainess Background View (Mountain) 

a. Open “C:\DATASETS\Vincent Sheehan\GA122371-
L\DWG\Environment\DWG\MOUNTAIN.dwg”. (Outlines of the 
Mountain are already in the drawing on the layer “MOUNTAIN-
GUIDELINES”). 

b. Set “MOUNTAIN” layer current. 
c. Click the Loft button under the Surface tab, Create panel. 
d. Click Mode in the command line. 
e. Click Surface. 
f. Select the inner green polyline, the red spline then the outer magenta polyline then enter. 
g. Repeat steps b – e for the other side of the scene. 

 
2. Create and trim the tunnel outlines from the mountain surface. 

a. Set “MOUNTAIN-GUIDELINES” layer current 
b. Click the Extrude button under the Surface tab, Create panel. 
c. Click Mode in the command line. 
d. Click Surface. 
e. Select the two yellow polylines on the same side of the mountain. 
f. Drag the cursor into the mountain. 
g. Repeat steps b – f for the other two yellow polylines. 
h. Trim the mountain with the tunnel surface extrusions. 
i. Click the Trim button under the Surface tab, Edit panel. 
j. Select the mountain surface object then right click/enter. 
k. Select the tunnel surface extrusion objects then right click/enter. 
l. Pick inside the tunnel surface area to trim. 
m. Repeat steps j-l to trim the other tunnel cutouts. 

 
3. Create a Mountainess Background View (Tunnel) 

a. Isolate the “TUNNEL-GUIDELINES” layer. 
b. Turn on “TUNNEL” layer then set it current. 
c. Click the Sweep button under the Surface tab, Create panel. 
d. Click Mode in the command line. 
e. Click Solid. 
f. Select the cyan arched closed polyline then enter. 
g. Click Alignment in the command line. 
h. Click Yes to align sweep object perpendicular to path before sweep. 
i. Select the yellow centerline polyline. 
j. Repeat steps b – i for “ROAD”, “SIDEWALK” and “ROAD-STRIPING” layers. 
k. Mirror tunnel to oppisite side of scene around 0,0,0. 

 

 
 
 
 
 

Open “C:\DATASETS\Vincent Sheehan\GA122371-L\DWG\Environment\DWG\04 - 
Layout.dwg” for a completed environment.  



 
 

Creating Assets 
 
1. Creating Assets. (Drop Box) 

a. Open “C:\DATASETS\Vincent Sheehan\GA122371-
L\DWG\Assets\Misc\DWG\USPS_Dropbox.dwg”. (Outlines of the drop 
box are already in the drawing on the layer “GUIDELINES”.) 

b. Set “DROPBOX” layer current. 
c. Click the Extrude button under the Solid tab, Solid panel. 
d. Click Mode in the command line. 
e. Click Solid. 
f. Select the cyan color leg/frame. 
g. Click Path in the command line. 
h. Select the magenta polyline. 
i. Repeat Extrude. 
j. Select the yellow square. 
k. Drag the solid up then Snap Endpoint to the bottom corner of the green polyline. 
l. Repeat Extrude. 
m. Select the white rectangle. 
n. Drag the solid outwards then Snap Endpoint to the bottom corner of the green polyline. 
o. Repeat Extrude.  
p. Select the green polyline. 
q. Drag the solid across the main box then Snap Endpoint to the corner of the solid. 
r. Click the Solid, Subtract button under the Home tab, Solid Editing panel. (This 

will subtract 3D solids from another.) 
s. Select the solid created in steps p & q then then right click/enter. 
t. Select the solid created in steps m & n then right click/enter. 
u. Click the Solid, Union button under the Home tab, Solid Editing panel.  
v. Select the lower and upper half of the drop box. (This will combine multiple 3D 

solids into a single 3D solid.) 
w. Mirror the leg/frame solid to the opposite side. 
 

2. Assigning Textures and Materials. 
a. Refer to steps 8. Assigning Textures and Materials for importing texture 

images and creating materials. 
b. Click the “Material Browser” button from the Visualize tab, Materials panel 

or type materials from the command line. 
c. Two materials for the drop box are save in the drawing. (MB1 and MB2) 
d. Select the three 3D solids that makeup the drop box. 
e. Right click on the MB1 materials then click Assign to Selection. 
f. Click MB2 then drag it while holding the “Control” (ctrl) key to the side of 

the drop box. 
g. Repeat step f for the opposite side of the drop box. 
h. To adjust the material mapping, click the Material Mapping button from 

the Visualize tab, Materials panel then while holding the “Control” (ctrl) 
key, pick the side of the drop box. 

 
 
 
 
 



 
 

3. Creating Assets. (Light Post) 
a. Open “C:\DATASETS\Vincent Sheehan\ GA122371-L 

\DWG\Assets\Misc\DWG\Light_Pole-1.dwg”. (Outlines 
of the Light Pole are already in the drawing on the layer 
“GUIDELINES”.) 

b. Set “LIGHTPOST-BASE” layer current. 
c. Click the Loft button under the Surface tab, 

Create panel. 
d. Click Mode in the command line. 
e. Click Solid. 
f. Starting at the bottom, pick the five (5), eight (8) sided, 

magenta polygons then enter. 
g. Right click or enter twice. 
h. Select the newly created solid then change the “Surface Normals” in the 

Propertied to change the shape of the light post base. 
i. Set “LIGHTPOST-POLE” layer current. 
j. Click the Extrude button under the Solid tab, Solid panel. 
k. Select the red circle on top of the light pole base. 
l. Click Path in the command line. 
m. Select the cyan color path along the light post. 
n. Set “LIGHTPOST-HOUSING” layer current. 
o. Click the Extrude button under the Solid tab, Solid panel. 
p. Select the green rectangle then type 6.0 for an extrusion height. 
q. Rotate the view to see the yellow polyline under the light housing. 
r. Click the Presspull button under the Solid tab, Solid panel. 
s. Point the pickbox inside the yellow polyline until it highlights then click. 
t. Type -5.5 then Enter. 
u. Set “LIGHTPOST-LENS” layer current 
v. Click the Extrude button under the Solid tab, Solid panel. 
w. Select the yellow polyline then enter then type -0.5 for an extrusion 

height. 
 
Instructions on modeling additional assets can be found at the end of this 
handout. Pre-made assets can also be found in the AutoCAD Civil 3D or AutoCAD 
Architecture install as Multiview Blocks. 
 
c:\Users\All Users\Autodesk\C3D 2018\enu\Data\Symbols\Mvblocks\ 

 
 
 
 
 
 
 
 
 
 
 
 
 

 

file:///c:/Users/All%20Users/Autodesk/C3D%202018/enu/Data/Symbols/Mvblocks/


 
 

Exporting the 3D Environment and Assets 
 
1. Export the 3D Environment and Assets. 

a. Isolate “BUILDING-01-FLOOR” layer. 
b. Click the Application Button ➢ Export ➢ FBX. 
c. Save the file to the project folder. 
d. In the FBX Export Options dialog box, check the 

Objects and Materials boxes. 
e. Select “Selected Entities” from the pull down the click 

the “Select Objects” button. 
f. Select the floor objects then right click or enter. 
g. Click the OK button. 
h. Repeat steps a - g for each layer. 
 
To speed up the export process, an FBX export Lisp 
Routine is located in the LISP folder of the dataset. The file 
name is “FBX_Export.lsp”. The lisp will export each layer 
to its own FBX file. 
 
C:\DATASETS\Vincent Sheehan\GA122371-L\LISP\ 
 
a. Load the lisp file by dragging the file into the model 

space. 
b. Type EXPORTFBX at the command line then enter. 
 
The FBX file names and paths in the Lisp file can 
be modified using Microsoft Notepad. 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

FBX Export Note: 

Export the model to individual FBX 
files per layer. This will allow for 
flexibility in the game engine. 



 
 

Launch Autodesk Stingray 
Latest Stingray version is 1.9.1494.0 

1. Crate a Stingray project. 
a. Click the Template tab at the top of the Stingray Projects dialog box. 
b. Click the Character template. 
c. Name the project AU2017. 
d. Click Create. 

 
2. Import the AutoCAD FBX files into Autodesk Stingray. 

a. Right click in the Asset Browser and create two new folders called Assets and 
Environment. 

b. Open the Environment folder then create a Ground folder. 
c. Open the Ground folder then create a Texture folder. 
d. Drag or import the “ROAD.fbx” into the 

..\Environment\Ground folder.  
e. Right click on the material to rename the Generic material to 

ROAD1. 
f. Open the Texture folder. 
g. Import “Asphalt_Zoab.png” and “Asphalt_Zoab_Bump.png” into 

the ..\Environment\Ground\Texture folder. 
h. Back out one folder and click on ROAD1 material. 
i. In the Property Editor dialog box, select the folder icon to the right 

of Color Map. 
j. Type Asphalt in the search field. 
k. Select the Asphalt_Zoab. 
l. Select the folder icon to the right of Normal Map. 
m. Type Asphalt in the search field. 
n. Select the Asphalt_Zoab. 
o. Select the folder icon to the right of Roughness Map. 
p. Type Asphalt in the search field. 
q. Select the Asphalt_Zoab_Bump.. 
r. Check the boxes for the “Use Color Map”, “Use Normal Map” and “Use Roughness Map”. 
s. Repeat steps a – r for the other environment and asset FBX files, textures and materials. 

 
 

 
 
 
 
 
 

FBX Import Note: 

Autodesk Stingray version 1.8.1267.0 does not import the material name and textures from 
the exported AutoCAD FBX file. Stingray renames the material to Generic*. 

https://www.autodesk.com/products/stingray/overview


 
 
3. Import the Unit Model(s) into the Stingray Level Viewport. 

a. Click and drag the ROAD unit in the Asset Browser to the 
Level Viewport. 

b. As the object remains selected, set the X,Y,Z to 0,0,0 in 
the Properties Editor pane. 

c. Adjust the rotation and scale as needed. 
d. As the object remains selected, right click then select 

“Open Selection in Unit Editor”. 
e. Once the Unit Editor is open, select the road object in the 

view port then click the Create pulldown menu. Click 
Create Actor. This will allow the players, vehicles, and 
objects to clash with and not fall/walk through objects. 

f. Click the File pulldown menu to Save then close the Unit 
Editor. 

g. Repeat steps a – e for the other environment units. 
h. Assets can be placed into the environment then modified 

using the move, rotate and scale tools. 
 
The compiled Stingray project is located under the following folder. 
“C:\DATASETS\Vincent Sheehan\GA122371-L\AU2017_Complete\” 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The game deployment file for this environment is called “AU2017.exe” and is located under the 
following folder. 
“C:\DATASETS\Vincent Sheehan\GA122371-L\Deployment\” 
 
 
 
 
 



 
 
Modeling Additional Assets 
 
1. Antenna (Solids) 

a. Open “C:\DATASETS\Vincent Sheehan\ GA122371-L 
\DWG\Assets\Misc.\DWG\Antenna.dwg”. (Outlines of the antenna are 
already in the drawing on the layer “GUIDELINES”). 

b. Set “ANTENNA” layer current. 
c. Click the Sweep button under the Surface tab, Create panel. 
d. Select the small red circle then enter. 
e. Click Alignment in the command line. 
f. Click Yes to align sweep object perpendicular to path before sweep. 
g. Select the antenna shaped magenta polyline then enter. 
h. Mirror the newly create antenna solid. 
i. Solid, Union the two antenna solids. 
j. Set “ANTENNA-BASE” layer current. 
k. Click the Sweep button under the Surface tab, Create panel. 
l. Select the small green square then enter. 
m. Click Alignment in the command line. 
n. Click Yes to align sweep object perpendicular to path before sweep. 
o. Select the angled yellow polyline 
p. Click the Extrude button under the Surface tab, Create panel. 
q. Select the small blue square at the bottom of the post. 
r. Click Path in the command line. 
s. Select the vertical green polyline. 
t. Add materials as shown in section 8. (Materials already loaded in 

drawing) 
u. Export the antenna solids to FBX shown in “Export the 3D 

Environment and Assets”. 
 
 
2. Satellite Dish (Solids) 

a. Open “C:\DATASETS\Vincent Sheehan\ GA122371-L 
\DWG\Assets\Misc\DWG\Satellite.dwg”. (Outlines of the satellite  are 
already in the drawing on the layer “GUIDELINES”). 

b. Set “SATELLITE-POST” layer current. 
c. Click the Extrude button under the Surface tab, Create panel.  
d. Select the green circle then enter. 
e. Click Path in the command line. 
f. Select the magenta polyline. 
g. Set “SATELLITE- MOUNTS” layer current. 
h. Isolate the red polylines. 
i. Click the Extrude button under the Surface tab, Create panel.  
j. Select the red polylines then type 0.025 for an extrusion height. 
k. Click the Solid, Subtract button under the Home tab, Solid Editing panel. 
l. Select the top bracket, Enter then select the cylinder. 

m. Repeat for lower bracket. 
n. Click the Solid, Union button under the Home tab, Solid Editing panel.  
o. Select the three solid objects. 
p. End Object Isolation. 
q. Set “SATELLITE- DISH” layer current. 
r. Click the Revolve button under the Home tab, Solid Editing panel.  



 
 

s. Select the cyan closed polyline then specify the center axis points (1-2) using 
snap endpoint. 

t. Type 360 in the command line. 
u. Set “SATELLITE- RECEIVER” layer current. 
v. Click the Revolve button under the Home tab, Solid Editing panel.  
w. Select the gray closed polyline then specify the center axis points (3-4) 

using snap endpoint. 
x. Set “SATELLITE- ARM” layer current. 
y. Click the Extrude button under the Surface tab, Create panel.  
z. Select the magenta rectangle polyline then enter. 
aa. Click Path in the command line. 
bb. Select the white polyline. 
cc. Add materials as shown in section 8. (Materials already loaded in drawing) 

dd. Export the antenna solids to FBX shown in “Export the 3D Environment and 
Assets”.  

 
 
3. Canopy (Surfaces) 

a. Open “C:\DATASETS\Vincent Sheehan\ GA122371-L 
\DWG\Assets\Misc\DWG\Canopy.dwg”. (Outlines of the canopy are 
already in the drawing on the layer “GUIDELINES”) 

4. Set “CANOPY - COVER” layer current. 
a. Click the Network button under the Surface tab, Create panel. 
b. Select the top yellow polylines then enter. 
c. Select the top red polylines then enter. 
d. Click the Loft button under the Surface tab, Create panel. 
e. Select the lower green and the yellow polylines then enter. 
f. Repeat step “e” for the left and right side and the back.  
g. Set “CANOPY - POST” layer current. 
h. Click the Sweep button under the Surface tab, Create panel. 
i. Select the green circle then enter. 
j. Click Alignment in the command line. 
k. Click Yes to align sweep object perpendicular to path before sweep. 
l. Select the cyan polyline. 
m. Set “CANOPY - SHELF” layer current. 
n. Click the Extrude button under the Surface tab, Create panel. 
o. Select the brown shelf support polyline then enter then type 

0.1 for an extrusion height. 
p. Repeat steps “n – o” for the rest of the shelf supports. 
q. Click the Extrude button under the Surface tab, Create panel. 
r. Select all the white rectangle polylines then enter then type 8.2 

for an extrusion height. 
s. Add materials as shown in section 9. (Materials already loaded in 

drawing) 
t. Export the antenna solids to FBX shown in “Export the 3D 

Environment and Assets”.  
 
 
 
 
 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Thanks for attending! 
 


