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Learning Objectives 

• Understand the Copy Design feature 

• Understand why Copy Design is used 

• Learn how to use Copy Design to reuse existing designs 

• Learn how to configure Copy Design for the best outcome 

 

Description 

Copy Design is one of the most powerful features in Autodesk Vault. Engineers are 

leveraging existing designs in one way or another, where either you reuse the design 

completely to eliminate the design time, or by copying an existing design or updating the 

design which will take less time. Moreover, less time is less cost. Not only this, apart from 

the reduced modeling time, design reuse will further have its impact in the form of cost 

and time savings in the downstream engineering, manufacturing, and purchasing. The 

Copy Design feature, in Autodesk Vault 2020, has many enhancements which help 

engineers do more faster with existing designs. This class will discuss the enhancements 

to Copy Design and illustrate how to use Copy Design to be more productive. 

 

Your AU Expert(s) 

James is a Quality Engineer on the Autodesk Vault team based in Novi, Michigan.  He has 

worked at Autodesk for eighteen years.  He works with customers to resolve various Vault 

problems.  His previous classes dealt with SQL and replicated environments.   

 

Irvin is a Product Manager on the Autodesk Vault team based in Novi, Michigan. He has 

worked at Autodesk for eleven years starting in product support and as a user experience 

designer. Irvin is a Microsoft® Certified Professional and has been working in the 

information technology field for more than 27 years. He helps partners, consulting, and 

sales develop Vault deployment plans in enterprise environments and system 

requirements. You can find multiple classes Irvin has presented at Autodesk University, 

on a wide range of Vault topics. Irvin is a technology geek and loves sharing with the 

community on Twitter (@ihayesjr). 

https://twitter.com/ihayesjr
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Introduction 

Copy Design helps you to automate design re-use by automatically creating new files and 

linking everything together. Copy Design is one of the most widely used features in the 

Vault, and last year’s polling within our Feedback Community indicated many customers 

were looking for improved usability and feedback during the copy process. Over the past 

year, we worked with several customers to transform Copy Design into a more powerful, 

easy-to-use tool. Copy Design is now a modeless dialog allowing access to information in 

the Vault client while setting up a copy. You can easily navigate back to the model in the 

Vault client by selecting the file in the main grid and selecting the new command Go To 

Source for or Go To Destination Folder after the copy operation completes. The Copy 

Design dialog can now also remain open while you use the Vault client for other 

commands. These changes make it much easier to set up, copy, and verify exactly what is 

being copied. Let’s get into the details of the Copy Design feature. 

 

Dialog Overview 

The Copy Design contains three different sections, the menu & toolbar, the main grid, and 

the right panel. 
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Menus & Toolbar 

The menu has been redesigned to make it more intuitive to the user and consistent with 

the Vault client user interface. Customize the toolbar and place the commands that are 

used often during the copy design operation.  

 

 
 

Main Grid 

The main grid displays information about the files that are going to be involved in the 

copy process. The user sets a specific action on each of the files displayed in the grid for 

the copy operation. These actions will be described later in this document. 
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Right Panels 

The right panel has the Numbering panel shown by default.  

 

The Numbering panel lists all of the files selected for the copy operation. It also shows 

the original and new file name for each selected file.  

The grid displays the renaming options based on available numbering schemes.  

In the Numbering Panel grid, you can edit certain fields and individual numbering 

schemes. 

 

 
 

There is also a Where Used, Folders, and Actions panel which are hidden by default. 

Display these panels by clicking the panel name in the View -> Panels menu. The features 

found in these panels can also be performed in the Main Grid. 
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Copy Design Features 

In this section, we will cover the specific features in the Copy Design dialog and how you 

will benefit from this information 

 

Main Grid Views 

The main grid has three different views for the user to use during the copy process. 

Change the views by clicking the view in the View -> Layout menu. 

 

Tree View 

The Tree View displays the assembly in an organize configuration which shows the 

hierarchy of the assembly and associated files in the copy process. This view allows the 

user to understand the relationship of all files involved in the copy process. The following 

operations are available in the Tree View: Find, Find & Replace, edit the file name, edit the 

file path, Set Numbering Scheme, drag & drop to the Numbering panel, set Copy Action, 

and drag & drop to the Folder panel. 
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List View 

The List View displays all of the files associated with the file selected in the copy process. 

The following operations are available in the List View: edit the file name, edit the file 

path, Set Naming Scheme, set Copy Action, column filtering and grouping. 
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Folder View 

The Folder View displays the destination folder where the new files will be placed after 

the copy process is complete. The following operations are available in the Folder View: 

Find, Find & Replace, edit the file name, edit the file path, drag & drop to the Numbering 

panel, set Copy Action, and drag & drop to the Folder panel. 
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Here is a chart showing the feature list and the various views: 

 

Feature Tree View 

List 

View 

Folder 

View 

Find X  X 

Find & Replace X  X 

Edit the File Name X X X 

Edit the File Path X X X 

Set Numbering Scheme X X  
Drag & Drop to Folder Panel X  X 

Set Copy Action X X X 

Drag & Drop to Numbering Panel X  X 

Column Filtering  X  
Grouping  X  
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Copy Design Actions 

The following list describes the actions that can be performed on files listed in the Copy 

Design dialog. 

 

Action Details 

Auto The Auto action is set on a drawing, documentation file when the 

parent file’s action is set to Copy.  

 

Note: the drawing receives the same new file name as the parent 

file and will be saved in the same location as the associated file 

when the copy operation completes. 

Copy All Sets the Copy action on all files in the Copy Design dialog. 

Copy Top Nodes Sets the Copy action on all files at the top node in the Copy Design 

dialog. 

Copy Sets the Copy action on all selected files. 

Copy To Sets the Copy action on all selected files, and the selected files 

will be placed in the specified folder. 

 

Note: The original folder structure will not be maintained for files 

with this action. 

Copy Branch Sets the Copy action on the selected files and the entire file 

structure (branch) beneath it. 

Copy Branch To Sets the Copy action on the selected files and the entire file 

structure (branch) beneath and sets the destination path to the 

specified folder. 

 

Note: When the copy operation completes, the copied files are 

placed to a specific folder maintaining the original folder 

structure. 

Reuse Sets the Reuse action on the selected files. The selected files are 

reused instead of creating a copy. 

 

Note: The Action column is cleared when this action is set. 

Reuse All All files in the Copy Design dialog will be set to Reuse. 

Reuse Branch Sets the Reuse action to the selected file and the entire file 

structure beneath it. 

Replace Replaces the selected file with the specified file. The name of the 

original file changes to the replacement file's name. 

Exclude Sets the Exclude action on the selected files. This action can only 

be used on parent documentation files. If this is set on any other 
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file in the structure, that file will be reused during the copy 

operation.  

Go To You can go to the original file in the Vault Client using the Source 

Folder option. 

 

After the Copy operation, you can go to the newly copied file in the 

Vault client using the Destination option. 

Edit The Edit action is set when a child of a file is set to Copy, and the 

parent is set to Reuse. The copy operation will edit, create a new 

version, of the parent file, and connect it to the newly copied child. 

Remove Removes the selected attachment 
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Copy Design Settings 

Copy Design has several settings which affects the copy process. This section outlines 

these settings with details of how they are used. 

 
Options Menu   

Numbering Schemes Set which numbering schemes will be available to set on files 
during the copy design process. You can also set the default 
numbering scheme to be used when the Copy action is set on a 
file. 

Action Rules Select to create, edit, and delete rules that apply to your copy 
operations. Each Rule Set can contain several property behaviors 
which are applied to the copied file when the tested condition is 
met. 

Automatically Copy Parents When selected, parents of child components with the Copy action 
set will automatically set the Copy action to the parent file. 
 
Note: When this option is not selected, the Edit action is set on 
the parent file. 

Link Drawings with Models When selected, the drawing connected to a model is copied to the 
same location and shares the same new file name as the model. 
The Auto action is set on the drawing 
 
Note: If more than one drawing is associated with the model, the 
copy process will prompt with an error stating that both drawings 
cannot have the same name, and the copy process will not 
execute. Exclude or rename one of the drawings to resolve the 
error. 

Remove All Attachments When selected, all attachments are removed from the newly 
created files. 
By default, all file attachments will get attached to the new file. 

Remove BOM Objects When selected, the BOM information inside of the newly created 
files will be removed during the copy operation. 
 
Note: These files will not be able to be assigned to an Item until 
they are updated inside of the CAD application. 

Select References By default, all component references are copied. When Select 
References is turned on, you can choose which references of a 
component are copied. 
 
Note: Multi-select is not enabled when using Select References 
view. Any reference that is selected must have a unique action. 
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Action Rules 

Action Rule sets are a collection of rules which define property behaviors on newly 

created files during the copy process.  

 

Open the Action Rules by clicking Action Rules > Define in the Options menu. A new rule 

can be created, or an existing rule can be copied or edited in the Action Rules dialog. 
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While editing a rule within a rule set, define the condition a rule must meet before the 

property behaviors are executed. If multiple conditions are defined for a rule, all 

conditions must be met before the property behaviors are executed. In the Rule Condition 

Builder section of the dialog, select a property, condition and set a value the rule will 

check when executed. In the Property Behavior section, select a property, action, and set 

a value that will be executed when the condition is met. 
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All rules in a rule set will be run in priority order from top to bottom. The first rule which 

the condition is met is executed on a file; the subsequent rules will not be checked on the 

same file. 

 

 
  

Copy Design Report 

Once a Copy Design operation is complete, a report can be generated, which shows the 

settings used during the operation. Once the copy operation is complete, select Export 

from the File menu, select a file name and destination folder to save the report. Open the 

report using Excel to review the settings used in the copy operation. Only columns 

showing in the dialog at the time of the operation will be exported in the report. 
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Things to Know 

• Unless attachments are set to Remove in the Copy Design process, they will get 

attached to the new parent file. 

• The Exclude action can only be set on documentation files when the Link Drawings 

with Model option is unchecked in the Options menu. 

• The Remove action can only be set on attachments.  

• Newly created files will be placed in the same folder as the file it was copied from 

unless the destination path is changed. 

• Add the Original File Name column to the main grid see the original file name. 

• PDF files created by the Job Processor will not appear in the Copy Design dialog 

and are ignored by the copy process. 


