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Description 

Increase your efficiency in creating, analyzing, and viewing simulation results with Inventor 
Nastran. Whether you are just beginning with Inventor Nastran or have extensive experience, 
the information provided in this presentation will help with all aspects of the analysis and 
navigating the Nastran interface. 
 

Speaker 

John Holtz started performing simulation in 1989, back when it was known as finite element 
analysis. Over the years and through 3 different employers, he has designed and analyzed 
furnaces, stacks, and material handling equipment for the steel industry. Such analyses 
included stress, vibration, heat transfer, and fluid flow (computational fluid dynamics). Holtz also 
worked for Algor and Autodesk, Inc., doing technical support, writing the user's guide, and 
designing the software. He is back with Autodesk doing technical support for the Simulation 
software products. Although computers and software have evolved since he started, the basic 
principles of simulation have not changed that much. Holtz looks forward to sharing his 
knowledge of the process with the audience. 
 

 

Learning Objectives 

• More efficient when setting up an analysis. 

• Understand the input for an analysis. 

• Know more ways of performing a task. 

• More efficient when viewing results. 
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Introduction 

Inventor Nastran is a general Finite Element Analysis (FEA) program for engineers and 
analysts. It is used to simulate stress, displacement, heat transfer, fatigue and more based on 
models created in Autodesk Inventor (or imported into Inventor). Inventor Nastran is a plug-in for 
Inventor to setup, analyze, and review the results of a simulation. 
 
This document provides more than 60 “tips and tricks” to improve the readers understanding 
and efficient use of the Inventor Nastran interface and results. (Yes, the number of tips 
expanded from the original proposal of 30+ to 60!) Since this presentation is on the interface, it 
is assumed that the reader has a general understanding of the concepts for simulation. 
 
The tips are classified according to the following topics which mirror the general procedure of 
performing an analysis, from conceptual work before creating the CAD model through creating 
the simulation through viewing the results and getting additional help. 

1) Modeling in Inventor 
2) Setting up Nastran environment 
3) Idealization 
4) Meshing 
5) Connectors 
6) Contact 
7) Loads & Constraints 
8) Ribbon & Model Tree 
9) Running Analysis 
10) Viewing Results 
11) Help & Other Topics 

 
The terminology and figures are based on Inventor 2022 and Inventor Nastran 2022. Future 
versions may use different terminology and different user interface. 
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1) Modeling in Inventor 

You should plan the analysis before creating the model. For example, should the analysis use 
beams, shells, or solids? What portion of the model can be simplified or eliminated? Create of 
sketch showing what loads, constraints, and contact is required can help when creating the 
model in Inventor (or modifying the model if importing a model from another CAD app). 
 

Tip 1. Use Model State 

The Inventor modeling environment includes the ability to create different versions of the model. 
(Prior to version 2022, the Model States were named something else.) For example,  

• The model will all details is created in the Master or Primary model state and is used to 
create the drawings used for manufacturing. See Figure 1. 

• The model with suppressed details is created in a Simplified” model state and is used for 
the analysis. See Figure 2. 

 

 
Figure 1 - The Master model state. 
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Figure 2 - Simplified model state has removed features that are of no benefit to the simulation. 

 

Tip 2. Combine parts of assembly 

Assemblies can often be simplified for the analysis by combining parts together that would 
otherwise be bonded in the analysis. In Inventor, use “Assemble > Simplification > Create 
Simplified Part”.  
 
The advantages are as follows: 

• The use of contact is eliminated when parts are combined. This reduces the size of the 
analysis (the number of elements) which helps the analysis run faster.  

• Eliminating contact also results in smoother results at the junction between parts. See 
Figure 3 and Figure 4 for an example where the stress result has a sudden change 
across the parts. 

• Some models will be easier to mesh when the parts are combined. 
 
The disadvantages are as follows: 

• The same material is used for all the “pieces” in the combined part. In other words, you 
cannot combine parts if they have different material properties. 

• Cannot hide the “pieces” when viewing the result. Only whole parts can be hidden when 
viewing the results. 
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Figure 3 - Two separate parts, a left half and right half split vertically through the hole, connected with 
bonded contact. Note the change in stress across the contact boundary. 

 

Figure 4 - Combined parts show a smooth stress gradient compared to the split model. 
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Tip 3. Create surface model for shell elements 

There are two types of models that can be used to create shell elements in the Nastran 
environment: 

1. A solid model (composed of “Solid Bodies”). 
2. A surface model (composed of “Surface Bodies”). 

 
Since shell elements are created from surfaces, a surface model is ideal for creating shell 
elements in the analysis. The advantages are as follows: 

• Avoids using Nastran to convert the solid to surfaces which takes time. (In Nastran, this 
would be done using the command “Prepare > Offset Surfaces”, “Prepare > > Find Thin 
Bodies”, or “Prepare > Midsurfaces”.) 

• The thickness of shell elements is based on the Idealization. By using a surface model 
and creating the idealization directly, the number of idealizations can be minimized. This 
makes it more efficient for the user to understand the model and change the thickness if 
necessary. (When converting a solid model to shells using the Nastran commands, the 
idealization created for the part has a thickness based on the average thickness of all 
regions of the part. In some cases, this is acceptable; in other cases, it is inaccurate. 
See Figure 5.) 

• Creating the surface model provides more control over the geometry. For example, gaps 
that would be created between faces can be eliminated. 

 
The disadvantages of creating a surface model are as follows: 

• In many cases, the solid model already exists. Converting the solid to a surface model, 
or creating the surface model from scratch, takes time. 

• The Idealizations need to be created manually in Nastran (by selecting the appropriate 
faces) when using a surface model. 

 
Considering that the model is created once, but the analysis is often duplicated and analyzed 
multiple times, the advantages outweigh the disadvantages in many cases. 
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Figure 5 - Solid model created in Inventor converted to surfaces in Nastran. Note the gap between the 
web and flanges. Contact is required which introduces some approximation. Note there is one Idealization 
that uses the average thickness of the web and flanges; this is usually not appropriate for the analysis. 

 

Figure 6 - Surface model created in Inventor used to create shell elements in Nastran. Note the user 
created the surfaces without gaps. Contact is not required to join the web to the flange which results in 
more accurate results. Note the two idealizations created so that the proper thickness can be entered for 
the flanges and web. 
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2) Setting up the environments 

Inventor and Nastran include options to make the workflow more efficient and easier to use. 
Follow these tips to setup the environments. 
 

Tip 4. Display surfaces as opaque 

When working with surface models to create shell elements, the default setting in Inventor is to 
display the surfaces as translucent. It is easier to “see” and understand the model when the 
surfaces are shown as opaque. See Figure 7 and Figure 8 for examples. 
 
In Inventor, change the following: 
 

• Before creating the model, check the box under “File > Options > Part > Opaque 
Surfaces”. 

• If the surfaces are already created, use the “View > Visual Style > Technical Illustration”. 

 
Figure 7 - Translucent surfaces make it hard to understand the surface and shell model. 
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Figure 8 - Opaque surfaces make it easier to visualize the surface and shell model. 

Tip 5. Change parameters for analysis 

Inventor Nastran uses many “Parameters” to control the behavior of the analysis. (Many, as in 
over 600!) Note that some of the parameters are set from input in various dialogs; that is, you do 
not need to set the parameter explicitly. Other parameters do need to be set specifically. 
 
Two parameters in particular are of interest to all users for all analysis types: 
 

• Nprocessors determines the number of processors to use when running the analysis. 
o Default is 2 or 4 depending on version. 
o 8 to 12 is optimum even if you have more processors available. 
o You may not want to use 100% of the available processors. Leave 1 or 2 available to 

handle other tasks. 
o If you do not know how many processors are available, run an analysis. The output 

includes the number available and used (near the top of the output). View either the 
log file (.LOG) or output file (.OUT) to find the number of processor information. 

• FileSpec indicates where temporary files are saved when running the analysis. 
o Set the path to a drive with most free space. Only set it to a drive on the local 

computer; do not use a network drive! (In part because your IT department will not 
like it, but more importantly because sending GB of data back and forth over a 
network is slow.) 

o Knowing where the temporary files are saved makes it easier to delete the temporary 
files that are occasionally left behind. 

o Use a path such as “D:\Temp\Nastran”. 
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Tip 6. Change parameters for current model 

For parameters than only need to be set for the current model, use the Parameters branch at 
the end of the Model Tree. See Figure 9. 

• Right-click “Parameters > Edit”. 

• Type the parameter of interest in the “Find” box. 

• Select the appropriate parameter from the list. 
 
Note: Parameters set using this tip will be used for all analyses in the current Inventor file. This 
sequence of steps could make changes to an existing analysis if not careful: 

1. Create and run Analysis 1. 
2. Create Analysis 2. Before running the analysis, you change a parameter, such as 

changing “NContactGeomIter” from the default to a different value. 
3. Run Analysis 2 
4. Activate Analysis 1 and re-run it. The results may be different because the original 

results were based on the default value of NContactGeomIter, and the new results are 
based on the different value. 

 
Figure 9 - Parameters for current model. 
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Tip 7. Change parameters for all new models 

When a new default value of a parameter is desired for all new models, change the parameter 
in the “Nastran.ini” file. This file is in the installation folder such as: 

• For versions 2015-2018, “C:\Program Files\Autodesk\Nastran In-CAD 
YYYY\System\Nastran\Nastran.INI”. 

• For version 2019, "C:\Program Files\Autodesk\Nastran 2019\Nastran". 

• For versions 2020 and newer, "C:\Program Files\Autodesk\Inventor Nastran 
YYYY\Nastran". 

 
The .ini file can be edited with Notepad. However, most Windows setup will not let the user save 
the modified .ini file to the installation folder! Instead, 

• Save the file to a location that Windows will allow, such as “Documents”. 

• Open two File Explorers: one to the “Documents” folder, and one to the installation 
folder. 

• Drag the “Nastran.ini” file from “Documents” to the installation folder. Windows will ask 
your permission to overwrite it. Choose Yes! 

 
Of course, administrative privileges will be required at some point to replace the “system” file 
with the edited version. 
 
See Also: 

• How to modify the default parameters for all new Nastran In-CAD and Inventor Nastran 
analyses 

 

Tip 8. Prompt for solution with warnings 

Sometimes when you start an analysis, the following dialog will appear: 
 

 
Figure 10 - Warning with the model setup. There is no option to proceed. 

In this situation, the option is to view the warning by clicking “Details”, and then fix the model 
until there are no warnings. 
 
However, it is sometimes acceptable to run an analysis even though there are warnings. That is, 
some warnings have no effect on the analysis. In this situation, check the setup option on the 
ribbon “System > Default Settings > General > Prompt for Solution with Warnings”. See Figure 
11. When this option is ticked, the warning dialog that appears when starting the analysis looks 
like Figure 12. 

https://knowledge.autodesk.com/article/How-to-modify-the-default-parameters-for-all-new-Nastran-InCAD-analyses
https://knowledge.autodesk.com/article/How-to-modify-the-default-parameters-for-all-new-Nastran-InCAD-analyses
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Figure 11 - Setting to allow solution to proceed even when there are warnings. 

After confirming the warnings are not important by clicking “Details” and reviewing the list of 
warnings, you now have the option to choose “Yes”, run the analysis. 
 

 

Figure 12 - Warning with the model setup. There is an option to proceed. 

The question that you should now be asking yourself is this: what type of warnings in the model 
setup are okay to ignore? These are some examples: 

• A part is intentionally not meshed because it is not required. Ideally, the part should be 
excluded from the analysis (by right-clicking on the part in the Model Tree and choosing 
“Exclude From Analysis”). If you forgot to exclude it; do not worry. Run the analysis. 

• When the model includes faces that have a very small area, the meshing may “skip 
over” the face. Instead of putting one (or more) elements in the tiny area, the mesh 
behaves as if the tiny area does not exist, and the surrounding faces are connected. If 
the tiny face has a load or constraint, the warning dialog will indicate that the load or 
constraint is not applied to a meshed face. Do not worry. Run the analysis but be sure to 
check the results to confirm that a vital load or constraint is not missing. 

• When running a transient analysis, such as explicit dynamics, the warning will indicate if 
there are no constraints in the model. Since it is a transient analysis and statically stable 
parts are not necessary, do not worry. Run the analysis. 
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Tip 9. Optimize load/constraint graphics 

The symbols for loads and constraints are a 3D object by default. When there are many 
symbols shown on the model, the 3D nature of the objects can slow the graphics for rotating, 
panning, and zooming the model. Use “System > Default Settings > Display Options > Optimize 
Graphics for Fast Rendering”. When checked, the symbols are shown as 2D objects, and 
graphic rendering is faster. 
 

 
Figure 13 - Reduce complexity of symbols to make the display respond faster. 
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3) Idealizations 

Idealizations set the element type for the selected CAD geometry. 
 

Tip 10. Use proper idealization for different geometry 

The type of CAD geometry selected in the Nastran environment determines what type of 
element can be selected:  

• Solid elements are created from solid bodies. Solid elements create elements 
throughout the volume. See Figure 14 and Figure 15 for the correct matching of solid 
elements to solid CAD geometry. 

• Shell elements are created from surface bodies. Shell elements are like a piece of 
paper: they have area but no thickness. (The thickness is represented mathematically by 
entering the thickness in the idealization.) See Figure 16 and Figure 17 for the correct 
matching of shell elements to surface geometry. Although it is possible to select the 
surface of a solid body to create shell elements, in most cases this creates the wrong 
type of model. See Figure 18 and Figure 19 for incorrect use of creating shell elements 
from a solid body. (The only situation when it is correct to create shells from a solid body 
is when the shell is like a “paint” on the surface of a solid.) 
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Figure 14 - Solid body used to create solid elements. 

 
Figure 15 – CORRECT. Solid model sliced through the middle. The results exist through the thickness. 
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Figure 16 – Surface body used to create shell elements. The surface could be created in the modeling 
environment (Tip 3) or by using “Prepare > Offset Surfaces”, “Prepare > Find Thin Bodies”, or “Prepare > 
Midsurfaces” in the Nastran environment. 

 

Figure 17 – CORRECT. Shell model sliced through the middle. The results only exist at the plane of the 
elements. The result is different on the top and bottom side of the element due to bending. 
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Figure 18 - Shell created on all surfaces of a solid body. 

 

Figure 19 – INCORRECT. Shell model sliced through the middle. The separate motion of the “outside” 
shell compared to the “inside” shell is not the expected behavior for a pipe with a nozzle. Also, there is no 
thickness of the “double-wall” shell that can be used to accurately represent the actual thickness. 
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4) Meshing 

Meshing creates the element type on the specified bodies or faces entered on the Idealization. 
 

Tip 11. Mesh settings versus Mesh table 

There are two methods to generate the mesh: 

• “Mesh > Mesh Settings” creates the mesh on the entire model using the same mesh 
size. (If smaller mesh size is desired in selected regions, add a “Mesh Control”.) 

 
Figure 20 - Mesh Settings dialog. 

• “Mesh > Table” can create a different mesh size on each part of an assembly. Enter the 
desired settings, check the box for the parts to be meshed, and then “Generate Mesh”. 

 
Figure 21 - Mesh Table dialog. Two parts are checked; only those parts will be meshed when 
clicking on “Generate Mesh”. 
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Tip 12. Which mesh was used? 

Occasionally, it is desirable to know which mesh was last used: Mesh Settings or Table. Right-
click on “Mesh Model” in the Model Tree and choose “Switch To”. The checked item shows 
which dialog was used the last time the mesh was generated. 
 

 
Figure 22 – “Mesh Model > Switch To" shows which command was used when the mesh was last 
generated. 
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5) Connectors 

Connectors are used to add specialized elements to the model: rod elements, bolts, springs, 
and rigid connectors.  
 

Tip 13. Multiple connectors in one dialog 

When creating a connector, click the “Next” button on the dialog to create another connector 
with the same input (but different geometry selected for where to create the connector). For 
example, use one dialog to define three bolts with the same diameter and preload.  

 
Figure 23 - Use "Next" to define multiple connectors in the same dialog. 
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The advantage is if you need to edit the input, such as to change the bolt diameter or preload, 
you only need to edit one entry in the Model Tree to change all the connectors in the dialog. 

 
Figure 24 - One branch in the Model Tree simplifies the view and makes it so that only one entry needs to 
be edited to change all the connectors. 

Tip 14. Rigid vs Interpolation Connector 

A rigid body connector is used to apply a mass, load, or constraint at a single point and 
distribute the load to multiple points on the model. For example, the task is to design a base 
plate that supports an electric motor. Instead of trying to model the motor, use a rigid connector 
to transfer the mass of the motor from the center of gravity to the 4 bolt holes where the motor is 
mounted. See Figure 25. 
 
The question then becomes how the motor affects the stiffness of the base plate being 
designing. The typical options are as follows: 

• The motor is much stiffer than the model; therefore, the motor is considered rigid. Add a 
“Connectors > Rigid body” and set the Type to “Rigid”. See Figure 26. The nodes where 
the connector is attached to the model will remain in a rigid plane. 

• The motor does not add any stiffness to the model. Add a “Connectors > Rigid Body” 
and set the type to “Interpolation”. See Figure 27. The nodes where the connector is 
attached to the model will not remain in a rigid plane. The load is transferred to the 
model based on interpolating the distance from the center point to the attachment points. 
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Figure 25 - Sample use of a rigid body connector. A mass is located at the center of gravity of a motor. 
The motor is bolted at four (4) holes on the base plate structure. 

 

Figure 26 - Rigid Connector type Rigid. 
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Figure 27 - Rigid Connector type Interpolating. 

Tip 15. Springs 

Springs are used to represent physical springs. Instead of modeling the spring as a 3D solid, 
use the spring connector to model the stiffness without including the minute details of the spring 
in the analysis. 
 
Springs can also be used to stabilize parts of an assembly that may not be fully held in place by 
contact. 
 
The important tips for using springs are as follows: 

1. Click the Advanced Options to show more of the input. 
2. Click the Stiffness checkbox and enter all six (6) of the stiffness values (K). Directions 1 

through 3 correspond to translational stiffness in the chosen Coordinate System’s X, Y, 
and Z directions, and directions 4 through 6 correspond to the rotation. 
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Figure 28 - Spring dialog. Click the items 1 and 2 to show the complete input. Enter the Stiffness for all six 
(6) directions. 

See Also: 

• How to enter spring stiffness in Nastran 

• Spring stiffness wrong if 0 or blank in a Nastran analysis 

 

https://knowledge.autodesk.com/article/How-to-enter-spring-stiffness-in-Autodesk-Nastran-In-CAD
https://knowledge.autodesk.com/article/Spring-stiffness-wrong-if-0-or-blank-in-a-Nastran-analysis
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6) Contact 

Contact is used in an assembly to connect parts together to transfer a load. Remember: load is 
transferred from one element to another when the elements are connected. For elements within 
a part, they connect because the mesh is continuous. For elements between parts, they connect 
through contact. (Or in the case of shell elements, continuous meshing can connect the edge of 
one shell to the face of an adjacent shell.) 
 
When defining contact, there are three commands on the ribbon that can be used: 

1. “Contacts > Auto” detects when two surfaces are touching (essentially in the same 
“plane”) and creates a manual contact entry in the Model Tree. 

2. “Contacts > Manual” lets the user choose which surfaces are included in the contact. 
3. “Contacts > Solver” will create contact throughout the entire model. 

 

 
Figure 29 - Choosing Solver contact command on the ribbon. 

 

Figure 30 - Choosing Manual contact command on the ribbon. 

Tip 16. Solver instead of manual contact 

When many contacts in the model have the same contact input, use the ribbon command 
“Contacts >Solver”. This creates one entry in the Model Tree which makes it easy to adjust the 
parameters if necessary. 
 
Solver contact will not override any manual contacts. If 90% of the model is to use bonded 
contact and 10% needs to use separation contact, use solver contact to setup the bonded 
contact, and use manual contacts to setup the separation contact. 
 
Another advantage of solver contact is that selecting the geometry is optional. 

• When no faces are selected, the solver contact applies to the entire model. 

• When faces are selected, the solver contact applies to the selected regions only. 
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• Regardless, solver contact does not override any manually defined contacts. 
 
Manual contact would be used when the contact is limited to specific regions or when there is 
large sliding motion between specific faces. 
 

Tip 17. Hide parts to select “covered” faces 

When using “Contacts > Manual”, it is not unusual for one or both faces that need to be selected 
are covered by the other part and cannot be selected directly. In some cases, Inventor’s “Select 
Other” command may show the intended face. If not, the following steps will let you select the 
covered face. In this example, one Manual contact is desired between the face of a weld neck 
flange and the eight (8) bolts that are modeled as a solid. 

1. Select the face on the flange for the Primary Entity. This face is easily selected because 
most of the face is not covered by the bolts. See Figure 31. 

2. Selecting the contact face on each bolt head is difficult because the flange is in the way. 
You can hide the flange by right-clicking on the part in the Model Tree and unchecking 
“Visibility”. Although the mesh is still shown, no faces can be selected on the flange 
because the CAD body is hidden. See Figure 32. 

3. Select the contact face on each bolt as the Secondary Entity. See Figure 33. 
4. Remember to make the flange visible again. 

 
Figure 31 - Select visible face of flange. 
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Figure 32 – Make the flange part invisible. 

 
Figure 33 - Select face of bolt head "through" the invisible flange. Although the mesh is shown on the 
flange, the mesh cannot be selected. 
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Tip 18. Max activation distance (manual contact) 

The problem with contact is that it is too easy to create an excessive number of elements. If you 
are not careful in the setup, the analysis can have 5 to 10 times more contact elements than 
solid elements! Of course, the more elements in the analysis, the longer it takes to solve, the 
more RAM memory required, and so forth. 
 
The number of contact elements is controlled by the input “Max Activation Distance”. The 
interpretation of maximum activation distance is different for manual contact (this tip) and solver 
contact (see the next tip). 
 
When using separation or offset bonded contact in manual contact, ALWAYS enter a maximum 
activation distance to minimize the number of contact elements created. (It is not as critical for 
bonded contact since only the closest nodes are connected.) 
 
The maximum activation distance needs to be larger than the distance from a node on the 
secondary entity (“S” in the following figures) to the furthest node on the matching primary 
element (“P”), based on the distance at time 0. In other words, the contact elements are created 
based on the mesh without any loads and displacements. Contact elements are not created 
during the analysis after the parts have deformed. (The deformation can only change which 
contact elements are in contact and which have separated.) 
 
If there is very little sliding between the faces, the maximum activation distance can be 
calculated as follows based on the gap between faces (if any) and the mesh size “h”: (See 
Figure 34.) The value of 1.1 provides a “tolerance” since the mesh size varies from element to 
element. 

 

 
Figure 34 - Max activation distance for Manual contact without sliding depends on mesh size “h” and gap 
between faces. “S” is a node on the secondary object that contacts the farthest node “P” on the primary 
element. 

𝑀𝑎𝑥.  𝑎𝑐𝑡 𝑑𝑖𝑠𝑡𝑎𝑛𝑐𝑒 ≅ 1.1√ℎ2 + 𝑔𝑎𝑝2 
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If the parts slide a distance “L”, the maximum activation distance needs to include the 
anticipated motion also. See Figure 35. Note that large sliding is only calculated in a nonlinear 
or explicit dynamics analysis.  

 

 
Figure 35 - Max activation distance for Manual contact with sliding depends on mesh size, gap between 
faces, and the amount of sliding “L”. 

See Also: 

• Understanding maximum activation distance and contact type in a Simulation 

• Difference between Maximum Activation Distance and Penetration Surface Offset in 
Nastran contact definition 

Tip 19. Max. activation distance (solver contact) 

The interpretation of the maximum activation distance is different in solver contact. If not set 
properly, contact will be created between “extra” nodes in the model which could change the 
stiffness and accuracy of the results. 
 
Because solver contact checks all the node in the model (or all the nodes on specified regions) 
and creates contact between a node and element within the maximum activation distance, the 
calculation is based on the following: (See Figure 36.) 

1. Max activation distance > 0. 
2. Max activation distance > gap 
3. Max activation distance < gap+h (linear mesh) or Max act distance < gap+½ h (parabolic 

mesh) 
 
The first rule is because no nodes are mathematically 0 distance from the matching element 
even if the CAD model has a theoretical gap of 0. The second rule ensures that nodes on one 
side of the gap are connected to the elements on the other side of the gap. The third rule 
indicates to keep the distance small enough that the next midside node (if a parabolic mesh) or 
corner node (if a linear mesh) does not get “accidentally” connected to the element across the 
gap. If that were to occur, the stiffness would be larger than reality and affect the accuracy of 
the results. 

𝑀𝑎𝑥.  𝑎𝑐𝑡 𝑑𝑖𝑠𝑡𝑎𝑛𝑐𝑒 ≅ 1.1√(𝐿 + ℎ)2 + 𝑔𝑎𝑝2 

https://knowledge.autodesk.com/article/Understanding-maximum-activation-distance-and-contact-type-in-a-Simulation
https://knowledge.autodesk.com/article/Difference-between-Max-Activation-distance-and-Penetration-Surface-offset-while-contact-definition-in-Nastran
https://knowledge.autodesk.com/article/Difference-between-Max-Activation-distance-and-Penetration-Surface-offset-while-contact-definition-in-Nastran
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Figure 36 - Maximum activation distance for solver contact is based on the gap. 

Tip 20. Unsymmetric versus Symmetric contact 

Similar to using the maximum activation distance to limit the number of contact elements in the 
analysis, the option of the Penetration Type can be used to limit the number of contact 
elements. 

 
Figure 37 - Use the Penetration Type to limit the number of contact elements. 

Keep in mind that contact is really a node-to-element detection. Therefore, the options for 
the Penetration Type determine which set of nodes (secondary or both) can contact which set of 
elements (the primary or both). The options are as follows: 
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• Unsymmetric Contact: 
o Secondary nodes (“S” in the following figures) make contact with the primary 

elements (“P”). Literally think of the secondary body as just the nodes without any 
faces. Therefore, the secondary nodes will not pass through the primary elements, 
but the primary nodes will pass through the secondary elements. 

o Fewer elements are created; thus, the analysis runs faster. 
o Unsymmetric contact is suitable when there is no contact between an edge and a 

face. See Figure 38, Figure 39 and Figure 40. 

• Symmetric Contact: 
o Secondary nodes (“S”) make contact with the primary elements (“P”) and the primary 

nodes contact the secondary elements. Contact is detected in both directions. 
o Better contact detection, especially when contact occurs at an edge. But 

approximately twice as many contact elements are created. See Figure 38 and 
Figure 41. 

 

 
Figure 38 - Sample of dropping a block onto a wedge. 

 
Figure 39 - Unsymmetric contact. If the wedge is the secondary, only the nodes are important. The block 
can fall between the nodes! 

 
Figure 40 - Unsymmetric contact. If the block is the secondary, only the nodes are important. The block 
falls and gets stuck on the wedge! 

 
Figure 41 - Symmetric contact. With detection between nodes and faces on both bodies, the behavior is 
as expected. The "cost" is twice as many contact elements which leads to a longer runtime. 
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Tip 21. Friction in contact 

Friction can only be included in the analysis with these settings: 
1. The contact type is separation. “Sliding” means the faces are free to slide, so friction is 

not included in the analysis. 
2. The analysis type is Nonlinear. Friction is not supported in a linear analysis. 

 
Two other settings are helpful to improve the accuracy of the friction calculation: 

• Set parameter SLINESLIDETYPE to STATIC. (Parameters are set from the second-to-
last branch in the Model Tree.) 

• Set “Nonlinear Setup > Number of Increments” to 25 or larger. 
 

Tip 22. Deleting contacts 

Once a contact is created, there is only one way to delete it from the Model Tree: select the 
entry and press the Delete key on the keyboard. 
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7) Loads & Constraints 

 

Tip 23. Face Chain 

When applying a pressure to multiple faces, such as the inside of a pressure vessel, use “Face 
Chain”. By clicking on one face, all connected faces are selected. 

 
Figure 42 - Right-click in “Selected Entities” and choose “Face Chain” to select connected faces when 
clicking on one face. 

Tip 24. Use Pressure where possible 

If a force needs to be applied to many elements, there is a delay when starting an analysis. The 
step “Generating Nastran file” can appear to get stuck. There is no delay when the load is a 
pressure load. Therefore, use a pressure load instead of a force load when possible. 
 
Note that “many elements” means the load is on thousands or more elements. When the load is 
applied to a few hundred elements, there is little difference to create the Nastran file between 
using a force versus a pressure. 
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Tip 25. Loads & Constraints in multiple subcases 

Subcases are used in a linear static analysis to apply different combinations of loads. Each 
subcase produces results that are independent of other subcases. 
 
Subcases are used in a nonlinear static analysis to create a sequence of loading and unloading. 
The results of one subcase depend on the results of the previous subcase. 
 
When a load is needed in multiple subcases, assign the load to the subcases on the load dialog. 
See Figure 43. Do not create new loads for the new subcases. 
 

 
Figure 43 - Assign loads (and constraints) to multiple subcases when creating the load. 

See Also: 

• How do subcases function in a non-linear solution type in Nastran 

 

Tip 26. New load or constraint 

When creating a load or constraint, click the “New” button instead of the “OK” button to do the 
following: See Figure 44. 

• Apply the current load or constraint. 

• Keep the dialog open with the same input (same load magnitude or constraint fixity). 

• Clear the “Selected Entities” box. 

https://knowledge.autodesk.com/article/How-do-subcases-function-in-a-non-lineear-solution-type-in-Nastran
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This way, the same load can be applied to a different selection, or you can modify the load and 
apply it to a different selection. 
 

 
Figure 44 - "New" will apply the current load or constraint and the dialog will remain open to define a new 
load or constraint. 

Tip 27. Duplicate load or constraint 

When creating a load or constraint, click the “Duplicate” button instead of the “OK” button to do 
the following: See Figure 45. 

• Apply the current load or constraint. 

• Keep the dialog open with the same input (same load magnitude or constraint fixity) and 
the same “Selected Entities”. 
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Figure 45 - "Duplicate" will apply the current load or constraint to the model and the dialog will remain 
open to define a new load or constraint. The entries in the selection box remain. 
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8) Ribbon & Model Tree 

Some tasks can be performed from the commands on the ribbon, some can be performed from 
the commands on the Model Tree, and some can be performed from both locations. 
 
Just to be clear, the Model Tree is the list of branches (usually on the left side of Inventor) 
shown in Figure 46, and the ribbon is the row of buttons (usually across the top of Inventor) 
shown in Figure 47. 
 

 
Figure 46 - The Nastran Model Tree 
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Figure 47 - The Nastran Ribbon. 

Tip 28. How to hide ALL CAD parts 

To hide all CAD bodies, use the ribbon command “Display > Object Visibility > CAD Bodies”. 
Note that the mesh, loads, or constraints are not hidden by this command. (Guess what? See 
the next few tips.) 
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Figure 48 - Hide CAD Bodies from the ribbon. 

Tip 29. How to hide mesh using Mesh Table 

When working with an assembly, the mesh associated with chosen parts can be hidden using 
the ribbon command “Mesh > Table”. Uncheck the “Visibility” column to hide the mesh in those 
parts. See Figure 49. 
 
Note that the CAD geometry, loads, or constraints are not hidden by this command. 
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Figure 49 - Hide the mesh on selected parts of an assembly. 

Tip 30. Hide parts and mesh using Model Tree 

Parts of an assembly and meshes associated with an idealization can be hidden from the Model 
Tree: 

• Right-click the parts and uncheck “Visibility” to hide the CAD body. 

• Right-click on the Idealization and uncheck Display” to hide the mesh associated with 
the idealization. 

 
Note that this does not hide the loads or constraints. (Guess what? You can right-click on the 
load or constraint and uncheck “Display” to hide them.) 
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Figure 50 - Hide bodies and mesh from the Model Tree. 

Tip 31. How to display beam cross-section 

When working on a beam model from an Inventor sketch, it is important that the orientation and 
offset of the cross-section matches the physical reality. For example, the model shown in Figure 
51 is composed of tubes (blue elements), angle ell (brown elements), and channel (green 
elements). 
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Figure 51 - Sample beam model. The region in the box is shown in the next figure. 

Note: orientation and position can also be controlled by using the Inventor Frame Generator to 
create the model. 
 
The orientation of the beam cross-section can be displayed from the Model Tree. Right-click on 
“Elements > Display Cross Section”. Note that this ability only exists when using the “Cross 
Section” input for the beam Idealization. If using the “Properties” input, the cross-section cannot 
be displayed (because Nastran does not know the dimensions that correspond to an arbitrary 
cross-sectional property.) See the next tip. 
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Figure 52 - Beam elements with cross section display shown. The elements at the connection are hidden 
in this figure to show the cross-section more clearly. 

Tip 32. Show direction or orientation of beams 

When using “Properties” input for beam elements, the orientation of the cross section can be 
shown from the Model Tree by right-click “Elements > Display Line Element > Orientation”. The 

Orientation arrow corresponds to the beam’s Y axis, and the second area moment of inertia Iy 

corresponds to the Y axis. (The Z axis is perpendicular to the beam and corresponds to Iz.) 

 
For applying end releases and viewing results, it is necessary to know which end of the beam 
element is end “A” and which is end “B”. Use the Model Tree “Elements > Display Line Element 
> Direction” to view this information. The Direction arrow points from end “A” to end “B” on each 
beam element. 
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Figure 53 - Beam Orientation and Direction arrows. 

See Also: 

• How to understand results in beam and bar elements in Inventor Nastran 
 

Tip 33. Keep Model branch collapsed 

When entering the Nastran environment, I suggest collapsing the “Model” branch of the Model 
Tree. Think of the “Model” branch as a library of everything ever applied to any analysis in the 
model. 
 

1. The Model branch is often longer than the analysis branch, so the Model branch takes 
up too much of the window. 

2. It is hard to know what items to edit from the Model branch because they include 
everything ever applied to any analysis. Instead, edit the input (Idealizations, loads, 
constraints, and so on) from the actual analysis. 

 

https://knowledge.autodesk.com/article/How-to-understand-results-in-beam-and-bar-elements-in-Nastran-In-CAD
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Figure 54 - The "Model" branch of the Model Tree. 

Note: Inventor Nastran 2023 tries to keep the Model branch automatically closed for you. 
 

Tip 34. How to add a concentrated mass 

Now that I suggested to keep the “Model” branch collapsed (Tip 33), here two tips for reasons to 
use the model branch! 
 
Concentrated masses can only be added to the model from the Model branch > “Idealizations > 
Concentrated Masses > New” command. Once the first mass is added to the analysis, the 
Model branch can be collapsed, and new masses can be added from the analysis. 
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Figure 55 - Add the first concentrated mass from the Model branch. 

Tip 35. How to copy loads, constraints, and so on 

Loads or constraints applied to a different analysis can be copied from the “Model” branch of the 
Model Tree and pasted into the current analysis. See Figure 54. 

1. Right-click on the load or constraint to be copied in the “Model” branch and choose 
“Copy”. 

2. Right-click on the “Loads” or “Constraints” branch in the analysis and choose “Paste”. 
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Figure 56 - Copy and Paste from the Model branch to the current analysis. 

Tip 36. What NOT to change from Model branch 

Technically, anything that is changed in any analysis will change that item in every analysis in 
which it appears. Therefore, be aware of what you are changing and how it may affect other 
analyses.  
 
But in particular, changing these items from the Model branch is confusing. See Figure 57. 

• Materials – the same “Material 2” is shared by all analyses. 

• Laminates – the same “Laminate 1” is shared by all analyses. 

• Tables – the same tables are shared by all analyses. 
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Figure 57 - Items in the "Model" branch that are shared among duplicated analyses. 

At least other entries in the “Model” branch are identified as “– Copy”, “– Copy (2)”, and so on. 
Those copies are generally used in only one analysis, so editing those copies is usually not as 
“dangerous”. When an analysis is duplicated, the material is not copied. Both analyses 
reference the exact same material entry. 
 
For example,  

1. Analysis 1 uses “Material 2”. You run the analysis and review the results.  
2. Analysis 1 gets duplicated for a different analysis, perhaps multiple times, but still uses 

“Material 2”.  
3. If “Material 2” is edited from anywhere (Analysis 1, the duplicated analysis, or the 

“Model” branch), it is changing the original “Material 2” in the original “Analysis 1” also.  
4. If Analysis 1 is re-run, the results will change because the material properties changed. 
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9) Running Analysis 

 

Tip 37. Activate results output for nonlinear analysis 

Before running a nonlinear analysis, set the “Subcase > Nonlinear Setup > Intermediate Output” 
to “On”. When the analysis is running, the results for each increment will be shown when the 
step is completed. With the default value of “Off”, results are not shown until the analysis is 
100% done. That might waste a lot of time of the setup is not correct. 
 

 
Figure 58 - Set Intermediate Output to On for a nonlinear analysis. 

Tip 38. Improve convergence in nonlinear analysis 

Nonlinear analyses use iterations to update the stiffness matrix to “follow” the changing stiffness 
of the model. Part of that process is calculating a convergence value to know if the calculated 
stiffness is accurate or not. 
 
In some cases, the analysis may fail to converge. If it fails before reaching the first output step, 
one diagnostic tool is to change the convergence criteria: “Subcase > Nonlinear Setup > 
Advanced Settings > Convergence criteria and error tolerances”. A typical problem is the parts 
are not touching; therefore, it takes 0 load to move the part, and it is difficult to get the answer 
within 0.05% of 0. By removing the “Load” convergence criteria, the analysis will often converge. 
Once you have some results, you can decide if changing the setup will solve the convergence 
issue, or perhaps that the results without the “Load” convergence are accurate. 
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Figure 59 - Change the criteria tested for convergence. 

Tip 39. Queue multiple analyses using Nastran Editor 

The Inventor interface only supports running 1 analysis at a time. The Nastran Editor Utility is an 
alternate interface that can run multiple analyses sequentially. The steps are as follows: 

1. Generate the Nastran file for each analysis that needs to be analyzed: right-click in the 
Model Tree > Generate Nastran file. 

2. Find the name of the Nastran file (.nas). (The files are created in the same folder as the 
Inventor file, then into the folder “modelname > InCAD > FEA”.) 

3. Start the Nastran Editor Utility (from the Windows “Start” button). 
4. In the Editor, use “File > Open” and select each Nastran file. Note that each file is added 

to the “Queue Window”. See Figure 60. 
5. Right-click in the “Queue Window” and choose “Start Queue”. 
6. After the analyses complete, use the Nastran Editor or Inventor Nastran to view the 

results. 
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Figure 60 - Run multiple analyses from the Nastran Editor Utility. 

Tip 40. Queue multiple analyses using batch file 

Multiple analyses can also be run from a batch file (.bat). The advantage is that the Nastran files 
are not loaded into any interface; therefore, more RAM is available for the analysis. The steps 
are as follows: 

1. Generate the Nastran file for each analysis that needs to be analyzed: right-click in the 
Model Tree > Generate Nastran file. 

2. Find the name of the Nastran file (.nas). (The files are created in the same folder as the 
Inventor file, then into the folder “modelname > InCAD > FEA”.) 

3. Open File Explorer to a convenient folder. 
4. Right-click and choose “New > Text Document”. Change the name and extension to 

“run.bat”. Confirm that you want to change the extension when prompted by Windows. (If 
you do not get the confirmation prompt, the extension was not changed from .txt to .bat. 
Use “View > Show/hide > File name extensions” on the File Explorer ribbon to show the 
extension, and then change .txt to .bat.) 

5. Right-click the batch file and choose “Edit”. This opens the file in Notepad. 
6. Copy the text from Figure 61 and paste into the batch file. 
7. Change the path in the “SUBST S:” command to the installation folder for the Nastran 

software on your computer. 
8. Change the path in the “SUBST M:” command to the folder where the first model to 

analyze is located. 
9. Change the lines “S:\nastran.exe “M:\model1.nas”” to the appropriate names of the 

Nastran files to be analyzed. 
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10. If all the models are in the same folder, add REM in front of the example commands 
“Subst M: /d” and the next line giving the new folder. 

11. Save the file and exit. 
12. Right-click the batch file (.bat) and choose “Open” or “Run as Administrator” to run the 

analysis. This opens a black “DOS” command prompt window. 
13. When the last analysis completes, the window will show “Press any key to continue . . .” 
14. To periodically review the progress of the analysis, open the .LOG file. To “refresh” the 

.LOG file, close it and re-open it. 
 

REM clear previous substitute commands. 
SUBST S: /d 
SUBST M: /d 
 
REM create new substitutes for folder with Nastran.exe 
SUBST S: "C:\Program Files\Autodesk\Inventor Nastran 2022\Nastran" 
REM folder with Nastran file 
SUBST M: "D:\Nastran InCAD\articles\batch queue (88900)" 
 
REM run each Nastran (.nas) file 
S:\nastran.exe "M:\model1.nas" 
S:\nastran.exe "M:\model2.nas" 
REM clear previous substitute and create a new folder for new model locations 
SUBST M: /d 
SUBST M: "D:\Nastran InCAD\NASA\SLS" 
S:\nastran.exe "M:\model3.nas" 
S:\nastran.exe "M:\model4.nas" 
PAUSE 

Figure 61 - Sample batch file to run multiple analyses. (REM is the command for a remark or comment.) 

Tip 41. View the warning/errors from analysis 

Always check the end of the log file for warnings or errors. Are they significant? 
1. Right-click “Results > Show in Folder” if the analysis completed or use Windows File 

Explorer to browse to folder with the model, then “modelname > InCAD > FEA” if the 
analysis failed. 

2. Open the corresponding .log file. 
3. Scroll to the end of the file and locate the WARNING AND ERROR MESSAGE 

SUMMARY. 
 

WARNING AND ERROR MESSAGE SUMMARY 
 
WARNING G3051: MODIFYING SECONDARY GRID - POSITION ON CONTACT ELEMENT -     (66) 
WARNING E5075: BISECTING CURRENT LOAD INCREMENT                            (4)   
WARNING E5078: SOLUTION HAS DIVERGED                                       (4)  

Figure 62 - Warning and Error Message Summary. 
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Tip 42. E5000, E5001, E5004 errors 

FATAL ERROR E5004: STIFFNESS MATRIX SINGULAR OR NON-POSITIVE DEFINITE 
 
FATAL ERROR E5001: NON-POSITIVE DEFINITE DETECTED AT GRID id COMPONENT  
 
FATAL ERROR E5000: SINGULARITY DETECTED AT GRID id COMPONENT  

Figure 63 - Fatal errors related to singularities and matrices that cannot be solved. 

An error stops the analysis; there are no results in a linear analysis, but a nonlinear analysis 
outputs results prior to the error. 
 
These errors indicate the matrix of equations (F=k*x) cannot be solved, either because a part is 
not statically stable, or a numerical problem makes the equations unable to be solved. The 
errors are caused by one of three things: 

1. Model is statically unstable. Make it stable! Either a constraint or contact is missing. If 
this is the problem, running the analysis as a Normal Modes will show which part is free 
to move as a rigid body (and a frequency of 0); view the displacement result and 
exaggerate the deformation scale if needed to show the part that is moving freely. 

2. Material properties are wrong. 
a. Modulus of elasticity too strong or weak. A ratio of the strongest material divided by 

weakest material should be no larger than 1E3 o 1E4. 
b. Poisson’s ratio = 0.5 

3. Mesh is distorted. Use the Model Tree “Mesh Model > Check Quality for Mesh” 
command to see if any Jacobian values are near zero (less than approximately 0.1) or 
negative. 

 
See Also: 

• "FATAL ERROR E5004", "FATAL ERROR E5001" or "FATAL ERROR E5000" when 
running an analysis in Inventor Nastran 

 

Tip 43. E5118 warning 

WARNING E5118: EXCESSIVE VECTOR RESULTANT MISMATCH DETECTED 

                        L O A D   V E C T O R   R E S U L T A N T 

SUBCASE      T1          T2          T3          R1          R2         R3 

   1   0.00000E+0  0.00000E+0 -7.24970E+3  4.72047E+1  2.24372E+4  0.00000E+0 

 

  S I N G L E  P O I N T  C O N S T R A I N T  V E C T O R  R E S U L T A N T 

SUBCASE      T1          T2          T3          R1          R2         R3 

   1  -1.89521E-3  3.90407E-3  7.24969E+3 -1.18543E+2 -2.21740E+4  1.16163E-1 

Figure 64 - E5118 warning. 

This warning does not stop the analysis; the results are available. 
 
This warning is critical and must not be overlooked. It indicates the reaction forces do not match 
the applied loads! To determine if the warning is significant or not, follow these steps: 
 

1. Find E5118 warning in output file (.out). 

https://knowledge.autodesk.com/article/Error-FATAL-ERROR-E5004-STIFFNESS-MATRIX-SINGULAR-OR-NON-POSITIVE-DEFINITE-when-running-an-analysis-in-Nastran-In-CAD
https://knowledge.autodesk.com/article/Error-FATAL-ERROR-E5004-STIFFNESS-MATRIX-SINGULAR-OR-NON-POSITIVE-DEFINITE-when-running-an-analysis-in-Nastran-In-CAD
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2. Compare applied load (LOAD VECTOR RESULTANT) and reactions (SINGLE POINT 
CONSTRAINT VECTOR RESULTANT). If difference is small, the warning is not a 
problem. Note that T1, T2, and T3 are forces in X, Y, and Z directions. R1, R2, and R3 
are moments caused by the loads about the origin. In the example, the forces are equal 
and opposite to within an insignificant difference. Although the moments have relatively 
large differences (47.2 versus 118.5, and 22437 versus 22174) and are the cause of the 
warning in this example, the difference are relatively minor compared to the magnitude 
of the load (7250). The moment difference is more likely due in this example to the 
difference between the moment arm of each load compared to the moment arm of each 
constraint. 

3. If the warning is significant and the different is large, run the simulation as a nonlinear 
static analysis. 

 

Tip 44. G3051 warning 

WARNING G3051: MODIFYING SECONDARY GRID 3590 POSITION ON CONTACT 
ELEMENT 69 
INITIAL MAXIMUM CONTACT SURFACE PENETRATION  =  1.1500E+01  AT GRID 36841 
INITIAL MAXIMUM CONTACT SURFACE PROTRUSION   =  2.2400E+01  AT GRID 43007 

Figure 65 - G3051 warning. 

This warning does not stop the analysis; the results are available. 
 
The warning indicates a node on the secondary contact face is interfering with an element on 
the primary contact face; that is, the node is penetrating the face. 
 

1. This is typical behavior because the mesh approximates surfaces (especially curved 
surfaces). 

2. Interference will exist with a random mesh. See Figure 66. 
3. Nodes on secondary contact face are moved to “eliminate” the interference, and this is 

where the G3051 warning comes from. 
4. The important question is: how far are they moved? 

a. Small distance = no problem. 
b. Large distance = problem. 

5. Search the .log file for “Surface Penetration”.  
 
In the example above, the node is moved 11.5 units. Whether that is inches, millimeters, or 
meters, it is too large. It indicates the contact is setup improperly and needs to be fixed. 
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Figure 66 - Interference due to random mesh. The shaft (yellow) and hole in the gray part theoretically 
have 0 interference, 0 gap. Due to the random mesh, a node on the shaft will penetrate the flat face on 
the hole. 

Tip 45. Add UCS to locate specific nodes 

Some warnings and error messages refer to a specific node. Add a User Coordinate System 
(UCS) to easily locate the node: 

1. View the Nastran file (.nas) to get the coordinates for the node (GRID number). This can 
be done in the Nastran File tab of the Inventor interface, by opening the Nastran file with 
the Nastran Editor Utility, or by opening the Nastran file with Notepad. See Figure 67. 

2. From the “3D Model” tab on the ribbon (not the Inventor Nastran tab of the ribbon), 
choose “Work Features > UCS”. 

3. Type the coordinates. See Figure 68. 
4. Press Enter twice. A coordinate system axis is placed “on the model” at the coordinate of 

the node. See Figure 69. 

 
Figure 67 - Get the coordinates for a node (GRID) from the Nastran file (.nas). The node number is in the 
third column of line 1 (node 258 in this example). The X coordinate is in columns 6 and 7. The number 
format is scientific notation with “E” implied; thus, -4.45-1 is -4.45E-1 = -0.445. The Y coordinate is in 
columns 8 and 9, and the Z coordinate is in columns 2 and 3 of line 2. 
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Figure 68 - Enter the UCS coordinate. 

 

 
Figure 69 - The UCS coordinate axis is created after pressing Enter twice. 
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10) Viewing Results 

 

Tip 46. Load results for current analysis 

When re-opening a model or activating a different analysis, there are two methods to load the 
existing results:  

• The easy way! Right-click on “Results > Load Results” in the Model Tree. See Figure 70. 

• The hard way. Use “Results > Load Results” on the ribbon. When the File Open dialog 
appears, write down the name of the file that needs to be loaded. Browse to the folder 
where the model is stored, then into the folder “model name > InCAD > FEA”. Select the 
results file that you wrote down. 

 

 
Figure 70 - Load Results for an existing analysis. 
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Tip 47. Review ALL the results! 

I should not need to mention this, but I will. (I see too many easy mistakes go unnoticed 
because users do not look at all the results.) 
 
REVIEW ALL THE RESULTS: 

• Displacements 

• Stress 

• Reaction forces 

• And so on. 
If there is a problem in the results, either due to user error or software problem, it will show up in 
one of the results. 
 

Tip 48. View reaction forces 

Although there is a contour plot that shows the reaction force, the plot shows the force at each 
node. This is usually not meaningful. 
 
To get the more meaningful result of the total reaction force, right-click in the Model Tree on 
“Constraint > SPC Summation”. The sum of the forces is given. (By the way, “SPC” stands for 
“Single Point Constraint”, as in a constraint on each individual or single node.) 
 

 
Figure 71 - Reaction force (SPC) summation. 

Here are some things you can do with the dialog and things to be aware of: 
1. If the analysis includes multiple subcases or steps, use the “Subcase” drop-down to 

choose which step to show. 
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2. The “Selected Entities” can be changed by clicking on the model and removing items 
from the selection box. There is no need to close the dialog and choose a different 
constraint – unless that is more convenient. 

3. Here is the tricky item: the total SPC Force Summation is not for the constraint on the 
selected geometry. The summation is the reaction forces for the nodes on the selected 
geometry. Most times the constraint and nodes are the same. In the quarter symmetry 
model shown in Figure 72, the blue constraint is a Z symmetry constraint, and the red 
constraint is an X symmetry constraint. When viewing the SPC summation for the Z 
symmetry constraint (Figure 73), you might expect the reaction to only have forces in the 
Z direction (TZ). However, the X direction (TX) also has a reaction force on the selected 
face because the nodes where the two symmetry planes meet creates an X force on the 
selected nodes. In other words, most of the nodes on “face <2>@long thingy:1” only 
have a Z constraint, but a few nodes include a Z constraint and an X constraint. The X 
reaction force comes from the few nodes with both the X and Z constraint. 

 

 
Figure 72 - Quarter symmetry model. The blue constraints fix displacement in Z on the Z symmetry plane; 
the red constraints fix the X direction on the X symmetry plane. 
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Figure 73 - Sum of reaction force from the nodes on the “Z symmetry” plane. The X reaction force comes 
from the nodes that are shared with the X symmetry plane. 

Tip 49. Meaning of moment SPC Summation 

The SPC Summation dialog includes the option to show the total reaction moment. This result is 
a source of confusion for some users. 

• How is it calculated, especially when solid elements do not have a moment result? The 
calculation uses the vector cross-product R x F where F is the reaction force vector at 
each node on the selected geometry, and R is the vector from the reference point to 
each node. See Figure 74. 

• For beam or shell elements, there can also be a moment reaction in the constrained 
nodes. That moment result is included in the equation. 

• The reference point needs to be set to define the R vector and get the desired result! 
The centroid of the selected geometry is often the desired reference point.  
o The default reference point is the origin.  
o The other option for the reference point is an existing node (grid point) in the model. 

To place a node at a precise location to use for the summation, add a sketch point to 
the model and a “Mesh > Mesh Control” on the sketch point. When the mesh is 
generated, a node will be located at the mesh control. 
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𝑀 = 𝑅1 × 𝐹1 + 𝑅2 × 𝐹2 +⋯+ 𝑅𝑖 × 𝐹𝑖 +∑𝑀𝑖 

Figure 74 - How the moment reaction is calculated, where Mi is the moment reaction (if it exists) at each 
node 1 through i. 

 
Figure 75 - The moment calculated depends on the entered "Reference Grid Point". 

Tip 50. Fringe and 6 color contour 

The default color scheme for the contour plots (“Continuous”) is fine when you do not want to 
clearly show what the result is at any point on the model. The smooth gradient makes it hard to 
pinpoint what the result is. 
 
When talking with co-workers, it is helpful to have a clear image of what the result is over the 
model. To do this, use the “Settings” on the legend toolbar and set “Rendering > Fringe” and 
“Levels > 6”. See Figure 76. This gives the best contrast of colors in the legend. Using a 
different number of colors starts to blend some colors together which makes it harder to 
distinguish the colors.  
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The rendering type (“Continuous”, “Fringe”, etc.) can also be changed from the ribbon using 
“Results > Options” to access the Plot dialog. 
 
Note that the colors on the model may still be hard to distinguish because the light shading of 
the model changes the tints.  
 

 

 
Figure 76 – From the Setup button located above the legend toolbar, change the legend rendering from 
Continuous to Fringe. 

 
Figure 77 - Number of colors in legend affects the contrast. Six (6) colors provide the best contrast 
between each shade. 
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Tip 51. Nodal Probe versus Probe 

There are two probes that can be used to show results on the model: 
 
From the Model Tree, “Nodes > Query Display”. This shows results at nodes, so the location is 
repeatable. That is, you can switch to a different result and read the value at the node since the 
node is a defined position. 

 
Figure 78 - Node Probe. 

From the ribbon, use “Results > Probes”. This shows the result interpolated to the position of 
the mouse, so the location is hard to repeat. 
 

 
Figure 79 - Interpolating Probe. 

Tip 52. Make XY Plot for results 

For analyses with multiple subcases or multiple steps, the XY Plots are a convenient method of 
seeing how the results change. From the Model Tree, right-click “XY Plot > New” or choose one 
of the predefined plots. (Predefined plots are available for certain analyses only). 
 
The input dialog is used to choose nodes or elements (depending on what result is to be 
plotted) and the result to plot. See Figure 80. Click the “Show XY Plot” to view the graph. See 
Figure 81.  
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Figure 80 - Input for XY Plot. Choose what to plot (node or element), where (along entity or specific ID 
numbers), and what to plot (displacement, stress, etc.) Click “Show XY Plot” to create the graph. 

 
Figure 81 - Example XY Plot showing the stress at 5 elements in a dynamic analysis. This dialog also 
includes options (not shown in this figure) to change the look of the plot and to copy the data points used 
to create the graph to the Windows clipboard. 
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Tip 53. How to hide parts 

Hiding parts in the results is different than hiding parts while setting up the model.  

• From the Model Tree, right-click “Results > Contour > Edit”. 

• From the ribbon, “Results > Options”. 
Then check the box for the “Part View” tab and select the parts that are to remain visible. Parts 
not listed will be hidden. 
 

 
Figure 82 - Show parts (and therefore hide other parts) in results. 

Tip 54. Turn off automatic updating (performance) 

If switching between results is slow, one option is to turn off the default that will refresh the 
display every time you make a change on the Plot settings dialog. Then you can make multiple 
changes on the Plot dialog and display the result one time (instead of multiple times with each 
change). 
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From the ribbon, check the box for “System > Default Settings > Post-Processing > Automatic 
plot updating”. 
 

 
Figure 83 - Deactivate "Automatic plot updating" to minimize how many times the contour plot is updated 
when changing the input. 

When automatic plot updating is unchecked, remember to click the “Display” button on the Plot 
dialog after making changes to the input to show the contour plot. Clicking OK closes the dialog 
without showing the result! 
 

 
Figure 84 - When "Automatic plot updating" is unchecked, use the "Display" button on the contour Plot 
dialog to show the display. 

Tip 55. Turn off undeformed model (performance) 

Showing the undeformed edges on the results (see Figure 85) can add to the time to display the 
results in a large model. To speed the display, turn off the undeformed edges. 

• To turn off for the current model, use the ribbon to uncheck “Display > Object Visibility > 
Undeformed Edges”. See Figure 86. 

• To turn off for all models, use the ribbon to uncheck “System > Default Settings > 
Display Options > Undeformed Edges”. See Figure 87. 
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Figure 85 - Undeformed edges are shown as red dashed lines in the results. 

 
Figure 86 - Object Visibility will turn the undeformed edges off for the current analysis. 
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Figure 87 - Default Settings will turn off the undeformed edges for all analyses. 

Tip 56. FNO Reader to extract results 

FNO Reader is a third-party app to access the results file directly. Why do you want to do that? 
 

1. Some results in the binary file (.FNO) cannot be displayed by Inventor. Such results are 
only accessible by converting the FNO file to a text file. 

2. It helps to understand what Inventor is showing by learning what result is in the FNO file. 
For example, 
a. Inventor shows a stress result at the midside node when using a nodal probe (see 

Tip 51); however, that result is not in the FNO file! Where does Inventor get the result 
to show? (Hint: Inventor calculates the average result from the corner nodes and 
displays that value.) 

b. A frequency response analysis shows results at the nodes. That result is not in the 
FNO file. Only the centroidal results are output. 

3. Create table of results for reports or for graphs. For example, the sum of the reaction 
forces from a dynamic analysis can be written down, one-by-one, from the Inventor 
interface by using the SPC Summation dialog and then typing the values into Excel. Or 
use FNO Reader to extract the reaction force sum to a CSV file and import into Excel. 
See Figure 89. 

4. Perform calculations after extracting results from and edge or face. 
5. Extract contact forces to calculate the moments transmitted through weld. 
6. Convert the Nastran file (.nas) to a text file for further manipulation, such as converting a 

constant load to some value based on a complex calculation. 
 
Do not let the fact that I am the creator of FNO Reader affect whether you want to use it or not. 

      The FNO Reader can be downloaded from this forum post on the Inventor Nastran forum: 

read binary results file (FNO) with a program - Autodesk Community - Inventor Nastran. Scroll 
through the thread to find the latest version attached. Full documentation and examples are 
included with FNO Reader. 
 

https://forums.autodesk.com/t5/inventor-nastran-forum/read-binary-results-file-fno-with-a-program/td-p/9020216
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Figure 88 - FNO Reader interface. Convert the binary result file or Nastran input file to text and vice 
versa. 
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Figure 89 - Sum of reaction forces extracted from an explicit dynamics analysis and plotted in Excel. 

Tip 57. FNO Reader to combine output steps 

A nonlinear analysis writes out the results of each increment to separate file. When the analysis 
completes, the separate files are merged, and then you can review the complete set of results. 
 
If the analysis is stopped, the separate files are not merged. This makes it difficult to review the 
complete set of results. (You would need to load one result, view those, then load another 
result, view those, and so on.) Use FNO Reader to combine the individual output files so that 
the complete results (up to the step it was stopped) can be viewed. 
 



 
 

 10) Viewing Results 

 

2022 Aug 30 rev 0 Page 73 

 
Figure 90 - Use FNO Reader to combine individual steps from a stopped nonlinear analysis (0001.fno, 
0002.fno, and so on) into one file. 

Tip 58. FNO Reader to create new results 

FNO Reader can convert the binary results to text and convert text files back to the binary 
format (.fno). This provides the possibility to calculate new results that can be displayed as a 
contour plot in Inventor. 

 

Figure 91 - Displacement of a tank with hydrostatic pressure. 
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Figure 92 - Hypothetical result calculated in Excel, transferred to the FNO file, and displayed in Inventor. 
Happy Birthday! 
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11) Help & Other Topics 

Tip 59. search Help (or AKN) > Technical Support 

When additional help is required for a topic, start with the following: 
1. Click “Help” on the Inventor Nastran ribbon and enter a search term. 
2. Select “Technical Support” in the Refine By. 
3. The hits found are articles written by me and co-workers. They include more detailed 

information than the Help documentation. The articles are particularly helpful to solve 
problems or answer questions you encounter. 

 

 
Figure 93 - Accessing Technical Support articles from the Help system. 

Autodesk Knowledge Network (AKN, www.knowledge.autodesk.com) provides similar access to 
articles for all Autodesk products and can also be used. You may find the “Help” page is easy to 
get to from the ribbon. 
 
Some of the tips in this document include links to these helpful articles. The “See Also” links are 
by no means the complete list of articles that are relevant to these tips! 
 

Tip 60. “List of changes” on Inventor Nastran forum 

The list of changes posted to the Inventor Nastran forum is more detailed than the What’s New 
in the Help. The list tells you what you need to know about changes that may affect your results. 
Be sure to review the list when a new release occurs. 
 
For example, see the following: 

• Inventor Nastran 2023.1 list of changes - Autodesk Community - Inventor Nastran 

• Inventor Nastran 2023.0 list of changes - Autodesk Community - Inventor Nastran 

• Inventor Nastran 2022.2 list of changes - Autodesk Community - Inventor Nastran 

• And so on. 

http://www.knowledge.autodesk.com/
https://forums.autodesk.com/t5/inventor-nastran-forum/inventor-nastran-2023-1-list-of-changes/td-p/11324194
https://forums.autodesk.com/t5/inventor-nastran-forum/inventor-nastran-2023-0-list-of-changes/td-p/11143129
https://forums.autodesk.com/t5/inventor-nastran-forum/inventor-nastran-2022-2-list-of-changes/td-p/10799981
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Figure 94 - List of updates published to the Inventor Nastran forum. 
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