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Description 

Often, you run several to dozens of results on a given part to optimize the results. Often, the 
changes in results are minor and subtle. However, these small changes are often the difference 
between a good design and great design. The maximum and minimum values for a result are 
usually outliers that don't tell the whole story; instead, value distribution is critical. Volumetric 
shrinkage is a case in point: The range of shrinkage may be 1% to 10%, but most of the part is 
between 2.5% and 4%. You can see this trend when you look at the graphical results, but you 
can't quantify it. But when you export your data using an API script, you can use a tool such as 
a spreadsheet program to create a histogram. Histograms become exceptionally useful when 
you compare them between studies. In this class, we’ll explore the use of histograms for looking 
at many types of Moldflow results. 
 

Speaker(s) 

I started working in a family-owned machine shop before and while attending Western Michigan 
University. After graduation Jay started with Moldflow then Autodesk for a total of 36 years. 
During most of Jay’s career, he has been involved in training, and since 2000 the developer of 
training material for Moldflow. Jay is the editor of the book Moldflow Design Guide. Since 2001, 
Jay has managed the certification program for Moldflow programs.   Today, Jay works for 
iMFLUX running Moldflow to support both mold building and iMFLUX process technologies. In 
collaboration with others, Jay has developed two methods for simulating the iMFLUX processing 
technology in Moldflow.  Jay is an Adjunct Assistant Professor at Western Michigan University. 
Since 1985 Jay has taught tooling classes, plastics processing classes, conducted research and 
published papers related to injection molding and simulation. Jay has been a member of the 
Society of Plastics Engineers (SPE) since 1983 and has attended over 30 ANTEC’s. In 2011, 
Jay was awarded the SPE Mold Making and Mold Design Division’s Mold Designer of the year. 

 

Learning Objectives 

• Discover the power of histograms for looking at Moldflow results 

• Discover how API scripts are used to generate the data 

• Learn how to create a histogram of Moldflow data 

• Learn about interpreting histogram data for various result types 
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Introduction 

Using histograms can be a powerful tool to compare results between studies and to look at in 
detail the results of a single study. Get more information from your data by using histograms. 
For me, I did not see the power in it the first time I used histograms. It took me a few examples 
to see the benefit of using histograms. Now that I have, I use them on every project, often more 
than one. 
 

Setup 

There are a few things you need to do before you can start using Histograms with Moldflow 
data. 
 

1. Download from AU’s web site for this class PM500014, the file PM500014 Extracting 
Moldflow Data Templates Scripts.zip.  
 
This contains Excel template files and script files. 
 

2. Extract the files from the zip file. 
 
You should have 3 .txt files and 10 xltx Excel template files. 
 

 
CONTENTS OF THE ZIP FILE 

 

3. Select and copy the Excel Templates. 
 

4. Open the Options for Excel and go to the Save options. 
 

5. Look for the Default personal Templates location. 
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It might be blank. If blank, enter a location. 
 

 
EXCEL OPTIONS 

 
6. In windows explorer, navigate to the personal templates folder. 

 
7. Paste the template file in this location. 

 
8. Test to see if the files are found. 

 
In Excel, Click File>New>Personal. 
 
You should see the Excel templates. 
 

9. Alternatively, you can navigate to where you downloaded the templates and double click 
on them. Having the templates in the proper location so Excel knows where they are is 
faster to open the templates. 
 

10. Navigate to the folder where the txt files are that you downloaded. 
 

11. Change the extension from .txt to .vbs. 
 

12. Copy and paste the vbs files to the scripts folder of the version of Moldflow you are 
using, Such as: My AMI 2021.1 Projects>scripts. 
 

13. Test to see if the scripts are found in Synergy. 
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Click Tools>Automation>Play Macro. Ensure the scripts are found. 
 

14. OPTIONAL, Assign the scripts to Assigned Macro buttons for faster access. 
 

Running a script 

Running the API script to extract the data you want is easy, but you need to keep in mind a few 
things: 
 

• There are 3 scripts depending on the type of data. This instruction set is going to 
concentrate on extracting Volumetric shrinkage at Ejection from a Dual Domain model. 
When procedures are different, they will be noted. 

• You need to have a study open. 

• The scripts are not tolerant of more than one session of Synergy open. (They are older 
scripts). You may need to close Synergy sessions. 

• It is best if you open Excel before running the script. For this example, you need the 
Histogram-VolShr.xltx template open. 
 
1. Ensure you have a Dual Domain study open that has Volumetric Shrinkage at Ejection 

results in it. 
 

2. Execute the script by: 
Tools>Automation>Play Macro>Vol She to file.vbs or 
 
Click the assigned macro button you assigned to the script. 
 

3. Ensure the script runs correctly. 
 
The script runs correctly when Notepad opens with a text file with the shrinkage data in 
it. The first line is the study name with _Vol Shr at the end of the name so you know 
what the study and data is. The second and third lines are blank. The file should open 
within a second or two from the execution.  
 
If the study does not have Volumetric Shrinkage at Ejection results available, the script 
should execute correctly but only the first 3 lines will be present  
 

 
TEXT FILE OF EXPORTED VOLUMETRIC SHRINKAGE DATA 
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Running the Other Scripts 
 
The other scripts are: 

• AnySDS_to_file.vbs 

• Any Intermed to file.vbs 
 

These scripts are more generalized. SDS stands for Single Data Set. To use the correct script, 
you need to know if the result is a single data set or intermediate result. If the default animation 
is time, then it is an intermediate result, if not it is a single dataset result. If you pick the wrong 
script, the file that is exported will not have the data in it. Just run the other script. 
 

1. Execute the script by: 
Tools>Automation>Play Macro>Any Intermed to file.vbs of AnySDS_to_file.vbs. 

2. Find the dialog called Jays Mess and the text file _Result_IDs.txt Notepad window. 
 
The scripts are not specific to any result. Therefore, you need to tell Synergy what result 
you want. The number of results depends on the study and may not fit in the space of 
the dialog. Therefore, the list in the dialog may be a partial list so the text file has the 
complete list. 
 
Find the result you want and its plot ID 
 
Enter the plot ID in the Dialog’s input field. The default value is 1629, the ID for Average 
Volumetric Shrinkage, (for the Any Intermed to file.vbs script). 
 

 
JAYS MESS DIALOG AND FILE WITH PLOT ID’S 

 
3. If you don’t get any data in the script, try running the other script. 

 
4. Inspect the data that is in the output text file that opens automatically. 

 
Some results don’t have data recorded for entities but have code numbers. For example, 
in the image below, the text file is from a study that is 3D, and the result is Average 
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Volumetric Shrinkage. The study has hot runners. As you know, hot runners cannot have 
volumetric shrinkage, so a key number is put in, so Synergy knows not to plot data. The 
data is always at the top of the file. Delete this data. The number is 
9.99999968028569E+37. 

 
EXAMPLE DATA THAT MUST BE DELETED 

 

Getting Data into Excel 

Getting data into Excel is a simple copy and paste. The first example above is Volumetric 
Shrinkage at Ejection and that is the example used here. NOTE: The templates have been 
updated since creating the presentation. A textbox on the histogram is now automatically 
generated. 
 

1. Activate the text file with the Volumetric Shrinkage at Ejection data in it that you 
exported. 
 

2. Press CTRL+A to select all the contents of the file. 
 

3. Press CTRL+C to copy the selected data. 
 

4. If you have not done so, open a copy of the Histogram-VolShr.xltx Excel template. 
 

5. Place the cursor in the A5 cell. It is highlighted yellow. 
 

6. Press CTRL+V to paste the data to the Excel sheet. 
 
The histogram and some statistics are automatically generated. 
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DATA PASTED INTO EXCEL 

 
7. Optional data to put on the sheet is part weight. You can get this from the Cavity Weight 

result.  
 
NOTE: The script does not require the shrinkage results to be displayed. You can have 
the cavity weight displayed and run the script. That way you have the weight and 
shrinkage data handy. 
 

The next step could be to modify the histogram or to add data from more studies. They can be 
done in either order. I find it normally useful to modify the histogram first then add data. In either 
case, there is usually some iterations going on. 
 

Modify Histogram 

Typically, you need to do some manipulation of the graph to make it more useful. For the 
Shrinkage graphs, it is assumed the bins (X-axis data) are 0.5% in size. It’s best if the bins are 
rounded to a half percent.  
 

1. To set the minimum value of the data, that controls the bin values,  
 
Click in cell A6, (currently blank). Enter a value in increments of 0.5. For this example, I 
can enter 1.5 since the lowest value is 1.6.  I could enter 2.0, but there are a lot of 
datapoints between 1.6 and 2.1 so I want to correctly capture that. 
 

 
ADDED DATA TO SET THE BIN SIZE TO ROUND NUMBERS 
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2. To set the Bin size, 

 
Click on the horizontal axis numbers to select the axis. Right click and select Properties. 

Click on Axis Options and enter a value in the Bin Width field. The current value 
should be 0.5. 
 

3. To set the Underflow and Overflow bins, 
 
In Axis Options, Check the Overflow and Underflow bins as needed, and enter a value. 
Currently the Underflow value should be checked with a value of 0.5. 
 
You may not need the Underflow or Overflow bins. In this case, the minimum value of 
the data is 1.6, and we entered 1.5 to set the bin increment. Nothing is needed. The bins 
are needed if the data range is very wide, and you don’t want to look at the ends of the 
data range closely. 
 

4. To change the graph title, 
 
Click the graph title (Volumetric Shrinkage) to select it. Modify the name, typically 
identify the study name or a unique identifier for the results. 

 

Adding data from more studies 

Histograms are most powerful when comparing multiple studies. Shrinkage from one study is 
done. Now it’s time to create a histogram for another study. 
 

1. To set up for adding a study, 
 
Double click on the Excel sheet name (Sheet 1) and change its name. Use a name that 
identifies the study. 
 
Right-click on the sheet name and select, Move or Copy. Select (move to end) and 
check Create a copy and click OK. 
 
Double click on the Excel sheet name you just created and change its name. Use a 
name that identifies the study. 
 
Click the graph title to select it. Modify the name, typically identify the study name or a 
unique identifier for the results. 
 

2. To create a second set of data, 
 
In Synergy open or activate a second study, typically of the same part. 
 
Execute the same script you did before to generate the first set of data. 
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Copy and paste the data from the text file to the second Excel sheet you created.  
 
NOTE: If you are not sure if this study has the same number of elements, select the 
current data on this sheet and delete it. Otherwise just paste over it. 
 
Make the necessary changes to the data to be consistent with the first histogram. 
Ensure there are the same number of bins and cover the exact same range. Use Cells 
A6 and A7 to enter min and max values as necessary to adjust the bin number and 
sizes. Modifying Cells A6 and A7 do not influence the statistics of the data. 
 
Ensure the Y-axis for all histograms is the same range. If not, select the range on the 
graph you need to change and set it to the same range as the other graphs 
 
Click on the text box in the graph to select it. Click on the Formula line. The formula will 

be =F3. Click the formula check to update the formula. This is done so the textbox on 
this graph will update to the contents of F3 on this sheet rather than the previous sheet. 
 

3. To copy all graphs to one page, 
 
You can compare multiple Histograms on one page to see trends easier. The Excel 
sheet called All Graphs is set up for this. You can compare as many Histograms as you 
want, but 6 is about the practical limit. 
 
Go to the sheet that has the first Histogram you want to copy.  
 
Select and Copy the graph. 
 
Click on the All Graphs sheet. 
 
Select Cell B2 and paste the graph. 
 
Go to the sheet that has the second Histogram you want to copy.  
 
Select and Copy the graph. 
 
Click on the All Graphs sheet. 
 
Select Cell B22 and paste the graph. 
 
Continue to copy and paste graphs, typically a column of graphs should be no more than 
3 graphs. 

 

Interpreting results 

As with any Moldflow result, knowing something about the analysis objectives, and the part 
geometry helps in determining how you will look at these results and decide what is good and 
bad. With Volumetric shrinkage, generally a narrow distribution is good. With iMFLUX typically 
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the average volumetric shrinkage is a bit higher, and the distribution is narrower for most of the 
part but there might be a few high or low elements. 
 
Looking at the histograms below, you can see that Study 1 has slightly lower shrinkage on 
average and slightly more of the elements have a shrinkage within 1% of the bin size average. 
Note the numerical average is 3.3, but the 2% range is within based on a bin size of 0.5%. 
 
Realistically, the results are close between these two studies, and both are good. One thing you 
could do with is say that the amount of the part that is over 4% shrinkage is quite limited. You 
could plot the shrinkage that is over 4% on the part and see where it is. 
 

 
TWO VOLUMETRIC SHRINKAGE HISTOGRAMS 

 

Summary 

Histograms are very useful for looking at results in more detail. With the API scripts and Excel 
templates they do not take long to create and can make a big difference in your understanding 
of the results. 


