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FAB463426 

Revit to Inventor - BIM exchange for custom fabrication hands-on Lab  

Paul Munford, Autodesk 

Description 

This lab will provide an opportunity for customers to get hands-on with the new 'Revit AnyCAD' 

functionality in Inventor 2021. 

We will cover some of the theory of why BIM is important to building product manufacturers and 

custom fabricators and level-set on our existing BIM exchange tools. We will then work our way 

through a four-part example use case for referencing Revit data. 

We will cover some basic clean-up of the model in Revit. Test what we can do with the data in 

Inventor. 

Marvel as changes made to the Revit model update inside of Inventor, and round trip the 

Inventor model back into Revit. 

This class will suit Inventor users who are confident using the Inventor UI to design and build 

their models. 

This class will be specifically focused on Inventor users who wish to participate in BIM Project 

and who would like to test the new 'Revit AnyCAD' functionality in Inventor 2021. 

Supporting documents 

'Don't forget to download the dataset and watch the video of the presentation on AU Online. 

https://www.autodesk.com/autodesk-university/au-online?query=paul+munford 

  

Learning Objectives 

• Learn how to create a simplified view in Revit, in preparation for referencing the 

Revit Project into Inventor. 

• Learn how to reference a Revit Project File into Inventor to design in context  

• Test the ability to update the Revit file, and consume the update inside Inventor 

• Round trip the Inventor file back into Revit. 

https://www.autodesk.com/autodesk-university/au-online?query=paul+munford
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Paul Munford 

Paul Munford is a laugher, dreamer, raconteur, CAD geek and 

Technical Marketing Manager for Autodesk in the UK. 

Paul's background in manufacturing items for the construction 

industry gives him a foot in digital prototyping and a foot in Building 

Information Modeling (BIM). 

Paul was a speaker at Autodesk University for the first time in 2012, 

and he says it's the most fun anyone can have with 250 other people 

in the room. 

@PaulCADmunford 

 

What is BIM? 

'BIM' or Building Information Modelling is the process of collaborating on a digital, 3D database 

of information about a building design. 

A 'BIM' is the Building Information Model itself. 

A BIM is created using a BIM authoring tool such as Autodesk Revit, and is compiled from a 

number of separate 3D model/databases, each created by a different specialist - for example an 

Architectural BIM, a Structural BIM and a Mechanical BIM. 

At each design stage, the BIMs can be coordinated, so that the overall design has no 

contradictions before being released to the broader project team. 

The coordinated BIM is a 3D model that represents a database of information about the design. 

Schedules, drawings and even simulations or renderings are all 'views' of the same database. 

The design BIM can be passed on to the General Contractor, who can continue to update the 

BIM by incorporating 3D models from trade subcontractors and specialists. 

Eventually, the 'As Built' BIM can be passed on to the building owner, who can use the BIM 

database for asset management throughout the building's lifecycle.  

BIM for Custom Fabricators 

In this class, we will take the role of a custom fabricator on a BIM project. We have been 

supplied with a Revit BIM to help us work in context with the Architect's design. 

Our deliverable will be a 3D model that can be returned to the General contractor and Architect 

for design coordination and aesthetic approval.  

https://twitter.com/PaulCADMunford
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About this lab 

At Autodesk University, a ‘Lab’ style class is an opportunity to get hands-on with Autodesk 

software. The Lab instructor takes you through the exercises, and there are ‘Lab Assistants’ to 

help you if you get stuck. 

Due to the coronavirus pandemic, AU is entirely virtual this year. This means that you’ll have to 

work a little harder to get the best out of this lab. You’ll need to install the software yourself, 

download the handout and dataset, and follow the instructions with minimal help from me and 

without Lab assistants. 

I’ve tried to make the instructions for each exercise as straight forward and easy to follow as 

possible. I welcome your feedback on how I can improve this for you. 

Please watch the video of the presentation that goes with this class. I will demonstrate each 

exercise for you, and then you can use the step-by-step instructions in this handout to try the 

workflow out for yourself. 

I have supplied a dataset with files for each exercise. If you don’t get the result you were 

expecting during an exercise, don’t worry – just close the file you are working on and open the 

file from the folder for the next exercise.  

Your feedback 

If you have any feedback on this class, the format, the dataset, the handout, or the presentation, 

please feel free to contact me: Paul.Munford@Autodesk.com 

To show your appreciation, please use the 

‘Recommend’ button on the Autodesk university 

online webpage for this class. 

Your questions 

You can ask questions via the ‘Comments’ box 

on the Autodesk University Online web page for 

this class.  

During the week of AU2020, I will monitor your 

questions and answer as many as I can. 

You will also be able to join us for a LIVE 

Q&A session on Thursday 19th November at 

08:30 PST 16:30 GMT 

  

mailto:Paul.Munford@Autodesk.com
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Prerequisites 

To follow the instructions in the class, you will need: 

• The Handout 

• The Dataset 

• Autodesk Inventor 2021 Installed on your computer 

• Autodesk Revit 2021 Installed on the same computer. 

It is expected that you will be familiar with basic concepts in Inventor and Revit, such as opening 

files, navigating within the file structure, and navigating in 3D space. 

 

Installing Inventor and Revit 2021 

If your subscription includes Autodesk Inventor 

and/or Revit 2021, you can install them via the 

Autodesk Desktop app or via your Autodesk 

Account. 

You can log into your Autodesk account using 

your Autodesk ID and password here: 

https://manage.autodesk.com/home/ 

 

Downloading a trial of Inventor 2021 

You can download a free 30 day trial of Autodesk 

Inventor using this link: 

https://www.autodesk.co.uk/products/inventor/free-trial 

If you’ve never used Autodesk Inventor before, please visit the trial center for ‘getting started’ 

tutorials: 

https://www.autodesk.com/campaigns/inventor-trial-center 

Or take a look at the in-product Tutorial Gallery 

 

Figure 1The Autodesk Desktop App 

https://manage.autodesk.com/home/
https://www.autodesk.co.uk/products/inventor/free-trial
https://www.autodesk.com/campaigns/inventor-trial-center
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Downloading a trial of Revit 2021 

You can download a free 30 day trial of Autodesk Inventor using this link: 

https://www.autodesk.co.uk/products/revit/free-trial 

If you’ve never used Autodesk Revit before, please visit this link for ‘getting started’ tutorials: 

https://knowledge.autodesk.com/support/revit-products/getting-

started/caas/CloudHelp/cloudhelp/2020/ENU/Revit-GetStarted/files/GUID-C3DEF8F6-A9C0-

496E-A554-8147B12A4EDA-htm.html 

A note on versioning 

The functionality we are learning about in this Lab did not exist prior to Inventor 2021. The 

workflow described in this class will not work with older versions of Inventor. 

Inventor 2021 can reference Revit files from previous versions of Revit (older than 2021); 

however – you will notice a performance hit. In the background, Inventor is updating the Revit 

file from the previous version to Revit 2021. 

To avoid this performance hit, we recommend updating the Revit project to Revit 2021 in Revit, 

before you reference it into Inventor 2021. 

The Video 

The video of the presentation that goes with this class will give context on why the workflow is 

helpful to Custom fabricators working on BIM projects, along with a recording of the 

demonstration for each exercise. 

Please watch each demo in its entirety before pausing the video and trying the workflow for 

yourself. 

You can use the instructions in the handout to help you follow along with the exercise, or rewind 

the video and follow along. 

The Handout 

If you are reading this – you have the handout - Thank you! 

The handout will take you through each exercise step – by step, including the file and folder 

path to the example files you will be using. 

The instructions in the handout follow the demo of the exercise we will see in the video of the 

presentation. 

Tip: I have included extra detail and references to further information in the handout that I didn’t 

have time for in the presentation. 

  

https://www.autodesk.co.uk/products/revit/free-trial
https://knowledge.autodesk.com/support/revit-products/getting-started/caas/CloudHelp/cloudhelp/2020/ENU/Revit-GetStarted/files/GUID-C3DEF8F6-A9C0-496E-A554-8147B12A4EDA-htm.html
https://knowledge.autodesk.com/support/revit-products/getting-started/caas/CloudHelp/cloudhelp/2020/ENU/Revit-GetStarted/files/GUID-C3DEF8F6-A9C0-496E-A554-8147B12A4EDA-htm.html
https://knowledge.autodesk.com/support/revit-products/getting-started/caas/CloudHelp/cloudhelp/2020/ENU/Revit-GetStarted/files/GUID-C3DEF8F6-A9C0-496E-A554-8147B12A4EDA-htm.html
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The Dataset 

The dataset is a zipped file containing all the files you need for the exercises. 

The files for each exercise are self-contained. If you don’t get the result you were expecting at 

the end of an exercise – don’t worry. Just close the file that you are working on and open the 

example file from the folder for the next exercise. 

Please download the dataset and extract the zipped files directly on to your C: Drive. 

We recommend saving the class files in this folder location ‘C:\Datasets\FAB463426’. 

You can download the dataset from the Autodesk University online page for this class, or you’ll 

also find it here: http://cadso.co/FAB463426_DOWNLOAD 

The Demos 

Each exercise is demonstrated in the video of the presentation for this class. Please watch each 

demonstration in full before you start the exercise.  

You can use the instructions in the handout to help you follow along with the exercise, or rewind 

the video and follow along. 

  

http://cadso.co/FAB463426_DOWNLOAD
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Exercises 

Setup – Before we begin… 

Before we begin, please check that you have the following: 

 Inventor 2021 installed 

 Revit 2021 Installed 

 Dataset downloaded and extracted C:\Datasets\FAB463426 

 Handout  

 Video of the presentation 

Please start Inventor and set the project file to point at the class dataset. 

With Inventor 2021 open, go to: 

1. Get started (Tab) > Launch (Panel) > Projects (Button) 

2. In the ‘Projects’ dialog, click on ‘Browse…’  

3. In the ‘choose project file dialog’ browse to C:\Datasets\FAB463426 

(or wherever you saved and extracted the dataset for this class) 

4. Select the project file ‘FAB463426.ipj’ with a left mouse button click, and click the 

‘Open’ button. 

5. In the ‘Projects’ dialog, check that ‘FAB463426.ipj’ has a ‘check’ mark next to it (✓) 

6. Click on the ‘Done’ button. 
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Exercise 01- In Revit, creating a simplified View. 

When we bring a Revit project file into Inventor, we don’t want to bring in EVERYTHING! The 

referenced Revit model would be large and unwieldy and would slow down Inventor. 

To reduce the size of the referenced Revit model file in Inventor, we can reference in a saved 

view of the Revit model, which has been filtered to just the information we are interested in. 

In this exercise we will learn how to create a view of the Revit model, which only shows the 

detail we are interested in.In this exercise, we will learn how to create a view of the Revit model, 

which only shows the detail we are interested in. 

In this Exercise, we will: 

• Open the data set for this exercise 

• Browse the Revit project structure 

• Copy and rename an existing 3D View 

• Filter the view 

• Use a Section box to crop the view 

Open the data set for this exercise 

1. From the Revit home page, look for ‘MODELS’ and click ‘Open.’ 

2. Navigate to: 

C:\Datasets\FAB463426\01 Creating a simplified view in Revit\ 

3. LMB select ‘AS-AK-00-ZZ-M3-A-00001.rvt’ (Revit Project File) and click 

on the ‘Open’ button. 

Tip: With the Revit ‘Open dialog’ open, navigate to ‘FAB463426-AU020-Dataset’ 

folder. 
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Now Right mouse button click over the ‘places’ bar and choose ‘Add current folder.’ This will 

create a short cut to the 

class dataset folder in 

your places bar.  

 

 

 

 

 

 

 

 

Browse the Revit project structure 

1. In Revit, look for the ‘Project Browser.’ 

2. Next to the ‘Views (all)’ node, click on the cross (+) symbol to expand the node. 

3. Next to the ‘3D Views’ node, click on the cross (+) symbol to expand the node. 

4. Look for the view called ‘Default 3D View.’ 

5. This view should be the current view. 

Tip: You’ll know ‘Default 3D View’ is current if the view name is in Bold text. The view name 

will also be shown at the tab of the current graphics window. 

Copy and rename an existing 3D View 

1. Right-click on the ‘Default 3D View’ node and select: 

‘Duplicate view> Duplicate.’ 

2. A new view will be created called ‘Default 3D View Copy 1’, and Revit will set it as the 

current view. 

3. Right-click on the ‘Default 3D View’ node and select: 

‘Rename’ 

4. Rename ‘Default 3D View Copy 1’ to ‘3D Circular Balcony.’ 

Tip: To change views, double the Left mouse button click on ‘Default 3D View’ to make it 

current. Double LMB click on ‘3D Circular Balcony’ to make it current again for the next 

exercise. 
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Filter the view 

To hide individual elements in a Revit view, hover over the element and use the tab key to cycle 

between overlapping elements. 

When you have the element highlighted that you want to remove, Right mouse button click and 

choose: 

‘Hide in View > Elements’ 
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Tip: Use ‘Hide in View > Category’, to hide all elements that belong to the same category, such 

as all walls or all windows. 

Tip: To select all instances of an element, select an element, then RMB click and choose 

‘Select all instances > Visible in View’ to select all instances of the same element. With the 

selection set active, you can now RMB click and choose ‘Hide in View > Elements’ to hide all 

instances of an element. 

Tip: You can hold down the CTRL and left mouse button click to select multiple elements from 

different categories. 
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A quicker way is to select everything and then use a filter to select only the elements we don’t 

want to see. 

If necessary, use the scroll wheel on your mouse to zoom out until you can see the whole Revit 

model. 

Tip: Hold down the scroll wheel on your mouse to Pan. Hold down the SHIFT key on your 

keyboard, plus hold down the scroll wheel on your mouse to orbit. 

1. In the graphics window, Left mouse button click and drag from the top left of the window, 

to the bottom right of the window; you should now have the entire Revit model selected. 

 

2. Navigate to: 

Modify | Multiselect (Tab) > Selection (Panel) > Filter (Button) 
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3. Click on the filter button. 

4. In the Filter dialog, notice that all Revit 

categories are represented. 

5. Click the ‘Check none’ button. 

 

 

 

 

 

 

 

 

 

 

 

6. Now select the categories we wish to hide: 

✓ Room separation 

✓ Doors 

✓ Furniture 

✓ Levels 

✓ Lighting Fixtures 

✓ Model Groups 

✓ Slab Edges 

✓ Specialty Equipment 

 

7. Click the OK button. 
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8. Only the items that belong to the categories we selected are highlighted. 

 

9. Right mouse button anywhere in the graphics window and choose: 

‘Hide in View > Elements’ 

 

10. The elements we don’t wish to see in Inventor are hidden.  

Only the items we are interested in are visible. 
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Use a Section box to crop the view 

We can also focus on the detail we are interested in by using a Section box. A Section box will 

crop the Revit model to just the area we are interested in. 

Tip: Before you start the next section, make sure that you don’t have anything selected by 

pressing the ‘Escape(esc)’ key a couple of times. 

1. In the Properties browser, under ‘Extents,’ check ‘Section box.’ 

2. A wireframe box will appear around the extents of the Revit model. 

3. Left mouse button click on the section box to activate it – Triangular handles will appear 

at the center of each face. 
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4. Use the triangular handles to crop the view of the model to show just the area around 

the circular handrail. 

 

5. Save your version of this file using: 

File > Save as > Project 

And then close this Revit file. 

 

Or go to: 

File > Close 

To close the file without saving and use the file I’ve prepared for you for the next 

exercise. 

Tip: Use the view cube to orient the view 

until you are parallel with the sides of the 

section box. 

To switch to an orthographic view, hover 

over the Viewcube and look for the options 

button (It looks like a rectangular bar, with a 

triangle underneath it). 

From the options, select ‘Orthographic’. 

When you are done, you can switch back to 

perspective mode the same way. 
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Extra credit 

To hide the section box, select it with a LMB click, then RMB click and chose: 

‘Hide in View > Elements’ 

 

 

To show the section box again, LMB click on the ‘Reveal hidden elements’ button from the Tool 

tray (It looks like a light bulb. It will turn Red when you click on it). 

 

Hover over the section box until it highlights, then RMB click and choose: 

‘Unhide in View > Elements’. 

 

Then LMB click on the ‘Reveal hidden elements button again. 

• How would you hide the section box again? 

• How would you add colour to the view? 

• How would you save the orientation and lock the view?  
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Exercise 02 - In Inventor, reference a Revit model into Inventor using ‘AnyCAD’. 

Before the release of Inventor 2021, we could only ‘Import’ a Revit project (.RVT) file into 

Inventor. 

This meant the file was converted from a Revit file to an Inventor file. The link to the original 

Revit file was lost. If the Revit file was updated, we would have to be import it into Inventor 

again. 

This meant that we had to re-create any references (projected sketches and relationships) that 

we had made between the Revit model and the Inventor model – this could be a lot of work! 

Additionally, we had no way of knowing what was in the Revit file until we had imported it. We 

would then have to do manual cleanup to delete any elements that we didn’t need. When we 

received an updated version of the Revit file – we would have to do this again! More work! 

Inventor AnyCAD for Revit file solves both these problems. We can reference a Revit project file 

into Inventor, taking advantage of any pre-defined views to filter the imported geometry. 

The link back to the original file remains ‘live’. If the Revit file is updated and saved, we will see 

the update in Inventor. Any relationships we have made will also update (within reason!). 

Let’s see how it’s done. 

In this Exercise, we will: 

• Open the data set for this exercise 

• Insert a 3D view of a Revit project file into our Inventor assembly 

• Browse the Revit project structure, and change the visibility state of an element 

• Insert an Inventor model, and constrain it to the Revit model. 

Open the data set for this exercise 

Before starting this exercise, please make sure that you’ve closed any files that you had open in 

Revit. 

1. From the Inventor home page, navigate to: 

Get started (Tab) > Launch (panel) > Open (Button) 

2. Navigate to: 

3. C:\Datasets\FAB463426\02 AnyCAD Revit to Inventor\ 

4. LMB select ‘Circular Balcony Location Assembly 01.iam’ (Inventor assembly file) and 

click on the ‘Open’ button. 
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Inserting a 3D view of a Revit project file into an Inventor assembly 

To use ‘AnyCAD’ to reference a Revit project into an Inventor assembly 

1. Navigate to: 

Assemble (Tab) > Component (Panel) > Place (Button) 

Note The ‘Place’ button always shows the last option 

used. It may read ‘Place from Content Center’ or ‘Place 

iLogic Component’, for example. 

Click on the bottom half of the ‘Place’ button to see more 

options 

2. Choose ‘Place Imported CAD File’. 

3. Browse to: 

C:\Datasets\FAB463426\02 AnyCAD Revit to 

Inventor\ 

4. LMB select ‘AS-AK-00-ZZ-M3-A-00002.rvt’ 

(Revit Project file) and click on the ‘Open’ button. 

5. In the ‘Import’ dialog, select ‘3D Circular Balcony’ 

from the drop-down menu. 

6. Check that ‘Reference model’ is selected. 

Click ‘OK’ 

7. You will see a preview of the Revit project ‘Float’ 

into your assembly, following your mouse cursor. 

8. Right mouse button click, and choose ‘Place 

Grounded at Origin’ 

9. Right mouse button click again and choose 

‘Cancel (esc)’ to finish placing instances. 

10. You can keep the file open for the next section. 
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Tip: ‘Place Grounded at Origin’ Places the Revit project into the Inventor assembly with the 

0,0,0 coordinate of the Revit file mapped to the 0,0,0 coordinate of the Inventor file. 

This means that we can work in the context of the building design, and when we export the 

Inventor model – it will map back to the correct location in Revit. 

TIP: If you are starting a new assembly/project, before opening any files you can ‘Import CAD 

Model’, under the ‘New’ button in the ribbon. This will create a new file, and insert the Revit 

reference model placed at the origin for you. 
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Browse the Revit project structure, and change the visibility state of an element 

First, we will create a new View in Inventor, which allows us to save the visibility state of 

components in our model.  

Then we will learn how to locate, select, and hide elements of the Revit model. 

Tip: Use the scroll wheel on your mouse to Zoom in and out. Hold down the scroll wheel on 

your mouse to Pan the view. Hold down the SHIFT key on your keyboard and hold down the 

scroll wheel on your mouse at the same time to Orbit. 

Pause over a component for two seconds to see a drop-down menu, which will allow you to 

select components that are on top of one another. 

1. In the Inventor model browser, expand the 

‘Representations’ node. 

2. Right-click over the node called ‘View:Default’, and 

select ‘New.’ 

A new view called ‘View1’ will be created. Left 

mouse button click once on this view to select it, and 

LMB once again to rename it. 

3. Name it ‘Circular Balcony location’. 

4. In the Inventor model browser, click the ‘+’ symbol 

next to the node that represents the Revit model. 

Note: Each Revit category is represented by a folder. You can browse the folder 

structure to look for elements. 

5. Hold down the SHIFT key and Right mouse button click at the 

same time. This short cut will bring up the selection filter. 

Note: you will also find the selection filter in the Quick Access 

Toolbar (QAT). 

6. Change the selection to ‘Part Priority.’ 

7. Select the handrail on the top of the circular balustrade. 

8. Right mouse button click and choose ‘Find in browser.’ 

In the Inventor model browser, you will be taken to the handrail 

element node in the Revit category folder 

9. With the handrail element selected, right mouse button click and select ‘Visibility’ to 

hide this element. 

Note: If you see the ‘Associative Design View Representation’ dialogue, select the OK 

button. 

10. Using a combination of the methods described, hide the stanchions and railing belonging 

to the circular balustrade. 

11. You can keep this file open - or close the file if you want to use the version I’ve prepared 

for you for the next step. 



 

24 | P a g e  

 

 

  

Figure 2 Using 'Find in browser' to find a Revit element in the Category folder structure 



 

25 | P a g e  

 

Insert an Inventor model and constraint it to the Revit model. 

Now we have a Revit model In Inventor, let’s see how we might design in the context of the 

Revit model. 

In this Exercise, we will: 

• Open the data set for this exercise 

• Insert an Inventor assembly. 

• Constrain the Inventor assembly to the Revit model 

Open the data set for this exercise 

If you still have the file open from the previous exercise – skip ahead. 

If you like, you can open this version of the Inventor assembly, that already has the Revit model 

inserted for you. 

1. From the Inventor home page, navigate to: 

Get started (Tab) > Launch (panel) > Open (Button) 

2. Navigate to: 

3. C:\Datasets\FAB463426\02 AnyCAD Revit to Inventor\ 

4. LMB select ‘Circular Balcony Location Assembly 02.iam’ (Inventor assembly file) and 

click on the ‘Open’ button. 
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Insert an Inventor assembly. 

We will now insert an Inventor model, which represents the manufacturing version of the circular 

balustrade. 

1. Navigate to: 

Assemble (Tab) > Component (Panel) > Place (Button) 

Note The ‘Place’ button always shows the last option 

used. It may read ‘Place from Content Center’ or ‘Place 

iLogic Component’, for example. 

Click on the bottom half of the ‘Place’ button to see 

more options 

2. Choose ‘Place’. 

3. Browse to: 

C:\Datasets\FAB463426\02 AnyCAD Revit to 

Inventor\ 

4. LMB select ‘Circular Balcony.iam’ 

(Inventor Assembly file) and click on the ‘Open’ button. 

5. A preview of the Circular Balcony will appear in the Inventor Graphics window, hovering 

near the mouse cursor. 

6. In the Inventor Graphics window, Left mouse button click in any empty space to place an 

instance of the Circular balcony assembly. 

7. To complete the command, Right mouse button click and choose ‘Cancel (Esc)’. 

8. To position, the circular balcony, navigate to: 

Assemble (Tab) > Relationship (Panel) > Joint (Button) 

9. In the ‘Place Joint’ dialog, from the ‘Type’ drop-down, set the Joint type to ‘Rigid’. 

10. For the first selection, pick the circular sketch at the center of the Balcony assembly. 

11. For the second selection, select the circular cut out from the Revit model. 

12. When the Circular balcony assembly has ‘jiggled’ into place, click the ‘OK’ button to 

complete the joint command. 

13. Save the file if you wish to keep using it or close the file if you want to use the version 

I’ve prepared for you for the next step. 

The location of the circular balcony assembly is now being driven by the location of the circular 

cut out in the Revit model. 

In the next exercise, we will see what happens when we update the Revit model. 
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Figure 3 Placing an Inventor assembly. Steps 1 to 6 

 

Figure 4 Positioning the Inventor assembly with a Joint - Steps 8 to 12 
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Extra Credit. 

If you are a confident Inventor user, you may be able to connect the diameter of the Inventor 

assembly to the diameter of the circular cut out in the Revit file. 

Watch the video for more detail on how to do this, or check out the finished version of the 

design from the dataset: 

C:\Datasets\FAB463426\03 Update Revit Model\Circular Balcony Location Assembly 03 

.iam 

1. Create an assembly sketch on the ‘floor’ of the Revit model. 

2. Project the circular cut out feature into the sketch. 

3. Place a reference dimension on the projected circle. 

4. Right-click on the dimension and choose ‘properties’ to rename the reference parameter 

to ‘Light_Well_Diameter’. 

5. Finish the sketch 

6. Create an iLogic rule. This rule will map the diameter of the light well into the diameter of 

the Circular balustrade, with a 200mm offset. 

 

Here is the code: 

'This rule passes the diameter of the light well into the balcony assembly 

Parameter("Circular Balcony:1", "Diameter_CL") = Light_Well_Diameter + 200 mm 

 

InventorVb.DocumentUpdate() 
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Exercise 03- In Revit update the Revit model. In Inventor Consume the update. 

Now we have a Revit model referenced into Inventor and an Inventor model whose location 

(and potentially size) is driven by the Revit Model. 

Now let’s imagine that we have received an update Revit model. This could be an update to the 

Revit model on our local server, an update coordinated by BIM360 docs, or simply a new 

version of the file which we would save over the top of the old one. 

We’ll replicate this by editing the Revit model ourselves, and then we’ll consume the update in 

Inventor. 

In this Exercise, we will: 

• Open the data set for this exercise In Inventor 

• Open the data set for this exercise In Revit 

• Edit the Revit model 

• Update the Inventor model 

Open the data set for this exercise 

If you still have the Inventor file open from the previous exercise – skip ahead. 

If you like, you can open the version of the Inventor assembly that already has the Inventor 

model inserted and linked to the Revit model. 

1. From the Inventor home page, navigate to: 

Get started (Tab) > Launch (panel) > Open (Button) 

2. Navigate to: 

3. C:\Datasets\FAB463426\03 Update Revit Model\ 

4. LMB select ‘Circular Balcony Location Assembly 03.iam’ (Inventor assembly file) and 

click on the ‘Open’ button. 

Now switch to Revit: 

1. From the Revit home page, look for ‘MODELS’ and click ‘Open.’ 

2. Navigate to: 

C:\Datasets\FAB463426\02 AnyCAD Revit to Inventor\ 

3. LMB select ‘AS-AK-00-ZZ-M3-A-00002.rvt’ (Revit Project File) and click on the ‘Open’ 

button. 
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1. In Revit, Use the project browser to navigate to: 

Views (All) > Floor Plans > 01 First Floor 

2. Double left mouse button click on ’01 First Floor’ to make the view active. 

3. Zoom in to the circular cut out feature. Hover your cursor over the edge of the shape. 

You should see a tooltip that reads ‘Shaft Openings: Opening Cut’. 

Left mouse button click to select the shaft opening. 

 

Tip: Hover your cursor over an element and use the TAB key to highlight each feature that is 

under your cursor. Left mouse button click to select when the circular shaft opening is 

highlighted. 
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4. With the shaft opening selected, navigate to: 

Modify | Shaft Openings (Tab) > Mode (Panel) > Edit sketch (button) 

5. Click on the ‘Edit sketch’ button 

6. Select the edge of the sketched circle. The dimensions will turn blue, indicating 

that you can edit them. 

7. Select the horizontal position dimension – change it from ‘4925’ to ‘5500’ 

8. Select on the vertical position dimension – change it from ‘3795’ to ‘2750’ 

9. Optional – select on the diameter of the circle. Change it from ‘3000’ to ‘4000’. 

10. To exit the sketch, navigate to: 

Modify | Shaft Openings > Edit Sketch (Tab) > Mode (Panel) > ✓ Finish Edit Mode 

(button)  

Tip: It looks like a green checkmark. 

11. Save the Revit project file by clicking on the diskette icon in the Quick Access Toolbar. 

12. You can leave the Revit project file open. 
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1. Switch to Inventor 

2. Look for the ‘Local/Global update’ button in the Quick Access tool bar – it should have 

a yellow ‘lightning’ flash symbol, indicating that there is an update pending. 

You may also notice a ‘Lightning flash’ icon next to the Revit model node in the model 

browser. 

 

3. Click on the Local/Global update button to update the Revit AnyCAD reference. 

4. Marvel as the location (and maybe even the size) of your Inventor design updates 

in response to the change in the Revit model! 

5. Return to Revit, and close the Revit file without saving. 

Note: If you save the Revit file, you’ll be asked to update the Inventor file again! 

6. Save the Inventor file if you wish to keep using it or close the file without saving if you 

want to use the version I’ve prepared for you for the next step. 

 

 

Figure 5 The Inventor design updates in response to changes in the Revit model 
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Exercise 04 – In Inventor, export the Inventor model. In Revit, import the Inventor model. 

In this class, we have learned how to reference a Revit file into an Inventor assembly to use a 

design reference. 

We have used the Revit model to locate and dimension our Inventor model, and we’ve seen 

how our Inventor model can be made to respond to updates in the Revit model. 

The next step in our BIM workflow is to output the Inventor file in a format that can be bought 

back into Revit for coordination. 

In Inventor 2021 this will be an IFC file.  

Tip: If you’d like to know what file formats Inventor may be supporting in the future, please join 

the Inventor feedback community by following this link: 

https://feedback.autodesk.com/ 

Why IFC? Why not a Revit family (RFA)? 

An IFC file is a Vendor-neutral BIM file format (a bit like Step). It is the equivalent to Revit 

project file (or an Inventor top-level assembly). 

An RFA file is a Revit family. A Revit family is equivalent to an Inventor sub-component file. 

A Revit family can be inserted at any orientation or location in a Revit project and can be used 

multiple times. 

An IFC file is ‘linked’ into the Revit project, and its location is mapped to the 0,0,0 coordinate of 

the Revit project file. 

Using a linked IFC file, we can demonstrate that our Inventor assembly has been designed in 

the correct location and orientation to suit the Revit model. 

In this Exercise, we will: 

• Open the data set for this exercise In Inventor 

• Create a new view 

• Export the Inventor model to IFC 

• Open the data set for this exercise In Revit 

• Link the IFC model into Revit. 

  

https://feedback.autodesk.com/
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Open the data set for this exercise 

If you still have the Inventor file open from the previous exercise – skip ahead. 

If you like, you can open the version of the Inventor assembly that already has the Inventor 

model inserted and linked to the Revit model. 

1. From the Inventor home page, navigate to: 

Get started (Tab) > Launch (panel) > Open (Button) 

2. Navigate to: 

3. C:\Datasets\FAB463426\ 04 Export to Revit\ 

4. LMB select ‘Circular Balcony Location Assembly 04 .iam’ (Inventor assembly file) 

and click on the ‘Open’ button. 

Creating a new view for export 

Before we export our Inventor model to IFC, we will 

create a new view so that we can hide the Revit model 

– and prevent the Revit model from being inserted into 

itself! 

1. In the Inventor model browser, Expand the 

‘Representations’ node and the ‘View’ node. 

2. Right-click over the top-level ‘View node.’ 

Note: It should currently be set to ‘View: Circular 

Balcony Location’- from the previous exercise. 

3. Select ‘New’ from the right-click menu. 

4. A new view will be created called ‘View1.’ 

5. Left-click on ‘View1’ once to select it, and left-

click on ‘View1’ a second time to rename it. 

6. Rename this view ‘Export to IFC’ 

7. In the Inventor model browser, right-click on the 

Revit reference node and select ‘Visibility’ to 

hide it in this view. Only our circular balcony 

should be visible. 

8. Use the ‘Diskette’ Icon in the Inventor quick 

access toolbar to save the file. 
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Exporting an IFC file from Inventor 

1. To export an IFC file from Inventor, navigate to: 

‘Environments’ (Tab) > ‘Begin’ (Panel) > ‘BIM Content’ (Button). 

 

2. In the ‘BIM Content’ Environment, navigate to: 

‘BIM Content’ (Panel) > Publish (Tab) > Export Building Components’ (Button)’ 

 

3. In the ‘Autodesk Inventor Professional’ dialog, click on ‘No.’ 

Note: Autodesk Inventor contains tools to help you simplify your Inventor assembly in 

preparation for exporting to Revit. Unfortunately, we don’t have time to cover them in today’s 

class. 

I’ll make sure that there are some links to more information on simplification in the 

references section of this handout. 

4. In the ‘save as’ dialog, browse to: 

C:\Datasets\FAB463426\04 Export to 

Revit 

5. Name your file 

‘Circular_Balcony_For_Coordination’ 

6. From the ‘Save as Type’ drop-down, pick 

‘IFC2x3(*.ifc)’ 

7. Click the ‘Save’ button. 

8. Take a short break while your IFC file is 

exported. 

9. Click ‘OK’ 

10. Optionally, view the translation report. 
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Linking an IFC file into Revit 

In this section, we will learn how to link an IFC file into Revit. The advantage of linking a file into 

Revit is that it will automatically be inserted with matching 0,0,0 coordinates. Our Balcony 

balustraded design will appear in exactly the right location to match the Revit project file. 

On a Real BIM project, the BIM coordinator, Architect, or General contractor can use this 

technical to coordinate your geometry with the design model. It’s a huge improvement in sharing 

‘flat’ 2D drawings! 

In this Exercise, we will: 

• Open the data set for this exercise In Revit 

• Link our IFC file into Revit 

Open the data set for this exercise 

I have prepared a version of the Revit dataset for you that contains a view with the Revit model 

of the balcony hidden. The dimensional changes from the previous exercise have been applied. 

1. From the Revit home page, look for ‘MODELS’ and click ‘Open.’ 

2. Browse to: 

C:\Datasets\FAB463426\04 Export to Revit 

3. LMB select ‘AS-AK-00-ZZ-M3-A-00004.rvt (Revit Project File) and click on the ‘Open’ 

button. 

Note: A new Revit view has been created and set current. It’s called ‘3D Circular Balcony 

Coordination,’ and the Revit model of the Circular balcony balustrade has been hidden. 

Link our IFC file into Revit 

To link an IFC file into the current Revit Project 

1. In Revit, navigate to: 

Insert (Tab) > Link (Panel) > Link IFC (Button) 

2. Click on ‘Link IFC’ 
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4. In the ‘Link IFC’ dialog - browse to: 

C:\Datasets\FAB463426\04 Export to Revit 

5. Under ‘Files of Type:’ Pick ‘IFC Files (*.ifc)’ from the drop-down. 

6. LMB select ‘Circular_Balcony_For_Coordination’.ifc’ (IFC File) and click on the 

‘Open’ button. 

Note: If you had a problem exporting the 

Inventor file to IFC. Please use this file, which 

I have prepared for you: 

C:\Datasets\FAB463426\04 Export to 

Revit\Circular_Balcony_For_Coordination 

(Finished).ifc 

3. Be patient. 

4. The IFC file will be loaded into the Revit 

project and will appear in the correct 

location on the screen. 

 

  

Figure 6 The completed workflow. The Inventor model is linked into Revit for coordination 
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Tip: To manage your linked files, navigate to: 

Insert (Tab) > Link (Panel) > Manage Links (Button) 

 

  



 

39 | P a g e  

 

Conclusion 

Buildings are built from components that are made by manufacturers. There is no escaping the 

role of manufacturers in the construction industry; from the processing and manufacturing of 

building materials to building products and equipment and specialist construction systems, one 

industry could not exist without the other. 

The construction industry has a poor reputation for efficiency and productivity, and it is looking 

to manufacturing for guidance on optimizing, and automating how we make buildings. 

The worlds of manufacturing and construction are rapidly converging; it’s more important than 

ever that the tools we use to design and make our products help us to collaborate effectively. 

In this presentation, we saw a workflow that helps custom fabricators like you to reference a 

Revit model into Inventor to use as a design reference – to make sure that your designs are 

coordinated with the design model. 

I hope that you found this class useful and that you have the confidence to try out this workflow 

for yourself. Please send me your feedback on this class to Paul.Munford@Autodesk.com. 

What next? 

Use it or lose it! Make sure that you practice this workflow to ensure that you remember how it’s 

done. Test it with your own dataset. 

Please feel free to share this class with your colleagues or use the dataset, handout, and video 

to conduct training in your company. 

If you’d like to have your say on what we can do to improve this workflow, please leave a 

message on the forum, a suggestion on the ideas board, or join the feedback community to test 

new functionality, which may be included in future versions of Revit and Inventor. 

Check out the ‘Resources’ section of this handout for details. 

Thanks 

Thank you very much to my colleagues who help me to put this presentation together: 

Jon Bagley 

Marc Sauro 

Jim Byrne 

 

Any mistakes remaining in this document are mine alone! 

  

mailto:Paul.Munford@Autodesk.com
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Resources 

If you want to learn how to make Revit families (.rfa) with Autodesk Inventor, make sure that you 

also watch: 

‘Anybody Can Do IT: Easily Build Revit Content in Inventor’ by Pete Strycharske 

 

If you want to know what ‘Might’ be coming up in future versions of Inventor, watch: 

Looking into the Crystal Ball: The Future of Inventor by Garin Gardiner 

Both classes can be found in the AU2020 conference schedule. 

 

Find more free classes on Autodesk Inventor’s BIM workflows from previous AU’s on Autodesk 

University online: 

Revit and Inventor class at Autodesk University On-line 

I can recommend this class: 

‘Providing Manufacturer-Specific BIM Content for Revit from Inventor’ 

And this one: 

‘Do You REALLY Want Manufacturer’s Content? Success Stories in Repurposing 

Manufacturing for BIM’ 

Ask questions and look for answers in the Autodesk Inventor Community Forums 

Suggest your ideas, or vote on the ideas of others – how can we improve Inventor? 

Autodesk Inventor 'Ideas' 

Join the Autodesk feedback community. Try out new prototypes of new functionality for future 

releases and have your say on the future of Autodesk products: 

https://feedback.autodesk.com/ 

Find us on social media: 

YouTube 

Twitter 

Linkedin 

Facebook 

Instagram 

https://www.autodesk.com/autodesk-university/au-online?query=bim&facet_product%5B0%5D=urn%3Aadsk.content%3Acontent%3A4594dd66-7b8c-45dd-9bb2-1df1b909e871
https://www.autodesk.com/autodesk-university/class/Providing-Manufacturer-Specific-BIM-Content-Revit-Inventor-2016
https://www.autodesk.com/autodesk-university/class/Do-You-REALLY-Want-Manufacturers-Content-Success-Stories-Repurposing-Manufacturing-BIM-2017
https://www.autodesk.com/autodesk-university/class/Do-You-REALLY-Want-Manufacturers-Content-Success-Stories-Repurposing-Manufacturing-BIM-2017
https://forums.autodesk.com/t5/inventor-forum/bd-p/78
https://forums.autodesk.com/t5/inventor-ideas/idb-p/v1232
https://feedback.autodesk.com/
https://www.youtube.com/user/AutodeskMFG/featured
https://twitter.com/Adsk_Inventor
https://www.linkedin.com/groups/130938/
https://www.facebook.com/adskinventor/
https://www.instagram.com/adskinventor/

