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Introduction 

Robot Structural Analysis Professional is an incredibly powerful tool for general purpose structural engineering, analysis and design.  No 

engineer I know would switch analysis programs without a fairly thorough investigation of the capabilities and detailed operation of the 

software.  We’re responsible for life safety and few, if any of us take that responsibility lightly.  This tutorial will get you started on the road to 

your own investigation of Robot Structural Analysis. 

The Goal of this Tutorial 

My goal in writing this tutorial is to give you a guided, step-by-step tour of the software.  I want to give you enough experience exercising the 

various features and functionality and a guide through the major workflows in the software such that you gain enough confidence in the 

fundamentals that you can begin your own investigation of the tool and compare it with previous designs you may have done with other 

software to see where it’s the same, and if different, to be able to dig into why it’s different.  We will cover the basics: interface, navigation, 

setup, display, simple modeling, basic loading, seismic, results exploration, and basic material design workflow.  We want you to have a good 

map of the functionality that you can start your own investigation and dissect models to learn more about them. 
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Robot General Capabilities 

 Structural Modeling for linear members, planar members, shell members, and solids. 

 Thorough loading and boundary conditions including standard nodal, linear, and surface loads as well as advanced loading 

(acceleration, time varying loading, displacements, temperature, etc.) 

 Advanced meshing capabilities for shell elements 

 Full complement of analysis types including static, non-linear, non-linear/p-delta, modal, moving load, time-history, buckling, and 

pushover 

 Full implementation of AISC Direct Analysis Method 

 Over 70 different country codes for material design: 40 for steel and 30 for concrete 

 Through documentation functionality for presentation of calculation results. 

 Full featured application programming interface (API) for creating custom solutions or advanced functionality and customized design. 

General Limitations 

While there are a tremendous number of capabilities of the software, there are a few items which are not currently supported by Robot 

Structural Analysis:   

 Composite design not supported 

 Pre-stress/Post-tension not directly supported 

 Steel strength and serviceability design are asynchronous. 
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 Section 1 - Getting Started 

The Robot Interface 

Open Autodesk Robot Strucutral 

Analysis and select “Building Design” 

under New Project.  If you don’t see 

building design, click “More…” and 

choose Building Design from the list of 

project templates 
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Robot will open the building design 

template.  Take a look at the interface 

components: 

 

In particular notice the view tabs at the 

top.  The building design template is 

the only Robot template with these two 

tabs.  They are not view tabs like you 

might expect, they are tabs within this 

one view (the main view).   
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When Robot first opens, the cursor will 

be in Zoom/Pan/Oribt mode so press 

escape to exit this mode.  Notice that 

there is no view cube in the plan tab, 

but if you switch to the view tab you will 

see the familiar view cube: This works 

exactly like it does in AutoCAD or 

Revit.  Other view controls which I use 

constantly are the middle mouse button 

to pan, middle mouse wheel to scroll 

and holding down the shift key and the 

middle mouse button to orbit a view.  I 

find this completely intuitive but you 

are welcome to use the view cube, 

and/or the view commands from the 

view menu for zoom, pan, and orbit. 
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Project Setup (5min) 

We’ll start with some project setup.  

Open project settings from the tools 

menu: Tools>Job Preferences… then 

select “Imperial” for the default units.   

 

Next, select the Materials item on the 

left and select “American” for the 

materials.  Then choose A992-50 for 

steel from the Steel dropdown menu. 
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Next expand “Databases” and if AISC 

and SJI are not available, select the 

“Add a new database” button at the top 

and select AISC then repeat for SJI  

(note, SJI is at the bottom of the list) 

Use the “UP/DOWN” arrow buttons to 

move AISC to the top of the list for 

better organization later. 

 

Next, Select “Design Codes” and for 

“Steel/Aluminum structures” select 

“AISC 360-10” and for “RC Structures” 

select “ACI 318-11” 
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Before we move on, in the steel 

dropdown, choose “more…” to see the 

full list of codes supported by Robot.  

The “Codes” dropdown on the left will 

allow you to browse the different code 

categories and the right arrow button 

(“>”) will allow you to add the code to 

the active list. 

 

Next, expand “design codes” and choose 

“Loads”.  Under loads, select “LRFD 

ASCE7-10” for “Code Combinations”, 

and “IBC2012” for “Seismic”.   

Once you’ve done that, press “Save 

current parameters as default” and 

then press “OK”. 
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Section 2 – Structural Modeling 

Modeling Structure Axes (5min) 

We’re going to start by laying out some 

project axes to draw our structure.  

These are not required, you can simply 

get out there and start clicking 

members if you like.  The grids are just 

helpful for reference and snapping 

points.  Open the grids dialog from the 

Geometry menu: Geometry>Axis 

definition. Or use the axes button from 

the modeling toolbar on the right:  
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On the “X” tab, enter 0.0 for the 

position, then 2 for “No. of repet:” and 

30.0 for Distance and select “1 2 3…” for 

Numbering at the bottom then press 

“Add”.   

You should now have 3 X axes 1, 2 and 

3 at positions 0, 30, and 60 as shown 

here 
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Now Switch to the “Y” tab and do the 

same except use 20 for the spacing 

which will give us a rectangular layout 

and choose “A B C…” for numbering. 
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Next, give us Z grids of 0, 14, and 28 and 

use “value” for numbering 

 



Robot Structural Analysis: Making the Change 

15 

 

Then click “Apply” and “Close”  Your 

model should look like this: 
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Now we’ll set up our stories to match 

the levels we’ve added.  Stories will be 

used in seismic analysis.  Open Stories 

configuration from 

Geometry>Stories>Stories…  First 

select “Define Manually” then enter “1” 

for “No.of Repet” and 14.0 for “Height” 

then press “Add”.  Your dialog should 

look like this: 
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Modeling Columns and Beams (15min) 

Now we’ll move into laying 

out beams and columns 

for our model.  You can 

continue with your 

current file, or you can 

open Dataset 1 – Setup 

and Grids.rtd to catch up.   

We’re going to start by 

orienting the project view 

to plan.  Down at the 

bottom of the view, use the 

dynamic view controls to 

orient to “XY’ in the first 

control and then select 

“Story 1 – 14.00ft” from 

the second control as 

shown here: 
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Next, we’re going to 

configure some sections 

for us to use.  From the 

geometry menu select 

Properties>Sections… or 

use the sections button 

from the modeling toolbar 

on the right:  

This is the section labels 

dialog.  It is used to 

configure and apply 

section labels to elements. 

 

Let’s configure a few 

sections to use.  First click 

the new section button on 

the toolbar of this dialog:  
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In the New Section dialog, 

make sure that the 

“Section Type” dropdown 

is on “Steel” (look at the 

other options there too).  

Then select “AISC 14” for 

the database, “HSSQ” for 

the Family and “HSSQ 

5x5x0.25” for the Section.   

Then press “Add”. 

 

Repeat this for the 

following sections 

“W12x19”, “W18x35”, 

“HSSQ 6x6x0.25”, and see 

if you can get a 14k1 joist 

added to the labels list as 

well and the close the New 

Section dialog:  Your 

Section labels dialog 

should now look like this: 
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Next, start the column 

placement tool from the 

Geometry menu: 

Geometry>Columns…  

Notice that, if you select 

“Steel Column” from the 

section type drop down, 

our newly configured 

sections will be available.  

Pick HSSQ 5x5x0.25 and 

make sure that “Height” is 

14.0 and Orientation is 

“Down (Z-)”. 
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Next click to place 

columns at each grid 

intersection as shown 

here. 
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If you happened to orbit 

the view around to see the 

columns, bring it back 

with the dynamic view 

controls, then open the 

beams placement editor 

from 

Geomtery>Beams…Select 

“Steel Beam” for section 

type and “W18x35” for the 

Section. 
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In the project click to place 

beams by clicking the 

start point and the end 

point of each beam.  We 

want W18x35s on girds 1, 

2, and 3.  (right click and 

choose display>Bars>Bar 

descriptions>Section 

Names to see text 

descriptions) 

 



Robot Structural Analysis: Making the Change 

24 

 

Do the same thing for 

W12x19 and put them on 

the column lines in the 

other direction: 
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Next we’ll put joists in for 

the floor.  Just click and 

place each one, use 

coordinates, or you could 

divide members without 

splitting to add nodes, 

and use 

Edit>Edit>Move/Copy… 

to quickly lay them out.  
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Orbit your model around 

to see your handiwork:  

Then use crossing 

selection to select all the 

elements then start the 

copy command from 

Edit>Edit>Move/Copy…  

then make sure “copy” is 

selected, and enter “1” for 

“Number of repetitions”, 

then click once in the 

“Translation Vector” edit 

control then move into the 

project and click the 

bottom of a column and 

then the top to copy:  (You 

can also type in 0,0,14 for 

the translation vector and 

then press “Execute”) 
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Now we’ll make sure we 

have elements assigned to 

the correct stories by 

selecting 

Geometry>Stories>Assign 

Geometrically…  Accept 

the defaults and press 

“Apply” and “Close” 
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Check your stories by 

using Filter stories or 

View>Display>Mark with 

Colors>Stories – legend by 

colors to get visual 

feedback on proper story 

assignment. 

 



Robot Structural Analysis: Making the Change 

29 

 

Let’s add some braces 

with the Bars tool from 

Geometry>Bars…  Set 

“Bar Type” to “Simple 

Bar”, “Section” to “HSSQ 

6x6x0.25” then click, 

snapping to member ends 

to place concentric braces 

on each of the four sides of 

the structure: (use the 

section shapes button at 

the bottom to see physical 

geometry) 
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Check our stories again.  

Fix any problems you 

notice… 
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Floor and Roof Decks (5min) 

You can continue with your current 

file, or you can open  Robot Dataset 

2 - Beams and Columns.rtd to catch 

up.   

Let’s get back to our XY view at 

story 2 level to facilitate placement 

of the second floor deck.  First we’ll 

configure our deck thicknesses and 

then create the deck elements.  

Open the thickness label dialog.  

Geometry>Properties>Thickness… 

or using the Thickness button from 

the modeling toolbar:  

Choose “orthotropic” 

Label: SlabOnDeck 

“Slab composed with trapezoidal 

plate” 

h: 5.00 

h1: 1.5 

Then Press “Add” 
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Do the same for the roof deck, 

selecting “Trapezoidal plate” and 

1.5” for “h”.  You can be more 

specific with the rib dimensions but 

it is not necessary for this tutorial. 

Add the roofdeck to our list of 

thicknesses and next we’ll setup 

calculation models. 
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Now that we have thicnkesses, we’ll 

configure our calculation models. 

Open Panel Calculation Models 

from the 

Geometry>Properties>Panel 

Calculation Model… 

Click on the new button to add a 

new model and configure the 

parameters of RoofDeck as shown.   

Make sure to “Add” it to the list of 

labels.  
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Do the same thing for the floor deck 

but use these settings: 

Add it to the label list and then 

close the labels dialog. 
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Start the floor tool from 

Geometry>Floors… or from the 

modeling tool bar with the Floors 

button:  

Select “SlabOnDeck” for the 

Thickenss 

Select “Floor Deck Model” for the 

Model 

Select “Rectangualr” for Definition 

method. 

Next, click intersection of grid 1C, 

1A, and 3A to define the three 

points of the rectangular floor. 
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Move up to the roof level and repeat 

to create the roof deck: 
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Section 3 – Loads and Calculations 

Loads and Boundary Conditions (10min) 

You can continue with your current 

file, or you can open   Robot Dataset 

3 - Floor and Roof Decks.rtd to 

catch up.   

The first thing we’ll do is set up our 

boundary conditions.  To do this 

we’ll open the “Supports” label 

dialog from 

Geometry>Supports…or the 

supports icon from the modeling 

toolbar:  

Click “new support definition” 
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Give our support a name “Pinned 

Base” and tick the UX, UY, and UZ 

directions then press “Add”. 
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Now our supports lables dialog 

should have our new “Pinned Base” 

support definition.  We need to 

apply it to the base nodes of our 

structure.  We’ll use the selection 

dialog to accomplish this task.  

First start the node selection dialog 

from the selection bar:  

Use the “Geometry” Tab and select 

Zaxis from 0.00 to 0.00 then use the 

double up arrow to create the 

selection:  
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Next, click into the “Current 

Selection” edit control and the 

selection will automatically 

populate.   

Then select the “Pinned Base” label 

and press the “Apply” button to 

apply the label to the nodes. 
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Check the support in the Nodes 

Table.  From View>Tables… select 

the “Nodes” table. 

You can see that our “Pinned Base” 

support has been applied to the 

nodes we selected. 

 

 

Now let’s create some load cases 

Open the Load Types Dialog from 

Loads>Load Types…Add the 

following Types. 

Number Nature Label Name 

1 Dead DL1 DL1 

2 Live LL1 LL1 
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These are our basic load cases to 

which we will add our loads. 

 

3 Snow SN1 SN1 

4 Wind W_EW W_EW 

5 Wind W_NS W_NS 
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Close the Load Types dialog and 

before opening the load definition 

dialog, go ahead and turn on panel 

descriptions.  Note the panel 

numbers for the floor and roof.  I 

have 75 and 76 respectively, yours 

may differ. 

 

Start the Load Definition dialog 

from Loads>Load Definition… and 

select surface tab and click Uniform 

Planar Load.  
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In the Uniform Planar Load Dialog 

enter -0.015 for the Z value and 

press “Add” 

 

Now you’re back in the Load 

Definition dialog, Choose 1:DL1 

from the load case selector: 
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Check to see that the Load 

Definition Dialog has the DL case 

shown then enter the roof deck 

element number in the “Apply to” 

edit control and press “Apply”. 

You will see your load created in the 

view as visual feedback of the 

application. 

 

Do the same for Floor Dead, Floor 

Live, Snow, and Wind uplift on the 

roof 

Floor Dead (DL1) Z: -0.025 

Floor Live (LL1) Z: -0.050 

Snow Load (SN1) Z: -0.040 

Wind Load (W_EW and W_NS) Z: 0.02 
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Take a look at the loads table for 

verification:  View>Tables>Loads 

 

Next we’ll apply wind loads for the 

side walls as linear loads at the 

levels as though there were vertical 

studs distributing the loads to the 

floors. 

Back in the Load Definition Dialog, 

select the Bar tab and “Uniform 

Load” then in the Uniform load 

dialog, enter 0.140 for the Y value 

of load at the roof then Press “Add” 
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Make sure W_NS is selected in the 

case selector then use the click-to-

apply method to apply the load to 

the windward beams on the south 

wall.  Then do the same for the floor 

portion of Y: 0.280 kip/ft on the floor 

level beams 
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Do the same for W_EW with the 

same load magnitudes 
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Configure Basic Seismic Load (10min) 

You can continue with your current 

file, or you can open    Robot Dataset 

4 - Loads and Boundary 

Conditions.rtd to catch up.   

We’ll configure an equivalent 

lateral load seismic load from the 

Analysis types menu.  

Analysis>Analysis Types… 

Select “New” 
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Give your new analysis a name like 

“Seismic” and select “Seismic 

(Equivalent Lateral Force Method)” 

then press “OK” 
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Now you will need to specify the 

parameters for the seismic loading.  

On the Seismic Analysis dialog, 

select all 4 eccentricities, ASCE7-10 

for the Seismic analysis according 

to, and “Precise (Modal analysis) for 

the “Method of defining values of 

fundamental period” as shown here 
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The only other thing we’ll need to 

configure here are the “Seismic 

Analysis Parameters” press this 

button to open the parameter 

settings for ASCE 7-10.  We’ll 

configure site class B with an R 

factor of 3.  Press “OK” once you 

have configured these settings.  

Then press “OK” in the Seismic 

analysis dialog. 
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Now your Analysis types dialog will 

list your new modal analysis as well 

as the seismic load cases which use 

the modal analysis as input.  Take 

a quick look at the list of load cases 

generated for you. 
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Let’s go ahead and run calculations 

at this point to generate our seismic 

loads and let us look at the results 

We may get a warning about the 

joist span, and we may get some 

type 3 instabilities (these are due to 

the type of deck we selected because 

the stiffness laterally is very very 

small and causes a big difference in 

the overall range of the stiffness 

matrix.  We may also get a 

suggestion to use DSC algorithm 

for structures with releases; the 

joists are released for bending at 

their ends.  This is an algorithm 

that facilitates dynamic and non-

linear analysis of structures with 

member end releases, you can read 

more about it in the help files and it 

it enabled in job 

settings>structural analysis.) 
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Now that calculations have been 

run, we can start looking at our 

seismic loading.  We’ll start by 

looking at our modal analysis.  

Open the modal analysis results 

from Resutls>Advanced>Modal 

Analysis.  

Here you can view your structure 

natural frequencies and periods 

calculated by Robot. 
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Next we’ll look at the mode shapes 

for our building.  Close the modal 

analysis table and go to 

Results>Diagrams for bars… 

which will bring up the Diagrams 

dialog.  Go to the “Deformation” tab 

and check “deformation” Then 

press “Normalize” 
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Next use the load case selector to 

change to the modal analysis case 

and then look just to the right for 

the mode selector and pick mode 1 

Now you will see the mode shape as 

applied to the model. 

Take a moment to look through the 

other mode shapes for the building. 
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Next we’ll look at the loading 

generated for the seismic cases by 

starting with the calculation notes. 

From the analysis menu choose 

Analysis>Calculation notes>full 

note. 

Scroll down the report and look for 

our first seismic case “ Case 7: 

ASCE 7-10 / IBC 2012 Direction_X” 

Note the fundamental period 

selected, the total seismic weight W 

of 200.81kips and the total base 

shear force.   

You should be able to do some quick 

verification of the values calculated 

here. 
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The last thing we’ll look at is the 

reduced forces for the building 

applied as a result of these seismic 

cases.  Open the Building diagrams 

from the results menu: 

Results>Diagrams for Buildings. 

In this dialog switch to the “Forces” 

tab and turn on “Reduced forces in 

G” for FX, and FY then tick the box 

by “Descriptions” and then press 

“Normalize”.   

Note that you will need to switch to 

one of the seismic load cases… 

(You can also use this tool to look at 

total lateral load from other lateral 

cases like wind load.) 
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Load Combinations and Calculations 

You can continue with your current 

file, or you can open     Robot 

Dataset 5 - Seismic Load.rtd to 

catch up.   

Now we want to generate load 

combinations to use in analysis.  

We’ll start from the Loads menu 

Loads>Automatic Combinations… 

In the Load Case Combinations 

Dialog, select “Manual 

Combinations – generate” then 

press “More” 
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Now we will configure the 

parameters that control which 

combinations are created.  On the 

first page (Combinations) leave all 

USL and SLS checked: 
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Next, switch to the Groups tab.  

Take a moment to look through the 

groups.  They are arranged by 

nature.  Note especially the two 

wind load cases have been grouped 

with an “Or(excl)” and that there 

are actually several groups created 

for the seismic load cases.  Take a 

look at what operator has been 

applied to each group. 
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Next, switch to the relations tab 

and again review the relations 

which have been set up.   

Notice that for seismic, where we 

had several different groups, each 

group has been added with a 

relationship to the other groups.  

What we have here is that each 

seismic load case group has been 

related to every other by an 

“or(excl)”. 

Groups and relations are 

REQUIRED for generation of load 

combinations.  Make sure they are 

set up properly. 
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Press the “Next” button to be taken 

to the list of combinations that 

Robot plans to create for you.  

Check all that you want to use, or 

use the “check all” button at the 

bottom then press “generate” 

 

Now Take a look at your Analysis 

types dialog and you’ll see your 

newly added load combinations 

right after your load cases: 
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At this point, we want to run 

calculations to start looking at 

results and getting ready for 

material design. 

Press “Calculations” in the 

Analysis Types Dialog. 

Pretty painless and we have a 

couple of errors/warnings but we’ll 

ignore them for now.  In this 

particular model, DSC algorithm 

doesn’t seem to make any 

difference in the modal analysis 

and we know that a 14k1 won’t go 

30’-0” (no surprise there) 
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Section 3 - Results 

Exploring Results for Bars 
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You can continue with your 

current file, or you can open      

Robot Dataset 6 - Load 

Combinations.rtd to catch up.   

Let’s start by looking at results 

for bars (linear elements).  We’ll 

open the diagrams dialog again 

from Results>Diagrams on 

Bars… 

If not selected, switch to the NTM 

tab and tick My to look at major 

axis moments on the elements.  

Press “Normalize”: 

Use the Load Case selector to 

look at different load 

cases/combination or envelopes. 
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Try some of the options on the 

“Paramters” tab to adjust the 

display results to show result 

magnitudes, or change the 

display style of the diagrams. 

Here we have differentiated 

positive and negative moment 

and added labels at the global 

extremes of the result values. 
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Next we’ll take a quick look at the 

result tables for reaction, 

member forces, displacements. 

Access each of these from 

Results>Reactions, 

Results>Forces, 

Results>Displacements 

Not that results are arranged by 

Node/Case   

Of particular interest might be 

the Envelope tab at the bottom.  

This tab will show you 

summarized results for each node 

and each force component. 

Here we see the max and min 

values for reaction FX at node 1 

and the associated load 

case/combination which 

generated this max/min value. 

Use the load case selector to 

remove the simple cases from the 

results to see only combination 

effects. 
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Exploring Results on Surfaces 

Now we want to take a look at 

results for surfaces, in particular 

our roof deck. From the results 

menu, select Results>Maps… to 

access the Maps dialog. 

Let’s look at the diaphragm shear 

in our roof diaphragm by ticking 

xy under Membrane forces – N as 

shown here and select case 

W_EW for the load case to 

display. 

Take a few moments to try some 

of the different options here 

including the display options at 

the bottom of the dialog.   
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You can also get a quick look at 

the deflection on the surface to 

see what you’re dealing with.  

Just tick the “z” box under 

“Displacements – u,w”. 

The legend on the lower right is 

helpful in getting your bearings: 
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Section 4 - Steel Design Workflow 

Configuring Member Types 

You can continue with your 

current file, or you can open      

Robot Dataset 7 - Results 

Exploration.rtd to catch up.   

The first step of steel design is 

properly configuring the 

“member types” these are the 

code (AISC, and other) 

parameters assigned to the 

members which will govern the 

member design.   

Open the code parameters dialog 

from the Design menu: 

Design>Steel Members Design – 

Options>Code Parameters… 

This will bring up the “Member 

Type – AISC 360-10” dialog.   

 

 



Robot Structural Analysis: Making the Change 

73 

 

 

Let’s add some types to represent 

our members.  Start by clicking 

on the “new steel member type 

definition” button to bring up the 

member definition dialog. 

Member type will be Joist for our 

joists. 

Make other settings as shown 

here and then save it. 
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Next we’ll create the member 

type for our tie-beams which we 

assume will be fully laterally 

supported by the deck. 

Member Type TieBeams: 

Buckling length coefficient for z 

axis will be 1.0, leave flexural 

torsional and lateral buckling 

alone as we do not expect either 

of these failure modes. 
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While we’re still on TieBeams, 

let’s also configure the deflection 

limits for this member.  Press 

“Service” on the right hand side to 

access the “Serviceability – 

Displacement limiting values” 

dialog: 

For live loads, check relative 

under uzl max with 360 and 

relative under uzt max and enter 

240 as shown: 

Then press “OK” and “Save” this 

TieBeam definition. 
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Next we’ll configure the girders 

which we expect to only be 

laterally supported by the 

adjoining members, not the roof 

deck.  Create a new member type 

called “Girders” and for the top 

flange press the   button to 

access the intermediate bracings 

dialog: 

Tick the box next to “Define 

manually coordinates of existing 

bracings” and enter “0.25, 0.5, 

0.75” and make sure “relative” is 

checked.  This will define lateral 

bracing at the top flange at the 

quarter points.   

The dialog graphic indicates 

locations of bracing to give you 

visual feedback about the 

locations of actual bracing. 
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Don’t forget to tick the box by 

“Lateral Buckling” so that Robot 

will consider lateral flange 

buckling in the member design 

checks.  Your Girders should look 

like this: 

Note, unless you started with a 

new member, your service 

criteria will be the same as your 

tie-beams.  Give it a quick check 

to see. 
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Now we’ll configure columns and 

bracings using a buckling length 

coefficient of 1.0 and no lateral 

bracing along the length of the 

members. 
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Close the Member definition 

dialog and we’ll go ahead and 

apply these labels to our 

members.  In the Member Type 

dialog, select joists and then click 

in the “Lines/Bars” field.   

 

 

We now need to build a selection 

of members to which we will 

apply this member type label. 

First click on the bar selection 

button on the selection toolbar: 
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In the Selection Dialog we can 

select the 14k1 attribute and 

press the double up arrow to add 

all 14k1s to the selection. 

Copy this selection to the 

clipboard with Ctrl+C after 

selecting the selection set (in this 

example, “22to33 55to66” 
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Paste this into the member type 

label dialog in the “Lines/Bars” 

field.  (you may find that it 

automatically populates) 

Then press “Apply” 

Repeat this process for the 

girders (W18x35s), the tie-beams 

(W12x19s), and the columns 

(HSSQ5x5x0.25 and 

HSSQ6x6x0.25) then use 

View>Display>Bar descriptions 

to show the member types: 
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Configure Design Groups 

Now we need to configure design 

groups to control the member 

design.  Open the steel design 

layout from the design menu: 

Design>Steel Members Design… 

Click on the “groups” tab in the 

“Definitions” dialog: 

Press the “new” button, enter 

“Roof Joists” for the Name. 
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Next we’ll configure a selection of 

roof joists only by combining two 

options in the bar selection 

dialog.  Launch the bar selection 

dialog and first switch to the 

“Geometry” tab, select “Z axis 

from-to” and select “Structure 

Axis Story 2 – 28(ft)” for each 

dropdown then press the double 

up arrow: 
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Next we’ll pull only items which 

match the section type we’re 

looking for.  Switch to the 

“Attrib.” tab and select 14k1 but 

this time press the “And” button: 

 

 

Copy paste this selection 

(“55to66” in my example) to the 

“Member list” field of the groups 

definition. 
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Next, Press the “Sections” button 

to configure allowable trial 

sections for design.  Tick “SJI 

Joists” in the “Databases” field 

and then click “K” in the “Section 

Families” list to populate the 

“Selected sections” list as shown: 

Next, click “OK” and then “Save” 

your first design group. 
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Repeat these steps to create a 

design group for the 2nd floor 

joists called “Floor Joists” which 

will also use the “K” joists as 

available sections for design. 
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We’ll create another group for 

roof girders (currently modeled 

as W18x35s).  This time you will 

need to pick the design material 

(we’ll use A992-50 steel).  

We can limit the number of 

sections available by opening the 

“Sections” dialog and clicking on 

the AISC database (do not tick 

the box), then click the “W” in the 

list of Section families (do not tick 

the box) Next, select individual 

sections and as you click or select 

them (ctrl, shift, and/or ctrl+shift 

type selections are allowed) they 

will be added to the “Selected 

Sections” list.  Try W12s through 

W18s by selecting the first W12 

and the then holding down shift 

while clicking W18x55. 
 

Continue creating groups for 

Floor girders, one for tie beams, 

one for columns, and one for 

braces. 

Name Floor Girders TieBeams Columns Braces 

Material A992 - 50 A992 - 50 A500-46  A500-46 

Sections AISC W sections 

(all) 

AISC W sections 

(all) 

AISC HSSQ section 

(all) 

AISC HSSQ section 

(all) 
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Use the members/groups table to 

take a look at the groups you’ve 

created:  Design>Steel Members 

Design – Options>Table of 

Members/Groups 

 

Group Design and Check 

 

You can continue with your 

current file, or you can open       

Robot Dataset 8 - Steel Design - 

Setup.rtd to catch up.   

Now we turn our attention to the 

Calculations dialog where we will 

want to select “Code group 

design”.  Use the “List” button to 

the right to add all of our design 

groups (there should be 7 of 

them). 
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Next, tick “Optimization” and 

press the “Options” button then 

tick “Weight” 
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In the lower half of the 

Calculations dialog tick “ULS” for 

limit states and pick your ULS 

load combinations if they have 

not already been selected.  You 

can use the List button to clear 

out basic load cases by selecting 

all the basic cases and using the 

subtraction button  
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Next, press the “Configuration” 

button to adjust the calculation 

points for the members.   

Change number of points to 11 

and tick “characteristic points” 

then press the “Options” button 

to allow you to check maximum 

forces. 

 



Robot Structural Analysis: Making the Change 

92 

 

Then close these dialogs and 

press “Calculations”.  Robot will 

begin checking each member and 

also attempting to optimize by 

weight for each code group.  The 

results will look like this: 

Notice that each group has a 

controlling member, and lists the 

trial sections around the optimal 

section. 

: previous failed section 

: Optimal section 

: Next section after optimal 

section 

NOTE: Next section may not be 

acceptable.  Check the Ratio to be 

sure if you want to use it. 
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You may not particularly like the 

sections that Robot has selected.  

The way to control this is to go 

back to your groups definitions 

and refine the list of choices.  For 

instance, Robot has picked a 

14x61 as the optimal section for 

group 4 floor girders… I know I 

would rather use a 16 or an 18 as 

14x61 is not a common beam size 

in the US.   

Clicking on any row will give you 

access to the detailed results for 

this calculation: 

You can see details on the forces 

for design in the “Forces” button, 

review the calculation notes for 

the group in “Calc. Note” and 

replace all members of the group 

with the optimal section by using 

the “Change” button. 
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Now we can rerun-calculations 

and then do a member 

verification for ULS and SLS to 

check where we are on service 

criteria. 

Select the “Member Verification” 

option in the calculations dialog 

and then also check ULS and SLS 

in the Limit States.   

Use the “List” buttons to select 

service load cases for dead, live, 

and total respectively then run 

the calculations. 

 

Note: “OK” icon, section, material, Utilization Ratio, the Controlling load combations, and the Utilization Ratio for 

service “Ratio(uz)” and the controlling service load case.  Any errors will be readily apprant here. 
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We can use the “Analysis” button 

to get a sense of how our 

members are performing, 

identify any members well over 

capacity and consider creating 

additional design groups to select 

some more useful members for 

these positions.  You should be 

able to see under utilization in 

some of the girders in particular 

as the exterior girders have about 

half the load. 

We can look at the most under-

utilized elements by entering 

clipping value in the “upper limit” 

field of 0.25 for instance. 
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Now we can use “Edit in a new 

window” button   to get a really 

quick look at the elements we can 

give their own design groups to 

improve utilization if we wish. 

We quickly see that most of the 

upper story braces and the 

outside tie-beams could be re-

designed for better utilization if 

desired.   

You can continue this refinement 

process until you are satisfied 

with the balance between 

utilization and uniformity in your 

structure.   

 

 

 


