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Getting Started 
Appending Files and Navigating 

The dataset for this tutorial can be found in: 

C:\Program Files\Autodesk\Navisworks Manage 2014\... 

\Samples\Getting Started 

What is Navisworks? 

Building Information Modeling has become synonymous 

with programs like Revit, but BIM does not stop there.  

Navisworks enables you to interrogate and utilize this infor-

mation throughout the design, build, and operation stages 

without the need for a design application. 

 

Navisworks is designed to bring together geometry and 

data created by multidisciplinary teams, on the largest pro-

jects, into a single model.  This model is available for clash 

detection, virtual construction, quantities, tenant improve-

ments, and lifecycle management over the entire life span of 

the building. 

 

The Navisworks engine intelligently prioritizes all objects in 

a scene.  If your computer is unable to draw all geometry 

while navigating, the engine elects to ‘drop out’ the finer 

detail, allowing you to continue navigating in real time. 

Step 1:  App Menu > File > Open > Open Structure.nwc 

Step 2:  App Menu > File > Open > Append MEP.nwc 

Step 3:  App Menu > File > Open > Append Architecture.nwc 

Step 4:  App Menu > File > Save As Conference.nwf 

Step 5: Ribbon > View Tab > Workspace Panel >   
 Load Workspace > Navisworks Extended 

Step 6: Press        on the Clash Detective Control Bar 

Step 7: Ribbon > Home Tab > Select & Search Panel >   
 Click on “Selection Tree” 

Step 8: If not already, Pin it open 

Step 9: Right-click “Architecture.nwc” in the Selection Tree 

Step 10: Choose Override Item > Override Transparency 

Step 11: Drag the slider right, towards 70% transparent. Click OK. 

Step 12: Turn off the display of lines.  Ribbon > Viewpoint Tab  
 > Render Style Panel > select “Lines” 

Step 13: Explore the model using the Walk Tool.  Ribbon > Viewpoint
 Tab > Navigate Panel > Walk 

Step 14: Left-click and push the mouse forward to WALK 

Step 15: Move the mouse left or right to LOOK left/right 

Step 16: Turn on the avatar (Third Person mode).  Ribbon > Viewpoint
 Tab > Navigate Panel > Realism > Third Person 

Step 17: Roll the mouse wheel to LOOK up/down 

Step 18: Hold the mouse wheel to PAN up/down/left/right 

Step 19: Turn on Collision Detection inside the “Realism” drop down.
 Walk forward 

Step 20: Turn on Gravity inside the “Realism” drop down, to walk up
 and down stairs 

Step 21: Ribbon > Viewpoint Tab > Navigate Panel > Zoom Window
 Drop Down > Zoom All 

Proceed to Sectioning ... 
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Workspace Shown = Navisworks Minimal 

Workspace Shown = Navisworks Extended 

Quick Tip:  Press Shift when starting the Options Editor    

dialog - "Green N" > Shift-Options.  This will run the         

enhanced version of program options settings.  

File Types 
See Help > User Guide > Work With Files > 

Native File Formats for more information. 

Cache Files are exported directly out of some applications.  They 
contain only the raw data necessary to bring in the file. 
 File Sets assemble multiple files (DWGs, NWCs, SATs, DGNs, 
other NWFs) into one model.  Links are live and update like xrefs. 

Dataset File is a published NWF and directly contains the data of 
all linked files.  Linked files are frozen and unnecessary. 

Want more information?  See Help > Quick Start > The User Interface > Parts of Autodesk Navisworks Interface 
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Quick Tip:  To emphasize your model, use the Selection Tree to 

override the Transparency of other disciplines’ files to 70%.  Use the 

Section Planes to further isolate a level.  



Sectioning 
Slice up your building to see inside 

Step 1: Navigate to any glass-faced section of the building 

Step 2:  Select one of the sections of glass (May be transparent.) 

Step 3: Mouse over Properties on the right 

Step 4: Select   and observe  

Step 5: Ribbon > Home tab > Select & Search panel > Find Items. 

Step 6: Mouse over Find Items.  Pin it open. 

Step 7: Set: 

Step 8: Add a second criteria: Item Name = Glazed 

Step 9: Right-click the new criteria and select 

Step 10: Press 

Step 11: Mouse over Sets tab on the left, pin it open 

Step 12: Select on Save Selection 

Step 13:  Name the Search Set by typing:   

 Architectural Glass 

Proceed to Clash Detection... 
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Step 1:   Ribbon > Viewpoint Tab > Sectioning Panel 

 > Enable Sectioning 

Step 2:   Ribbon > Sectioning Tools Contextual Tab 

 > Mode Panel > Verify set to “Planes” 

Step 3: Planes Settings Panel > Current: Plane 1 

Step 4:   Planes Settings Panel > Alignment: Top  

Step 5: Application Menu > Options   

 > In Tree Expand on Interface 

Step 6: Select on Display Units 

Step 7: Set Linear Units to Feet and Inches. Ok out. 

Step 8: Ribbon > Sectioning Tools Tab > Transform Panel 

 > Move 

Step 9: Ribbon > Sectioning Tools Tab > Transform Panel 

 > Expand on “Transform” Panel Drop Down 

Step 10:  Change Z to 14 Feet 

Step 11: Planes Settings Panel > Set Current: Plane 2 

 Notice:  Plane 2 Light bulb Turns On. 

Step 12:  Planes Settings Panel > Alignment: Front 

Step 13: Transform Panel > Change Z to 0 Feet 

Step 14: Plane Settings Panel > Enable Plane 3 

Step 15:  Align to Left, Set to 0 Feet 

Step 16: Turn Off Plane 3 

Step 17: Align Plane 2 to Bottom, Set Z to –12 Feet 

Step 18:  Link Section Planes 

Step 19: Set Current: Plane 1, to flip the UCS MOVE Gizmo 

Step 20:  Mouse to the MOVE Gizmo, Grip the Blue 

 Z-Axis to Drag the Slicer Up and Down 

Step 21: Disable Plane 1 and Plane 2 

Proceed to Search Sets... 

Clash Detection 
Identify, collaborate, resolve interferences 

Search Sets 
Create dynamically refreshed selection sets 

Redlining 
Record & collaborate decisions 

Sectioning: By Planes By Box 
A SELECTION SET only includes objects currently selected. 

A SEARCH SET is automatically updated each time you use it to include 

items that match the search criteria. 

In the above exercise, it would add any additional window glass that has 

been subsequently added to the project.  Search Sets can be EXPORTED to 

other projects. 

Quick Tip:  Define a number of generic searches.  For example: Level 1, 

Structural Steel, etc.  Then save and re-use them on future projects. 

Workspace Shown = Navisworks Extended 
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Step 1: Mouse over Clash Detective on the left.  Pin it open.  

Step 2: Click Add Test at the Top Right of Clash Detective 

Step 3: Click Add Test at the Mid-Left above the tabs 

Step 4: On the Select tab, in Selection A, change the drop down 

 filter to “Sets” 

Step 5: Select on our new Search Set “Architectural Glass” 

Step 6: On the Select tab, in Selection B,  select Structure.nwc 

Step 7: In Settings, verify:     

  Type = Hard     

  Tolerance = 0.00 feet 

Step 8: Press Run Test 

Step 9: Observe the changes: 

• Results tab set current 
• First clash > Selected 
• First clash > Zoomed into view: 
 
 
 
 

 

 

Proceed to Redlining ... 

Step 1: Ribbon > Review tab > BOTH Redline & Tags panels 

Step 2: Draw a cloud around the clash, click for each arc 

Step 3: Add a Redline Tag to the cloud   

 2 clicks: Leader start at target-finish at tag 

Step 4: Add Comment box pops up, add a comment:  Fix it! 

Step 5: Ribbon > Viewpoint tab > Navigate panel > Pan 

Step 6: Pan away from the clash. The markup vanishes. 

Step 7: Ribbon > Review tab > Comments panel >  

 select Find Comments 

Step 8: Press .  Select Clash1. 

Step 9: Observe it zooms back to Clash1.   

Step 10: Ribbon > Review tab > Comments panel > Search bar 

Step 11: Type in “Fix It!”, click .  Same effect. 

Proceed to Timeliner ... 

Step 1: Export NWC Cache files from each design product.  Use 

 the same file names for the life of the project. 

Step 2: Open the first NWC Cache file 

Step 3: Append any additional Cache files 

Step 4: Enable Tools > Global Options > Interface > Snapping > 

 Snap to Vertex 

Step 5: Select Measure Tools > Point to Point 

Step 6: Measure between points which should be common in 

 the two models 

Step 7: Select the file you wish to move in the Selection Tree 

Step 8: Select Measure Tools > Transform Objects.  The current 

 change is only temporary. 

Step 9: Right-click the file in the Selection Tree.  Select Override 

 Transform.  The change is now stored for the Cache file. 

Step 10: Save the File Set as an NWF. 

Shared Coordinates 
Align Project Origins and Orientation 
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SHARED COORDINATES are used for remembering the mu-

tual positions of multiple interlinked files. Those interlinked 

files can be all Revit files, or a combination of Revit, DWG, 

and DXF files.  Navisworks will recognize Shared Coordi-

nates when present. 

Quick Tip:  You should derive shared coordinates from only 

one file. That one file defines the coordinates for all other 

files that compose the project. Acquire coordinates from one 

file and then publish those coordinates to other files.  

Quick Tip: Place a physical monument at the project 

origin of each design file.  This will provide a common point 

for step 6. 

INTERNAL VS SHARED COORDINATES 

Quick Tip:  Use Redline Tags to make notes about 

markups.  Only Redline Tags can be searched. 

Quick Tip:  To edit a Redline Tag, mouse      

over the Comments bar.  Right-click the       

Redline Tag item, select Edit Comment.  

Quick Tip:  

Use clash 

rules to 

eliminate 

false posi-

tives. Ignore 

same layer, 

group, file, 

points, etc. 



Timeliner 
Model your project tasks & schedules 

TimeLiner Tasks 

Use the TimeLiner to link your model to an external construc-

tion schedule for visual time and cost based planning. 

In TimeLiner tasks can be created in one of the following ways: 

• Manually, one at a time 

• Automatically, based on object structure in the Selection Tree, or the selection 
and search sets 

• Automatically, built from data sources added to TimeLiner 
 

Step 1: Ribbon > Home tab >  Tools panel   

 > TimeLiner 

Step 2: TimeLiner window> Tasks tab   

 > Add Task  

Step 3: Create ALL Tasks seen above 

Step 4: Ribbon > Home tab   

 > Select & Search panel   

 > Sets drop down > Manage Sets 

Step 5: Ribbon > Home tab    

 > Select & Search panel    > 

 > Selection Tree 

Step 6:  Explore the Selection Tree    

 Expand on Structure.nwc, etc 

Step 7: Create Selection Sets Similar to   

 what is seen in the image on right 

Step 8: TimeLiner window > Attach each   

 Set to a Task using Attach button 

Step 9: Observe Timeline to right of tasks 

Proceed to TimeLiner Simulation… 

Quick Tip:  Observe in the top image the “Task Type” column.  

When this is blank, the Task does not participate in the Simulate 

video.  The “Task Type” list is derived on the “Configure” tab.  

Three Default Task Types: Construct, Demolish, Temporary 

Quantification 
Generate a quantity takeoff for analysis 

TimeLiner Simulation 

Watch your building being built from the ground up by playing a 

video of your TimeLine 

Step 1: TimeLiner window > Configure tab 

Step 2: Click  

Step 3: Click   button 

Step 4: Rename the new appearance to White (90% Transparent) 

Step 5: Double-click in the color swatch and set to be white 

Step 6: Set Transparency to 90%. Ok out.  Do Not Use Just Yet. 

Quick Tip:  Meaning of Appearances: 
• Start Appearance - how the items will look at the start of the task 

• End Appearance - how the items will look when the task is completed 

• Early Appearance - how the items will look if the task is started before the planned time 

• Late Appearance - how the items will look if the task is started after the planned time 

• Simulation Start Appearance - how the items should be displayed at the start of a simula-
tion.  Simulation start precedes all task starts 

 

Step 7: TimeLiner window > Simulate tab 

Step 8: Click Settings button 

Step 9: Set according to image to right 

Step 10: Press Play 

Step 11: Try different Settings and Appearances:    

 Enable: “Show all tasks in interval”   

 Set Start Appearance: White (90% Transparent) 

Proceed to Quantification... 

Quantification gives you the tools to automatically make material 

estimates, measure areas and count building components 

Step 1: Save your NWF file 

Step 2: Click the button 

Step 3: It may ask: Would you like to view Quantification getting 

started tutorials now?  > Remind me later 

Step 4: Answer the questions in the Project Setup Wizard: 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 5: Choosing Catalog CSI-16 in the Wizard results 

in this tree structure.  To explore different Catalog tree structures, 

close your file without saving.  Re-open the NWF file and try a differ-

ent Catalog in the 

Wizard. 

 

 

 

 

 

 

 

 

Step 6: Create some Sample Resources and Items 

Step 7: In the Quantification Workbook, click the Item you want to 

use for the takeoff.  In the Scene view or Selection Tree, select the 

object(s) you want to take off.  Right-click selected object(s) > Quanti-

fication > Takeoff to: (name of existing Item) 

Step 8: The takeoff appears in the Quantification Workbook, under 

the existing catalog Item 

Quick Tip:  The available measurements (variables) are: 

Length  Width Height Perimeter Thickness 

Weight  Area Volume Count 
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Quantification workflow: 

1. In Navisworks, open a design data source file 

2. Open the Quantification workbook 

3. Set up a project 

4. Create or select takeoff items 

5. Hide unwanted items 

6. Use measurement tools for items not in catalog (for 

virtual takeoff) 

7. Organize takeoff items (change item order, create 

new items) 

8. Edit formulas/parameters 

9. Refresh model after changing data 

10. Analyse and validate takeoff data 

11. Output takeoff data to Excel XLSX format 

 

Model takeoff 

Model takeoff uses the properties embedded in the design 

source files to create takeoff data. It extracts the objects 

from the model and displays them as Items in the Quanti-

fication Workbook. 

Virtual takeoff 

Perform virtual takeoff to add takeoff items that are not 

linked to a model object, or where an item appears in the 

model but contains no associated properties. You can use 

measure tools in conjunction with a virtual takeoff, and 

associate a viewpoint with the virtual takeoff Item. 

Proceed to Presenter, Animator, Scripter... 

A. Navigation pane. This contains a list of Items and WBS (Work Breakdown Structure) 
codes 
B. Rollup pane. The summary of your takeoff items. Right-click a column header to change 
the columns displayed in the Rollup pane 
C. Takeoff pane. Displays all takeoff items. Right-click a column header to change the 
columns displayed in the Takeoff pane 

A 

B 

C 

Quick Tip: Export your Task List to create a folder 

of Selection Sets that match the name of Tasks. 

Sets are automatically attached to the Tasks. 

Quick Tip:  Primavera 
P6 v8.2 now supported 

Quick Tip: Lock the X, Y or 

Z axis from initial point 

when doing measurements 

Quick Tip: Measure in a 

Perpendicular or Parallel 

alignment to the surface 

of an object 

Quick Tip:  

Limit sectioning 

planes or boxes 

to elements you 

have selected. 

Great for levels! 



An important enhancement to the Autodesk line of products is the 

introduction of Ray Trace. Navisworks will now render the Autodesk 

library of materials. Any Autodesk materials applied to a model in Revit 

will persist in Navisworks. The look and feel of the model will be con-

sistent from Autodesk product to Autodesk product.  As of 2014,  

material libraries are now included. Don't forget, you can also view 

your NWD models on the Autodesk BIM 360 Glue mobile iPad app. 

NOTE: Tutorial dataset does not have Revit materials pre-assigned 

Step 1: Model space: Use ViewCube to zoom in tight anywhere 

Step 2:  Ribbon > Viewpoint tab > Save, Load & Playback panel > 

Save Viewpoint.  “Saved Viewpoints” opens.  Save as: “My View” 

Step 3: Ribbon > Home tab > Tools panel > Presenter  

Step 4: Set up the scene: 

Use Materials tab to drag and drop materials onto items in the 

model; Or Rules tab to set up rules which define project-wide 

material application; Or Texture Space tab to more accurately 

map materials onto items in scene; Or Lighting tab to set up ad-

ditional lighting; Or Effects tab to add background/foreground 

effects to scene; Or Rendering tab to select a rendering style 

Step 5: Click Render to start the rendering process.  Rendering 

process can be stopped by clicking Stop 

Step 6: Click Clear; Pause       , Save        or Close        on Ribbon 

Quick Tips 
Goodie Bag  

Collaboration 
Supported file types 

The Animator and Scripter windows are the two dockable windows 

that are used to create and edit object animation 

Once you have set up and rendered a scene, you can additionally 

create animation in that scene. The rendering that you have set 

up will be applied to each frame of the animation 

Step 1: Ribbon > Animation tab > Create panel > Animator 

Step 2: Ribbon > Animation tab > Create panel > Record 

Step 3: Use Focus, Orbit, Walk, Look, Pan and other navigation tools 

to fly the camera around the building 

Step 4: Ribbon > Animation tab > Script panel > Enable Scripts if used 

Step 5: Ribbon > Animation tab > Recording panel > Pause or Stop 

Step 6: Ribbon > Animation tab > Playback panel > Play 

Step 7: Ribbon > Animation tab > Export panel > Export 

 

 

 

 

 

 

 

Step 1: Animator: Create “Open Door” animation that rotates a door 

by 90-degrees.  While recording, use Gizmo: Rotate to manually turn 

door 

Step 2: Ribbon > Home tab > Tools panel > Scripter 

Step 3: Click Add New Script.  Name it: Door Script 

Step 4: In Events, click “On Hotspot” 

Step 5: In Properties, set Hotspot: Sphere.  Click Pick button and locate 

in front of a door that you will navigate thru. Trigger when entering, 

radius 4-feet 

Step 6: In Actions, click “Play Animation” > Open Door.  Properties 

pane: set parameters: Animation = Open Doors; Pause = Checked; Start-

ing at Start; Ending at End. This opens our doors.  Reverse start/end to 

close door 

Step 7: Walk through the doors. You should see them open 

FOCUS You can put the Scene View into focus mode until the next 

click.  When you are in focus mode, clicking on an item swivels the 

camera so that the point clicked is in the center of the view. This 

point becomes the focal point for the Orbit tools (Steering Wheels 

and Navigation Bar) in a 3D workspace only. 

 

In a 2D workspace, the camera is moved to the center of the box of 

focused item while the z value remains the same. 

 

Model space > Navigation Bar > Look flyout > Focus 

Model space (no selection) > Right-click menu:  

 Scene > Focus 

Model space (make a selection).   

 Ribbon > Item Tools Contextual tab >  

 Look At panel > Focus on Item  

 

Ribbon > Viewpoint tab > Navigation Panel >  

 Look Around > Focus 

 

 

 

Ribbon > Home tab > Select Item   

 Select any item(s), Right-click    

 > Focus On Item 

 

 

 

 

 

 

 

 

 

 

 

 

 

FIT SELECTION When sectioning by box, try “Select All” on the 

Ribbon > Home tab, then on the Ribbon > Sectioning Tools tab try 

“Fit Selection.”  The Sectioning Box will now encompass the entire 

project. 

 

Field Of View Defines the area of the scene that can be 

viewed thru the camera: Ribbon > Viewpoint  

  tab > Camera panel > F.O.V. slider 

 

In Presenter, Animator & Scripter, when you are recording, you 

can add predefined views and record based on those views.  

Then tweak that in the animator. 

 

High-End Renderings - Suggested Settings for Production: 

Global Options > Interface > Display: Level Of Detail drop down > 

Low (Tradeoff between 2D fidelity & higher rendering performance) 

Navisworks has two graphics engines - Presenter & Autodesk, 

choose the one that works best with your video card. 

Hardware Acceleration, Occlusion Culling = On.  Hardware: SSD’s, 

Maximum RAM, 64-bit OS, Direct3D 9® and OpenGL® capable 

graphics card with Shader Model 2 (minimum) 

Presenter, Animator, Scripter 
Render, animate & interact with the model  
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Quick Tip: Set Presenter profile 

> Options Editor to Advanced, 

dialog box will include a full list of 

parameters, allow you to change 

the type of foreground 
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