
 

AV1715 Add Life to Your Visualization Using Traffic 
Simulations with Civil View Tools in Autodesk® 3ds 
Max® Design 

Chip Weatherman  –  HNTB Corporation   

AV1715 This class shows you how to use Civil View traffic import tools in Autodesk 3ds 

Max Design software to bring in traffic simulation data from PTV Vissim. We examine how to 

prepare your data in VISSIM, how to bring that data into 3ds Max Design using Civil View, and 

how to handle conflicts such as overpasses. We then talk about various ways to use this data 

once it is set up, including how to export from 3ds Max Design to another 3D package such as 

Autodesk® Maya® software. You also learn how to replace the imported data with actual 

vehicles from the Civil View Vehicle library and how to use your own car library. 

Learning Objectives 
At the end of this class, you will be able to: 

 Accurately prepare or communicate how to prepare VISSIM data prior to export 

 Properly bring the VISSIM data into 3ds Max Design via Civil View 

 Identify conflicts such as overpasses, vehicles going the wrong way, and so on 

 Replace/link various car libraries to VISSIM data and know what to do with them afterwards 

About the Speaker 

With over 10 years in the 3d industry, Chip has done extensive work in the areas of civil 

engineering, industrial design, visual fx, and 3d animation. Some of the clients he’s worked with 

have included national and collegiate sports teams (in-game jumbotron animations), Garmin 

and Hot Shot (commercials), Learjet and Rayovac (photo-real concept renders). He is 

Autodesk Certified in 3ds Max and Maya. He has been the Tech Editor of Mastering Maya 

book (Sybex) for the past 2 years. He has also taught 3d modeling, texturing, render, etc. at 

Kansas City Art Institute (kcai.org). In addition, he is the President of the Kansas City chapter 

of AAUGA. Currently at HNTB in Kansas City, he is a 3d Team Lead responsible for oversight 

and best practices on many visualization projects utilized by their pursuit teams. 

Email: cweatherman@hntb.com 
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Introduction 

What is Traffic Simulation? 

 A computer generated representation of traffic flow patterns as they pertain to civil 

engineering. It’s generally used to determine what impact a change in road design will have on 

traffic. 

 

What is VISSIM? 

 VISSIM is a traffic simulation program by a company called PTV Group. It is highly 

accurate and is considered by many the standard for traffic simulation. The great thing about it 

is, as visualization artists, we can tap into that highly accurate simulation to help bring life to a 

static visualization. 

 

How can I, as a visualization artist, tap into that accurate traffic sim? 

 That’s why you’re in this class! Autodesk acquired a software package called Dynamite 

VSP from a company called 3AM Solutions. It was first released as an SAP for 3ds Max Design 

2010. It is now called CivilView. 

 

What is CivllView? 

 CivilView is an extension to 3ds Max Design that has many tools to help visualize civil 

engineering data, that due to many different factors, can be difficult to show in a high quality 

manner. While CivilView has many types of tools, the specific tool I’m going to go over in this 

class is the VISSIM traffic sim importing function. 
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Exporting data from VISSIM 
 

This is using VISSIM v. 5.30-08 (32-bit) and 3ds Max 2014 Design (Civil View extension).  This 

should work with previous and future versions of each. Civil View was added to 3ds Max 2011 

Design and was originally called Dynamite VSP. 

 
1. Export your simulation from VISSIM. Go to Evaluation > Files… 

 

2. Check “Vehicle record:” and click the Configuration button. 
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3. In the Vehicle Record dialog add Parameters from the right pane (Parameter selection) 

to the left pane (Selected parameters).  The only ones needed to be added are World 

Coordinate Front X, Y, and Z, World Coordinate Rear X, Y, and Z, Speed (mph), Vehicle 

Type Name, Vehicle Number, and Simulation Time. Save the Configuration file to its 

own folder. It will produce more than just the single ‘FZK’ configuration file. 

 

4. With your simulation data set up, hit the Simulation continuous button to record the 
simulation. 
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5. After the simulation is recorded, check the folder you saved the ‘FZK’ file and check to 

see what other files were saved with it.  There should be an ‘FZP’ file in there as well. 

That is the file you will import into Civil View. 

 
 
 

Setting Up 3ds Max Design 

 
1. Regardless of your system units you worked in VISSIM or 3ds Max (feet, inches, etc.), 

the Civil View traffic importer only imports correctly into Meters scenes.  Make sure your 

3ds Max System Units are set to Meters by going to Customize menu > Units Setup… to 

open the dialog. Then click the System Unit Setup at the top, then in the units drop down 

list, choose meters. 

 

2. Since you may have changed the System Units from something other than meters, you’ll 

need to merge your road geometry to make sure it remains the same size. Typically you 

only need your road surfaces. We merge just the roads into their own scene and do all 

the traffic in that scene and save it as an xref. After you have made sure your system 

units are set to Meters, go to File > Import > Merge and merge your road surfaces. Make 

sure your roads are collapsed and all material ID’s are set to 1. You can use Soulburn 



AV1715 Add Life to Your Visualization Using Traffic Simulations with Civil View Tools in Autodesk® 3ds 
Max® Design 

6 
 

Script Material ID randomizer and set both min/max random values to 1 and it will reset 

all Material ID’s to 1. Now make sure the roads just have a default gray material and the 

objects are set to Non-renderable. This will ensure no additional maps or geometry are 

loaded into memory from the xref scene during render time. We are only using the roads 

to place the cars. 

 

3. Next, if Civil View is not started, go to the Civil View menu and choose Start Civil View. 

 

Importing VISSIM into 3ds Max Design 

 
1. Then go to Civil View > Traffic Import > Import FZP File…, navigate to where you saved 

the VISSIM data and choose your FZP file.  
 

 
 

2. For help on FZP file importing please refer to: 
http://docs.autodesk.com/3DSMAX/16/ENU/3ds-Max-Help/index.html?url=files/GUID-
607F1D5B-07F9-4BF2-A907-F62020CF01E9.htm,topicNumber=d30e551609 
 

a. The base resolution will show essentially 1/10th of a second. So in a 30fps 
animation, that’s a key every 3 frames.  
 

 

http://docs.autodesk.com/3DSMAX/16/ENU/3ds-Max-Help/index.html?url=files/GUID-607F1D5B-07F9-4BF2-A907-F62020CF01E9.htm,topicNumber=d30e551609
http://docs.autodesk.com/3DSMAX/16/ENU/3ds-Max-Help/index.html?url=files/GUID-607F1D5B-07F9-4BF2-A907-F62020CF01E9.htm,topicNumber=d30e551609
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b. The first section is the Open and Filter values. Open allows you to open the FZP 

file, while the Filter field allows you to type a Vehicle Type in the field and click ‘+’ 

or ‘-‘, whether you want to check or uncheck the given Vehicle Type.  

 

 

 

c. Time Based Data Filtering allows you to set the start and end of the animation in 

seconds. The example image above starts at .2 seconds and ends at 140.6 

seconds (roughly 2 min 20sec). Be advised, it’s not frames. 

 

d. Step Based Data Filtering allows you to adjust the amount of keyframe data that 

applied to each vehicle. Global Step Interval (in seconds) will adjust the overall 

amount of keys per second. Using Minimum Number of Steps, you can exclude 

vehicles that have less than 2 steps from importing. This means if you have cars 

that start to show up right at the end of the simulation, it won’t import those since 

they’re only animated for a few frames. It’s a balance between accuracy and 

what your computer can handle. Usually, the default values are sufficient. 

 



AV1715 Add Life to Your Visualization Using Traffic Simulations with Civil View Tools in Autodesk® 3ds 
Max® Design 

8 
 

e. Resulting Scene Animation Settings allows you to shift where the keyframes start 

and also lets you apply a speed multiplier to vehicle speed. The Scene Start 

Time Shift usually is the opposite of the Select Start Time to be Imported. For 

instance, if the Start Time is set to 10 seconds into the simulation, you want to 

set the Scene Start Time Shift to -10 so the animation will start at frame 0. This 

allows you to start showing the animation without having to waste time filling the 

roadways. The Vehicle Speed Multiplier does exactly what it says. If you have 

vehicles traveling at 30mph, then putting 2.0 in the Vehicle Speed Multiplier 

would essentially double the speed to 60mph. Should only need to change this 

for ‘artistic’ purposes (i.e. time-lapse effect) or if you know your VISSIM values 

are less than they should be. 

 

f. Global Shift Values helps you offset your traffic if you are using a geo-spatial 

offset for your other imported civil you would put the offset values in here. The 

Constant Z you may want to pay attention to. You want to make sure all your 

cars are above or below the extents of your road geometry just for consistency or 

to make sure all your vehicles are above visible terrain, etc. 

 

g. Once all your settings are complete, click the OK button to bring in your 

geometry. The process took about 2-3 minutes. You may get the following 

caution dialog below. Basically, it’s telling you that the current time line length is 

not capable of holding all the current animation and wants to know if you want to 

extend it to the length of the entire animation. 
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Surface Tracking 

 
1. After import, all vehicles will be on the ground plane. You will need to run through the 

Surface Traking Manager in Civil View. Civil View > Traffic Import > Surface Tracking 
Manager. 
 

 
 

2. For information on the Surface Tracking Manger panel, refer to:  
http://docs.autodesk.com/3DSMAX/15/ENU/3ds-Max-Help/index.html?url=files/GUID-
607F1D5B-07F9-4BF2-A907-F62020CF01E9.htm,topicNumber=d30e551609 
 

3. In the Surface Tracking dialog, you’ll see two main windows.  
 

a. The top one contains a list of all the vehicles imported. The two buttons right 

below that window allow you to select or deselect all the vehicles. Selecting a 

vehicle in the viewport will make it become highlighted in the Surface Tracking 

window. This gives you a visual queue to just go ahead and check on the 

checkbox and all of the selected cars will be included in the calculation. After the 

calculation completes, it will deselect all the vehicles. 

 

 
 

http://docs.autodesk.com/3DSMAX/15/ENU/3ds-Max-Help/index.html?url=files/GUID-607F1D5B-07F9-4BF2-A907-F62020CF01E9.htm,topicNumber=d30e551609
http://docs.autodesk.com/3DSMAX/15/ENU/3ds-Max-Help/index.html?url=files/GUID-607F1D5B-07F9-4BF2-A907-F62020CF01E9.htm,topicNumber=d30e551609


AV1715 Add Life to Your Visualization Using Traffic Simulations with Civil View Tools in Autodesk® 3ds 
Max® Design 

10 
 

b. The bottom window is where you can load all of your road surfaces into the 

Surface Tracking Manager and let it process. You can add individual roads and 

just select the cars that drive over them and process just those. To add a 

surface, click “Pick New Tracking Surface”. You can either click on the surface in 

the viewport, or open the selection window and choose it from there. You can 

only add or remove one surface at a time. 

 

  
 

c. After you pick a surface, the Surface Tracking Filter pops up letting you pick with 

Material ID to apply tracking to. This allows you to decide exactly on a piece of 

geometry where to track. For instance, if you have geometry that includes your 

asphalt, shoulders, grassy area materials, you can tell the filter you only want to 

track the material ID that matches the asphalt and it will ignore the rest of the 

geometry meaning the calculation will be faster. You can further speed up the 

calculation by minimizing the amount bearing on the vehicles. The default is set 

for a single full rotation, but for instance, if your vehicles will never make a full 

circle, you can minimize this and the calculation will only have to rotate the 

vehicles in the given range. 
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d. You can click Ok to just process and close the dialog, or just hit Apply to keep the 

dialog open to allow you to do multiple calculations. One of the great things about 

this system is its edit ability. You can run this multiple times, so if a car is reacting 

to a different surface (for instance, it is jumping up to an overpass that it shouldn’t 

drive on) you can remove all surfaces from the surface tracker, then detach the 

faces of just the part of the road the cars need to drive on, add back in the newly 

detached surface to the Surface Tracker, the hit Apply. This will only update the 

animation. 

 

 
 

e. When you hit Ok or Apply to start the calculation the following warning will pop 
up. It’s just to make sure that you do want to go ahead and process the data 
supplied. The example file took about 5-10 minutes on a Dell 7600 32 core Intel 
Xeon E5-2665. 
 

 
 

f. Once the animation is processed, it is baked onto the object, but can be updated. 
You do not need to process all roads and all cars in order to update a single car, 
or just a few. Reprocessing will not affect everything that has already been 
processed. It will only update the roads added and the cars checked. This data is 
stored in your scene. So you can close your file, reopen, then bring up the 
Surface Tracker again to fix other cars if necessary. In addition, the surface and 
cars are not linked in anyway once the process is completed. If the road 
geometry does change, you will need to redo the surface tracking for the updated 
roads. 
 

Things to keep mind. Vehicles that travel over top of surfaces they have already 

been tracked on to, can’t determine which is the correct surface so there will be 

some clean-up. You can detach areas for clean-up and just re-calculate the cars that 

have errors. Also, you can adjust the geometry itself if you have cars that aren’t lining 

up exactly where they should be. 
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Replacing the Boxes with Vehicles 
 
Next, you’ll want to replace the boxes in the scene with your own vehicles. We’ll look at 2 ways 
of doing it using the civil view library or importing your own vehicles and using those. 

Using Civil View built-in Vehicle Substitution 

1. Go to CivilView > Traffic Import > Vehicle Substitution Manager For further info on this 
manager, refer to http://docs.autodesk.com/3DSMAX/16/ENU/3ds-Max-
Help/index.html?url=files/GUID-E14C0F2B-4582-415C-9CAD-
39ABA55B4E68.htm,topicNumber=d30e227229 
 

 
 

2. The Vehicle Substitution Manager allows you to replace your boxes with high res 
vehicles. 
 

 
 

http://docs.autodesk.com/3DSMAX/16/ENU/3ds-Max-Help/index.html?url=files/GUID-E14C0F2B-4582-415C-9CAD-39ABA55B4E68.htm,topicNumber=d30e227229
http://docs.autodesk.com/3DSMAX/16/ENU/3ds-Max-Help/index.html?url=files/GUID-E14C0F2B-4582-415C-9CAD-39ABA55B4E68.htm,topicNumber=d30e227229
http://docs.autodesk.com/3DSMAX/16/ENU/3ds-Max-Help/index.html?url=files/GUID-E14C0F2B-4582-415C-9CAD-39ABA55B4E68.htm,topicNumber=d30e227229
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a. The leftmost window gives you details on each vehicle. Some of the columns 

won’t be filled in until you have done the substitution of the boxes. Similar body 

types are instanced to maintain smaller file size. 

 

b. The right side of the window contains the Select By Type drop down list. This 

allows you to choose a type of vehicle depending on the criteria that was 

originally created by the VISSIM file. There are 3 ways to select vehicles for 

substitution. You can select in the viewport, select from the list of the left, or via 

the Select By Type drop down.  

 

 
 

c. The bottom section of the right side displays information regarding the the of 

Resource Kit you have loaded. After you have selected vehicles you have to click 

Assign Vehicle to List. You’ll notice the vehicles names are highlighted in the list 

on the left. If you need to start over because you selected the wrong group, just 

hit Cancel and reopen the Manager. Next, you click the ‘directory’ you want to 

use to replace the selected vehicles. 

 

 
 

d. If you would like the vehicle wheels animated, you just have to check on 
“Animate rotation of vehicle wheels” before you hit Ok or Apply. 
 

 
 

e. Finally, click Ok or you can click Apply (to keep the dialog open). For other 
vehicle types or if you need to change/update previously replaced vehicles, just 
repeat the the steps a – e.  
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Replacing CivilView boxes with Custom Vehicles 

 
1. Merge your own car library into your scene. 

 
2. You’ll need the Put Pivot tool part of Soulburn Scripts 

(http://www.neilblevins.com/cg_tools/soulburnscripts/soulburnscripts.htm) as it’s the 

easiest way to reposition the pivot of all cars to a specific point. Civil View places the 

pivot of all the vehicle boxes to the front. To replace with cars from your car library, the 

pivot needs to be moved to the bottom front of the vehicle box. 

 

 
 

  

http://www.neilblevins.com/cg_tools/soulburnscripts/soulburnscripts.htm
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3. Next, you’ll want to use “Object Replacer” script that’s part of SoulburnScripts pack to 
replace with your own car library. 
 

 
 

a. Replacer Type lets you specify what type of replacing you would like to do. 
There’s Single Object, Selection Set, or Multiple Objects. 

 
 

b. The next 3 sections correspond to which type of replacing you intend to do. 

Under Single Object, you click “Pick The Obj To Replace With”, then click in the 

viewport the object to want to use as the replacer (or open the selection window, 

choose object and hit OK). If you chose Selection Set, the Selection Set drop 

down will be active and you can choose from the list which selection set you want 

to use. Finally, if you chose Multiple Objects, you select your objects, then click 

“Add Sel To Replacer List”. You can remove an object from the Multiple Objects 

list by clicking the “-“ button. 
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c. Something to consider is how to replace with Groups if you have your vehicles as 

separate objects. There’s a quick workaround I discovered that is now posted on 

the SoulburnScripts site. One of the other users, Bruno Lopes, created a quick 

YouTube video explaining the workflow. That can be found here: 

http://youtu.be/J6VWAlv4Aq4 

Basically, open the group nodes, select the top group nodes from the selection 

window (you can sort by groups and it'll only show those nodes), then add the 

groups as the objects to replace with, then close the group nodes  

 

d. The next 3 sections contains options for what you want the replacer object to 

maintain from the objects being replaced. For our purposes, we only want to 

maintain the Transform Controller (you can uncheck Visibility Controller since we 

don’t have those on the group nodes). Also, we want to Uncheck “Delete 

Originals?”. If you Delete Originals, then try to update the Surface Tracking or 

Vehicle Substitution, it won’t do it even though it has the CivilView Controller on 

the object. 

 

 
 

e. The bottom area contains 4 buttons. The ‘Do’ button will do the replacing, then 

close the windows. The ‘Apply’ button will do the replacing, but keep the window 

open. Help opens a help dialog explaining how to use the script. Finally, the 

http://youtu.be/J6VWAlv4Aq4


AV1715 Add Life to Your Visualization Using Traffic Simulations with Civil View Tools in Autodesk® 3ds 
Max® Design 

17 
 

‘SaveDef’ allows you to set default settings for the script so next time you open it, 

it will be set up. 

 

f. Finally, select the vehicle objects you want to replace, then click Do or Apply, it 

will randomly replace your selected objects with the replacer objects in the list. 

 

Things to Remember 

 
1. Start your VISSIM and vehicle box creation in a Meters scene. After you are completed, 

you can merge the resulting scene into a different System Unit set up (for example, 
Feet). 
 

2. If you’re road geometry changes, you’ll need to redo the Surface Tracking. 
 

3. Pay attention to overpass areas and feel free to delete keys if needed. 
 

4. When substituting vehicles with CV vehicles, make sure to save a ‘non-substituted’ file in 
case you replace something wrong. Many times it’s easier to start over with boxes, then 
amend a mistake. 
 

5. When using the Object Replacer script, make sure you pick the Group node if 
necessary. 
 

a. Make sure the objects you’re replacing with are already similar size as the CV 
boxes. 
 

b. Make sure that you don’t Delete Originals 
 

c. May need to rotate cars in Local Z to make sure they’re going the right direction 
 

6. Organize your scene via layers or selection sets in case you need to redo any of the 
steps again. 

 

 


