
 

Basic 3-Axis CAM in Delcam PowerMILL 
Brian Ringley – Woods Bagot  

PE4997-L This course will examine the fundamentals of a basic 3-axis setup using Delcam 
PowerMILL. We will start by learning how to set up a part within stock, and then we will use area 
clearance toolpaths to rough the part. We will then discuss various finishing strategies, moving from a 
semi-finish to a true finish, and we will follow up with detailing toolpaths, such as auto cornering and 
pencil cuts. Finally, we will use workplanes and interactive stock models to set up a second position, 
commonly known as a “flip mill,” before analyzing our toolpaths for gouging and collisions and then 
simulating our numerical control programs. 

Learning Objectives 
At the end of this class, you will be able to: 

• Learn how to position a part within stock for a 3-axis CAM setup 

• Learn how to set up a CNC programming strategy moving from rough to semi-finish to finish to 
detailing 

• Learn how to use workplanes and interactive stock models to set up a second position for a “flip mill” 

• Learn how to analyze and simulate NC programs to better ensure quality and avoid gouging and 
collisions 

About the Speaker 
Brian Ringley is the design technology platform specialist at Woods Bagot, where he 
specializes in project-specific design technology integration, design computation methodology, 
and Building Information Modeling (BIM). Prior to working at Woods Bagot, he was the Fuse 
Lab technology coordinator for the Department of Architectural Technology at the New York 
City College of Technology (CUNY), and he was the digital fabrication coordinator for the 
College of Design, Architecture, Art, and Planning at the University of Cincinnati. He has 
worked in the architectural offices of Kohn Pederson Fox Associates, Dellekamp Arquitectos, 
and R&Sie(n), and he has taught fabrication seminars and design studios at the University of 
Cincinnati, the City University of New York, and Pratt Institute. He has also led design-build 
workshops at Rensselaer Polytechnic Institute and plusFARM, and he has sat on juries as an 
invited critic at Columbia Graduate School of Architecture, Planning, and Preservation and 
Cornell University College of Architecture, Art, and Planning. He is a regular contributor to 
Designalyze.com and AEC-APPS.com. 
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Positioning a Part within Stock 
Importing a CAD Model 

Setting a Default Directory 
After first launching PowerMILL it’s helpful to set a default directory by going to Tools > Customize 

Paths.  

1. In the PowerMILL Paths window, select Default Directory from the drop-down menu. Add a file 

path by selecting the Add path to top of list button and browsing to the desired directory in the 

Select Path window. A good first path first path to add is C:\dcam\pmill4. Once the path is 

selected, hit OK to close the Select Path window.  

2. Repeat the process with the same path for the File Dialog Button 1 option in the drop-down 

menu.  

3. For File Dialog Button 2, I recommend C:\Program Files\Delcam in case there’s a need to 

access system files. Other paths can be set as needed. When finished, select Close to close the 

PowerMILL Paths window. 
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Setting Units 
To set the desired units go to Tools > Options and then expand Unit System in the Options window. 

Select Unit System and then select the desired radio button, either Metric (millimeters) or Imperial 
(inches). 

 

Importing the Part 
To import a CAD model of the part, go to File > Import Model… or right-click on Models in the 

PowerMILL Explorer and select Import Model… from the drop-down menu. In the Import Model 
window select File Dialog Button 1 to automatically jump to the previously specified directory. In this 

example I will navigate to C:\dcam\pmill4\cad and set the Files of type: drop-down menu to IGES (*.ig*) 

or All Files (*) prior to selecting samplePart.igs by double-clicking the file name or selecting Open.  

Note: PowerMILL is capable of importing many file types depending upon your licensed exchange file 

types within Delcam Exchange. 
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After the model imports successfully there will be a model in the Models drawer of the PowerMILL 
Explorer window. Also, the geometry will maintain layer sorting from the original CAD file in the Levels 
and Sets drawer, although the levels will need to be renamed by right-clicking each level name and 

selecting Rename from the cursor menu. To better see the part: 

1. Select the Iso 1 and Plain Shade buttons from the toolbar to the right of the screen.  

2. Make sure that Wireframe button, also on the right, is selected so that curve objects display.  

3. To better see the wireframe curves, select them and right-click over top of them. Then select 

Color… from the drop-down menu to select a custom color. 
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Defining the Block 

Saving the File 
It’s a good time to save the file – to do this go to File > Save Project As… and save the project to 

C:\dcam\pmill4\projects as myProject01 (this file is available as a course resource). 

Note: A PowerMILL project file is actually a file directory, so remember to archive the file as a *.zip or *.rar 

file if exchanging via the email or web. One advantage of this is that it’s difficult to inadvertently save over 

a file. 

 

Sizing the Block 
Select the Block icon from the toolbar at the top of the screen to open the Block form. We will create a 

simple Box type block from the Active Workplane. Because the extent of the block is modeled on the 

blockBounds level of the imported part, we can simply press the Calculate button to automatically size 

our block. Otherwise dimensions can be entered manually into the Limits fields.
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Block Visibility 
Block Opacity can be adjusted on a slider within the Block form. Block visibility can be toggled using the 

Draw checkbox within the Block form or by selecting the Block visibility icon in the right toolbar. 

Defining a Workplane 
In this first example we are using the default global workplane, an XY plane with Z up at the origin 0,0,0. 

However, we can explicitly define a workplane by right-clicking on Workplanes in PowerMILL Explorer 

and selecting Create Workplane…  

1. A workplane creation toolbar will appear at the top of the screen. Name the workplane 

position01 and then raise the Position form to ensure that the workplane is in the World 

workspace on the XY plane at coordinate position 0,0,0.  

2. Select Apply to exit the form, then accept the changes by clicking on the Green Checkmark 

icon. 

3. The new workplane will appear in the Workplanes drawer in PowerMILL Explorer. Double-click 

position01 so that it turns bold and a carrot appears to the left of its name. This means that the 

workplane is now the active workplane for downstream operations. 

4. The progress file myProject02 is available as a course resource. 
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CNC Programming Strategy 

Roughing 

Area Clearance Toolpath 
Select the green Toolpath Strategy icon in the top toolbar to launch the Strategy Selector window. In 

the left-hand list select 3D Area Clearance, then select the Model Area Clearance toolpath form the list 

on the right and hit OK. 

 

The Model Area Clearance toolpath form will appear – in the default section set Style to Offset all and 

the Profile and Area Cut direction both to Any. This will ensure that the toolpath is offsetting from both 

the block and the part geometry and is constricted to neither a climb nor a conventional cutting direction. 

Name the toolpath 010rough. 
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Area Clearance - Set Workplane and Block 
Select Workplane in the left menu of the Model Area Clearance toolpath form – the position01 

workplane should already be set since it was set active prior to entering the form.  

Now select Block. This, too, should bring in the block information that was already set. However, we will 

adjust the bottom of the block as a means of preventing the roughing operation from cutting all the way to 

Z 0 (for example, we may be relying on a continuous material base for vacuum holding). Set the Z Min 

Limit to 0.25. 

Area Clearance - Set Tool 
Select Tool from the tree on the left of the form. We will create a cutter for the rough from scratch. Select 

the end mill tool type and name the tool 0.75in_flat. Then select the Pencil button to raise the End mill 

tool form where we can define the tool dimensions. In the Tip tab: 

1. Set Length to 3.0. 

2. Set Diameter to 0.75. 

3. Set Tool number to 1. 

4. Set Number of flutes to 2. 
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In the Shank tab select the Add Shank Component button: 

1. Set Upper and Lower diameters both to 0.75 to match the cutting edge diameter. 

2. Set Length to 2.0 (for a total tool length of 5.0). 

In the Holder tab select the Add Holder Component button: 

1. Set Holder name to myHolder. 
2. Set Upper diameter to 2.0. 

3. Set Lower diameter to 1.5. 

4. Set Length to 2.5. 

5. Set Overhang to 3.5 so that the full cutting length is extended outside of the holder while 

maintaining 1.5 inches of the shank within the holder for good grip. 

Note: Hyperlinked dimensional inputs allow the user to measure parameters directly from the model. 

 

In the Cutting data tab set Coolant to None. We could also set cutter speeds and feeds here so the tool 

has default values but we will do that in the toolpath form instead. Close out the tool form. 
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Return to Model area clearance – now that we know the diameter of our tool we can determine our 

toolpath parameters. Set Stepover and Stepdown both to 0.3. 

Note: The Hand icon signified that the user has manually overridden toolpath form values. 

Area Clearance – Rapid Move Heights and Leads and Links 
Go to Rapid move heights where we can set the Safe Z, the height at which the tool moves rapidly over 

the part and block, to 4.5 (1 inch above the block) and the Start Z, the height at which the tool begins its 

descent into the block, to 3.75 (0.25 inches above the block).  

We can easily visualize the Safe Z by selecting the Front View icon for an orthogonal view and then right-

clicking the tool and selecting Shaded to better visualize the tool. 
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Next go to Leads and links > Lead in where we will set a Ramp entry as our 1st choice entry strategy. 

Select the Ramp options… button: 

1. Set Follow to Toolpath to make the entry XY coordinates match the corresponding cutting XY 

coordinates – a good way to make sure the tool doesn’t travel somewhere unexpected during 

entry. 

2. For Height I use the following rule of thumb to make sure the tool always begins entry prior to 

hitting stock: Stepdown + Thickness + Tolerance = Height. For us this would be 0.3 + 0.05 + 0.01 

= 0.36. 

3. Check Always Ramp if you always want this lead-in strategy. 

 

Area Clearance – Feeds and Speeds 
Go to Feeds and speeds where we will set our feed rates and spindle speeds: 

1. Set Spindle speed to 12000 rpm. 

2. Set Cutting feed rate to 150 in/min. 

3. Set Plunging feed rate to 75 in/min. 

4. Set Coolant to None. 

The progress file myProject03 is available as a course resource. 

Note: Chipload calculations are a good way to get initial speeds/feeds, but it is more of an art than a 

science (in my opinion) and depends on outside factors like your machine’s capabilities. 

Hit the Calculate button at the bottom of the toolpath form to finish, then hit Close to close out the form. 
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Toolpath Simulation 

Safety Status 
The Safety Status is the colored checkmark to the left of any toolpath name. All Safety Status icons need 

to be green to guarantee, limited by the accuracy of your programming, that there are neither collisions 

nor gouging resulting from your tool or tool holder.  

To check the status, activate the toolpath in question and select the Toolpath Verification icon to open 

the corresponding form. It’s recommended to add a Shank and Holder Clearance value that is at least 

as large as the tolerance used to calculate the toolpath, so I will use a value of 0.01 for both. 

Check Against Models for both Collisions (holder in contact with stock) and Gouges (cutter violating 

surface model) by selecting Apply. If no problems are found the Safety Status turns green. Otherwise you 

will want to select Draw Unsafe Moves in the Toolpath Verification Form to further investigate where the 

problem lay. 
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Simulation 
To get all of the toolbars you need for toolpath simulation, right click in the upper toolbar area and select 

Simulation and ViewMill. 

 

Prior to starting the simulation, make sure to set the Z Min Limit back to 0 for an accurate block 

representation and adjust your view to a good vantage point. There are dynamic simulations but high 

quality shaded simulations are static. 

In the ViewMill toolbar, toggle ViewMill On and select the Plain Shaded Image icon. In the Simulation 

toolbar, select toolpath 010rough from the drop-down list and hit the Play button to simulate the rough. 

Back in the ViewMill toolbar, select the No Image icon to return to the model view, or select Exit 

ViewMill to start the simulation all over again. 

 

The progress file myProject04 is available as a course resource. 
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Finishing 

Finishing Toolpath 
Select the green Toolpath Strategy icon in the top toolbar to launch the Strategy Selector window. In 

the left-hand list select Finishing, then select the Optimized Constant Z Finishing toolpath form the list 

on the right and hit OK. 

 

The Optimized Constant Z Finishing toolpath form will appear.  
1. Name the toolpath 010rough.  

2. Verify that the Workplane is set to the active workplane position01. 

Optimized Constant Z - Set Tool 
Select Tool and set the tool type to Ball nosed and name it 0.5in_ball. Then select the Pencil button to 

raise the Ball nosed tool form where we can define the tool dimensions. In the Tip tab: 

1. Set Length to 2.5. 

2. Set Diameter to 0.5. 

3. Set Tool number to 2. 

4. Set Number of flutes to 2. 
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In the Shank tab select the Add Shank Component button: 

3. Set Upper and Lower diameters both to 0.5 to match the cutting edge diameter. 

4. Set Length to 1.5 (for a total tool length of 4.0). 

Now we’ve already made a tool holder so instead of making it all over again from scratch, let’s reference 

it from our previous tool: 

1. Close the Ball nosed tool form, then select the 0.75in_flat tool from the drop-down list within 

the toolpath form. 

2. Select the Pencil icon to edit and go to the Holder tab. 

3. Select the Save Tool Holder icon and name it myHolder.dgk.  

4. Close the 0.75in_flat tool form and go back to 0.5in_ball tool form.  

5. Go to the Holder tab and select the Load Tool Holder icon to load myHolder.dgk.  

6. Set the Overhang to 2.875, leaving 1.25 inches of the shank firmly within the collet.  

7. Close out the tool form. 
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Optimized Constant Z – Adjust Block 
Now that we know the diameter of our ball mill, we can adjust the block accordingly. For a complete finish 

of a three-dimensional part with a ball mill there is often a need for the tool to dip below the base of the 

model by the radius of the tool, necessitating a spoil board or fixture for part elevation.  

Go to Block and set the Z Min Limit to -0.125 to allow the tool to travel this extra depth should it be 

necessary to finish the part. 

Optimized Constant Z Toolpath Parameters 
Go to Optimized constant Z finishing: 

1. Constrain Cut direction to Conventional. 

2. Thickness should be 0.0. 

3. Notice that the Stepover can be controlled by the resultant cusp height. Set the Cusp to 0.3 and 

observe the corresponding change in the Stepover field. 

 

  



PE4997-L - Basic 3-Axis CAM in Delcam PowerMILL 

19 
 

Optimized Constant Z – Rapid Move Heights and Leads and Links 
Go to Leads and links > Lead in:  

1. Set Ramp entry as the 1st choice entry strategy and select the Ramp options… button. 

2. Set Follow to Toolpath. 

3. Reduce Height only slightly to 0.28 as we are directly following a rough and there could still be 

large steps of stock for the tool to run through. 

4. Accept the changes to the Lead In Ramp Options form then go to Leads and links > Links. 

Because we have cleared away much of the stock in the prior operation we no longer need to use 

the Safe height for our rapid moves. 

a. Set Short to On surface to keep the tool from lifting when linking moves between 

toolpaths are under the Short/Long threshold. 

b. Set Long to Skim to keep the tool moving at a relative distance from the part rather than 

always retracting to the Safe height. 

Optimized Constant Z – Feeds and Speeds 
Go to Feeds and speeds where we will set our feed rates and spindle speeds: 

1. Set Spindle speed to 18000 rpm. 

2. Set Cutting feed rate to 200 in/min. 

3. Set Plunging feed rate to 125 in/min. 

4. Lower the Skim feed rate to 500 in/min. 

5. Make sure that Coolant is set to None. 

Hit the Calculate button at the bottom of the toolpath form to finish, then hit Close to close out the form. 
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Adjusting Toolpaths 

Recycling and Cloning 
Looking at our toolpath result you’ll notice certain efficiencies, such as excessive air moves, superfluous 

cutting outside of the part, excessive ramping, and the tool dropping too deeply into part pockets. Let’s 

recalculate with different settings and also try using a boundary. 

      

To edit a toolpath, make it active in PowerMILL Explorer and then right-click on the toolpath title. Then 

select Settings to launch the toolpath form. To edit a form, you can either Recycle or Clone the toolpath 

using the two icons in the upper left hand of the form. 

Let’s clone it so we can compare the two toolpath results. In cloned toolpath 020finish_1, go to 

Optimized constant Z finishing and check Closed offsets and Smoothing.  

Go to Lead In and set Max zig angle to 14.0 and lower the Height to 0.15. Uncheck Always Ramp. 
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Limiting with Boundaries 
Go to Limit and:  

1. Select Boundary type Selected Surfaces Boundary.  

2. Name it 020finish_bound and check Roll Over.  
3. Tolerance and Thickness should match your toolpath settings, 0.002 and 0.0, respectively.  

4. The tool, too, should match, and should be set to 0.5in_ball.  
5. Lastly, select the surfaces to which the toolpath will be bound by right-clicking on the Level part 

and selecting Select All. 
6. Hit Apply to create the boundary. 
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Hit Apply within the toolpath form to recalculate the toolpath – the result should look much cleaner. 

 

Compare results by toggling the Light Bulb (visibility) icon next to the prior toolpath name. You can also 

compare estimated machine time for each toolpath by right-clicking on the toolpath and selecting 

Statistics. We have almost half as many lifts and are saving over 20 minutes! 

 

Note: A typical finish toolpath would have a much finer stepover value but in the interest of saving 

calculation and simulation time we are going with a larger value for this demonstration. 
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Stock Visualization and Analysis 
Simulate 020finish_1 in ViewMill using the Shade Cuts by Toolpath option which uses coloration to 
distinguish which areas of the machined result were affected by which toolpaths. 

 

You can get a better idea of remaining stock on the model using Dynamic Sectioning, available in the 
View menu. Constrain the Axis to Y and check the Front and/or Back Planes to take live section cuts 
through the part. If done while using the ViewMill Dynamic Image option you can rotate the model to 
closely inspect it. 

 

The progress file myProject05 is available as a course resource. myProject06 uses a finer stepover and 

more accurately finishes the part – we will proceed with this latter file. 
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Detailing 
Refer to myProject07 in the course resources to review a detailing strategy consisting of the following 

toolpaths: 

1. Perimeter vertical wall finishing (Constant Z toolpath) 

2. Inside corner detailing (Auto Corner toolpath) 

3. Inside corner center line cut (Pencil toolpath) 

Constant Z Perimeter Finishing 
In the case of our part, any naked edge above Z 0 will be considered a vertical wall, projected in plan 
from a 3 axis approach. Therefore, in order to finish the outer perimeter of the part as well as in the 
interior holes, we can utilize a Constant Z Finishing toolpath constrained by a Selected Surface 
boundary. The key difference to this approach is to modify the boundary such that Trimming is set to 
Keep outside, rather than the Keep inside option we used by default for the Optimized Constant Z 
Finishing toolpath. 
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Auto Corner and Pencil Finishing 
Our part has many curvature discontinuous concavities – this type of inside corner is not particularly well 
suited to the profile of a ball mill, nor easily detectible as minimum radius curvature due to the 
discretization of the model, but if we’re willing to accept an interior fillet to the form we can still approach 
relative verisimilitude to the original surface model. 

The Auto Corner Finishing toolpath limits the cutting of what is typically a smaller diameter tool to only 
those areas of the part which the prior toolpath’s larger cutter could not reach without the need for 
specialized boundaries. 

This is perhaps most easily visible using the Shade Cuts by Toolpath option in ViewMill. 

   

The addition of the Pencil toolpath as the final toolpath in our detailing strategy is arguably unnecessary 
as the auto corner typically includes a pencil path, but depending upon the geometric complexity of the 
part there are moments where it may be necessary to include it. By viewing both toolpaths simultaneously 
we can see some of these moments. 
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And the result! 
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Additional Position Example: The “Flip” Mill 

Set Up 

Importing the Sample Model 
Import the sample model myFlip.igs from C:\dcam\pmill4\cad. It will import with 4 levels – rename them 
in the following order: 

1. pallet_pos1 
2. pallet_pos2 
3. part-w-outboarding 
4. blockBound 

 

Sizing the Block to Selected Geometry 
Turn off visibility for the pallet_pos1 and pallet_pos2 levels and open the Block form. Then window-pick 
the remaining geometry and then select Calculate to size the block. 
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Setting Workplanes from the Block 
To set the position 1 workplane, right-click on Workplanes in PowerMILL Explorer and select Create 
Workplane…, then hit Accept immediately to place a workplane at the default origin. Name this 
workplane pos1. 

To set the position 2 workplane, we will create a workplane from the block. First we will have to adjust the 
block so that its top is defined as the top of the outboarding rather than the top of the true block – this is 
because we want to use a facing operation to ensure that we have a perfectly flat base for the flip. 

Window-pick all the visible geometry and then deselect the top curve on the blockBound level. Open the 
Block form and hit Calculate, then Accept. Right-click on Workplanes in PowerMILL Explorer and 
select Create and Orient Workplane > Workplane Positioned Using Block… 

In order to set the position 2 workplane so that my part is flips about the X axis of a YZ plane centered on 
the left face of my block (post-facing), I’ll select the top left green sphere. 
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The resultant coordinate system is not yet correctly oriented. Rename the new workplane pos2 and then 

right-click on its name and select Workplane Editor… 

In Workplane Editor mode select the Twist about X button and enter 180.0 into the Angle field, then 

Accept. Accept the changes in the Workplane Editor to return to the model. 

 

Importing Tools from a Database 
Raise the Tool Database Search form by selecting the corresponding button in the lower left of the 
screen. No tools will be found initially as we have not set the correct path for our tool database file. Select 
the Tool Database Options button in the bottom right of the form and enter 
C:\dcam\pmill4\tooldatabase\DAAPToolDatabase.mdb, then Accept. Now if you hit Search with no 
filters, 172 tools (the entire library) will appear. 

 

Note: This sample database was generously shared by the University of Cincinnati DAAP Rapid 
Prototyping Center – special thanks to Nick Germann for the creation of this file. 
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Now let’s limit our search: 

1. Enter KOMO into the Search String to limit the results to tools for the Komo router. 
2. Constrain the Type to ball nosed tools. 
3. Set Diameter Min to 0.25 and Diameter Max to 0.5. 
4. Hit Search. 

Now the search results have been limited appropriately, and we can select the following tools to load into 
our project: 

1. V2235 
2. V2265 

Hit Create Tools to load the tools into the project. Now change the search: 

1. Change Type to end mills. 
2. Increase Max Diameter to 0.75. 
3. Decrease Min Diameter to 0.5. 

And load the following end mills: 

1. V1265 
2. V1285 

Now our tools are loaded and ready for use. The progress file myFlip01 is available as a course 

resource. 
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Flip Mill Position 1 Toolpathing Tips 

General Tips 
When using multiple workplanes it’s very important to always be sure that the correct workplane has been 

activated prior to generating a new toolpath – this way the toolpath form will import the proper workplane 

by default. 

It’s also recommended to sort your PowerMILL Explorer assets, such as toolpaths, in separate folders 

based on the machining position by right-clicking on an Explorer item such as Toolpaths and selecting 

Create Folder.  

Component Thickness 
You’ll notice if you try to calculate a toolpath nothing will happen. This is because our pallets, though 

hidden, are still being calculated and are blocking the tool’s ability to reach within the block. You can 

assign machining behaviors to specific geometry groups by selecting the Default Thicknesses icon in 

the upper toolbar. 

With the Thickness Preferences form open to the Surface Defaults tab, turn on the visibility of the pallet 

levels and select the pallet geometry. Set the Machining Mode to Ignore and then click the Acquire 
Selected Components button in the form. Hit Accept and you’ll notice the pallet geometry changes color 

to indicate that it will be ignored by subsequent machining operations. Turn pallet visibility back off and 

recalculate the toolpath  
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When calculating your first toolpath, you will need to select the Component Thickness button within the 

toolpath form and select the Copy Thickness Data from Default button in the Surfaces tab. This 

change should propagate to ensuing toolpaths. 

 

Position 1 Roughing Tips 
While some would only Rough only to the part line, I would suggest roughing as much as possible form 

the first position (so long as there are not tool reach issues) and then rough what remains on the flip, 

while still maintaining a block Z Min Limit of 0.25.  

Lower the block Z Max Limit to prevent unnecessary roughing of the outboarding’s top face as we will get 

this with a facing operation later. 
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Position 1 Finishing Tips 
When created a Selected Surfaces boundary for the finish, we only want to select those surfaces that 

are approachable from the current position. Anytime geometry needs to be further organized apart from 

levels, you can create a Set by right-clicking Levels and Sets in PowerMILL Explorer and selecting 

Create Set. 

Create a set and call it pos1partFinish. Select the upper surface of the part, then right-click on the set 

name pos1partFinish and select Acquire Selected Model Geometry to acquire the geometry into the 

set. 

    

Indexing the Flip 

Facing 
We can face the top of the outboarding (so that position 2 rests on a perfectly flat, machine-calibrated 

face) using the Offset Flat Finishing toolpath and constraining the toolpath by calculating the block with 

only the top outboarding surface and top block boundary curve selected – this way we avoid the need to 

create boundaries. 
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Patterns and Feature Sets 
The imported pallets have pin holes with which we can use to index the flip. To do this properly, we will 

need to drill the corresponding pin holes into the part: 

1. Isolate the visibility of the position 2 pallet and create a new pattern by right-clicking Pattern and 

selecting Create Pattern. Rename the pattern to pos1_drill. 
2. Select the top face of the pallet and right-click on the pos1_drill pattern, then select Insert > 

Model to duplicate the naked edges of the surface. 

 

3. Create a new feature set by right-clicking on Feature Sets in PowerMILL Explorer and selecting 

Create Feature Set. Rename the feature set pos1_drill. 

4. Select the three 0.125 inch radius indexing pin holes in the pattern and right-click the feature set 

pos1_drill again, selecting Create Features. 

5. In the Feature form: 

a. Set Type to Pocket. 
b. Define top by Maximum curve Z. 

c. Define bottom by Depth from top and enter 1.0 into the number field. 

 

Now you have a feature set to specify drill location and depth.  

Note: Drilling not covered in this course. Maybe next year! 
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Flip Mill Position 2 Toolpathing Tips 

Stock Models 
To only rough what remains in position 2 we will need to save the resulting stock model from position 1:  

1. Start by right-clicking on Stock Models in PowerMILL Explorer and selecting Create Stock 
Model, then rename it pos1Result. 

2. Open the Block form and set the dimensions to correctly reflect the actual block size, then right-

click on stock model pos1Result and select Apply > Block. 

3. Activate each toolpath in their proper order and apply them to the stock by right-clicking on stock 

model pos1Result and selecting Apply > Active Toolpath Last. 

4. Right-click again and select Calculate to generate the stock model. 

 

Roughing from a Stock Model 
To calculate the position 2 rough from the stock model, activate the pos2 workplane and create a Model 

Rest Area Clearance toolpath. Select Rest within the toolpath form and: 

1. Set the Rest machining drop-down menu to Stock model. 
2. Set the stock model drop-down menu to pos1Result. 
3. Make sure that Stock Model state is set to the latest state, the pos1_040face toolpath. 

4. Calculate the toolpath and Accept. 

 

Note: From here on out you can complete the toolpathing normally! The progress file myFlip02 is 

available as a course resource. 
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Writing an NC Program 

Position 1 NC Program 
Right-click NC Programs in PowerMILL Explorer and select Create NC Program. In the NC Program 

form: 

1. Set Name to POS1. 

2. Maintain the default Output File path, which will store your NC programs within their 

corresponding project folders. 

3. Apply and Accept. 

Select all toolpaths within the Toolpath pos1 folder and drag them into the POS1 NC Program. Make sure 

that they are in the right order. 

Right-click on the POS1 NC Program and select Settings. Set Output Workplane to pos1. Apply and 

Write the program. 

The program will fail to write! You will need a post-processor configured for your machine for the graphical 

data of PowerMILL to be translated properly into machine code. 

 

The progress file myFlip03 is available as a course resource. 
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